WOL over Internet question

Discussion in 'General Gaming and Hardware Forum' started by Maphusio, Aug 2, 2009.

  1. Maphusio

    Maphusio Sonny, I Watched the Vault Bein' Built!

    Sep 25, 2004
    Say I've been tinkering with WOL. I have all three of my desktop computers able to WOL via the local network; however, when I try from the Internet, I can only get one to work.

    Here is what I have done.

    Added the necessary port forwards on my router


    set up dynamic dns to point to my routers public IP

    Set up my iPhone app "iNet" with the following.

    PC's local address: 192.168.1.XXX
    Subnet: 255.255.255.0 (tried all .255's to no avail)
    PC's NIC MAC address
    Host address (dynamic dns name)
    Port: 5850

    I also took the liberty of disabling Windows firewall on all computers.

    So to recap, using the settings above, I can WOL over the Internet on one of three computers. All PC's can wake via local area WOL.

    What are your thoughts?
     
  2. JayGrey

    JayGrey It Wandered In From the Wastes

    113
    Jun 8, 2009
    Does this mean a bot-net can now turn on your computer while you're away? :lol:

    Well, looking at Wikipedia, I'll ask a foolish question:
    "The computer to be woken is shut down (Sleeping, Hibernating or Soft Off, i.e. ACPI state G1 or G2), with power reserved for the network card, but not disconnected from its power source."
    Do your other two computers support WOL?

    I'll do some searching . . . I never heard of WOL before, but I like the idea.

    A troubleshoot for a similar problem:
    http://thwack.com/forums/t/16151.aspx
    Closer . . .
    http://forums.untangle.com/networking/3987-wake-lan-magic-packet-2.html
    One that won't help at all . . .
    http://weblog.bassq.nl/index.php/wake-on-lan-wake-on-wan/
    From DD-WRT itself . . .
    "Wake On LAN is usually disabled by default in most PCs. This feature, if optional, must be enabled in your BIOS otherwise WOL isn't going to work. Consult your motherboard's manual and BIOS screen (DEL at startup, usually). If you don't see the WakeOn-type options in your BIOS, usually somewhere in Power Management, your motherboard may not support WOL. "
    http://www.dd-wrt.com/wiki/index.php/WOL

    Ignorance is bliss . . . Lies.
     
  3. babadook

    babadook Testament to the ghoul lifespan
    Staff Member Admin Orderite Board Cop oTO

    Apr 2, 2005
    Can you really use the same port for all three?
     
  4. SuAside

    SuAside Testament to the ghoul lifespan
    Admin

    May 27, 2004
    wake on lan is usually discouraged to allow over the internet due to security issues. but i guess you're going for security through obscurity. well, your choice.

    anyhow, port forwarding from the same port to 3 different local ips is usually impossible in routers. you'd basically do replication instead of forwarding which isn't what it's meant for.

    forward 3 distinct outside ports instead and it should work if you can get the WOL software that you're using to work over 3 ports rather than the standard one.
     
  5. Maphusio

    Maphusio Sonny, I Watched the Vault Bein' Built!

    Sep 25, 2004
    Thanks SuAside, I obviously don't know routers and IP as well as I should. I assumed that the portion of the packet containing the MAC would be sufficient to designate what PC to go too. I did not think using the same port would be an issue. Works like a charm now... I'll enjoy harassing my roomies from work while they sleep.
     
  6. SuAside

    SuAside Testament to the ghoul lifespan
    Admin

    May 27, 2004
    the problem you ran into with port forwarding is that a router assigns a port exclusively to a single destination (unless the router is capable of replicating the packets instead of transmitting them, but in this context that would be rather useless and unlikely for a SOHO router).
    imagine asking a question (SYN) and getting 3 simultaneous answers (3 SYN-ACK). you wouldn't know what's going on (moreso because you asking the question can only see one ip replying simultaneously 3 times). regardless of the protocol, you can't negociate a secure connection in this fashion.

    so eventhough you configured 3 destination IPs, the router only sent it to one destination. which is logical, since networking generally requires two way communication and replication would create cross chatter.