Error loading game (Fo2)

Discussion in 'Fallout RPG Gameplay & Tech' started by Kindo, Jan 12, 2004.

  1. Kindo

    Kindo Still Mildly Glowing

    Jun 26, 2003
    Fallout 2

    I try to load a game, and it says "Error Loading" or something. Any 3rd party stuff (such as editors) doesn't work either. I can pinpoint it to when and what is the cause for it.

    In redding, there's a casino. A guard is right inside the metal door that leads to the room where all the juicy scrips and money is. I can't get past him without killing him, and I don't want the town to hate me if I kill him myself.. so I use a couple of TNT and plant it on him, enter the manhole nearby, and POOF..dead guard. I go up, loot the place (RICH!) and then leave. I want to save game first, but it crashes during the save! And it's most likely that crash that makes my game unable to load. It didn't have time to finish the save, so errors loading HP and inventory and other stuff are showing up (because it didn't have time to save that before it crashed), but it still has the actual "save game".

    Now, being the naive loser I am, I don't have any other saveslots or backup saves..so is there some way I can somehow revert back stuff to how it was the last time I saved? Or some way I can "force it" to complete the save or something? I don't have any ideas myself, so I was hoping someone here had.

    Thanks.
     
  2. Kindo

    Kindo Still Mildly Glowing

    Jun 26, 2003
    I'm f**ked, ain't I?

    ::Sigh::

    And things were going so damn good.

    *Sullenly clicks the New Game button*
     
  3. Kindo

    Kindo Still Mildly Glowing

    Jun 26, 2003
    Haha, guess what? I did it again! I started over (pain!) and got to the place I was when my game stopped working before, and this time I promised myself to not go anywhere near that casino loot. I didn't, and I had just cleared out the damn Wanamingo mine (such a tedious quest), and I proceeded to the exit grid for the town. I saved my game, and opened up my inventory editor to change an armor (I wanted a weaker one)..I won't tell you the technical details, but my game doesn't load anymore! It just loads it..and then the screen turns black and nothing else happens. Hahahah! I rock at screwing games up! :D

    So anyway..I'm carefully considering how painful it would be for me to start over once again. Things I would hate to do again for the THIRD TIME IN A ROW: Temple of fucking Trials, Run through rat cave to get the car part in Klamath, Dodge the thieving hellspawn kids in the Den, clear out the goddamn Wanamingo mine...

    *Sigh*.. :(
     
  4. King of Creation

    King of Creation Vault Fossil

    Dec 9, 2003
    You do have the patch installed, right?
     
  5. Kindo

    Kindo Still Mildly Glowing

    Jun 26, 2003
    Of course I have the patch installed. These sort of things keep happening to me because I tend to do questionable things that run high risk of causing some major error in the game file. And as stupid as I am, I never back up save files before fooling around with editors, and I only use one save slot.

    I'm not new to Fallout. I think I've played Fallout 2 about 40-50 times since it came out. ;)
     
  6. Ozrat

    Ozrat Antediluvian as Feck
    Orderite

    Apr 2, 2003
    But the beauty about Fallout is how you can use up all 10 save slots on the same game!

    USE THEM!

    I like giving each save a personal name...

    Ozrat prepped for the fight!

    Things like that.

    Try it!
     
  7. Kindo

    Kindo Still Mildly Glowing

    Jun 26, 2003
    It takes too long to type. I abuse quicksave to the max.
     
  8. Dove

    Dove Half-way Through My Half-life
    Orderite

    Dec 2, 2003
    Maybe using the quicksave so much is causing it?
     
  9. Kindo

    Kindo Still Mildly Glowing

    Jun 26, 2003
    Yeah, I've been careless.

    I just started again, and cheated my ass through the goddamn Wanamingo mines so I'd have that done as soon as possible..and now I'm progressing quite nice, almost catched up with my old game now. This time I make the occasional backup save, though. So no more crappy re-runs for me. :P
     
  10. VaultDweller

    VaultDweller First time out of the vault

    Feb 9, 2004
    I use QS only when I wanna steal. That's very useful- but I save my games in different slots. That helps!
     
  11. The Dude

    The Dude First time out of the vault

    Apr 22, 2003
    So still noone has a solution to this problem? I got it in the Den. Guess the cd is f*cked then.

    I tried another cd and it still gives me the same problem.

    It starts like this:

    I install the game, I unpack the 1.04 patch in the game directory. I unpack the uk.zip in the game directory.

    When I start the game there is no problem. I arrive in the Den with no problem. Do the usual stuff in the West Side of the Den. I go to the East side. Then:

    I go back to the West Side and instead of arriving on the east side of the West Side, I come in from the north side of the West Side like I got there from the world map. Even if I killed Flick, he is back alive now. If I try to load a game in the West Side, the game gives me the error:

    Error: Unable to load game

    Anyone else got this problem?
     
  12. Per

    Per Vault Consort Staff Member Admin

    Apr 1, 2004
    You mean of having resurrected a dead thread and being in the wrong forum at the same time? No, but I think there's a thread in the modding forum on problems with the Den and 1.03/1.04/something.
     
  13. jona0

    jona0 First time out of the vault

    Apr 4, 2003
    Hello!

    I also have massive problems to get this to work on my sh* PC ;-(((
    Either it doesnt start up at all (black screen and then desktop...) or it crashes (randomly?) - mostly in the Klamath canyon, but often also if I change maps in the ratcaves .....
    So I never got any further (on the PC!)

    What can be wrong ?
    (Yes I have the patch 1.02 installed!)
    I have an AMD 1..2 GHZ with 40 GB HD and 512 MB Ram on W98 - anything else ???



    Greetings
    Jona
     
  14. Odin

    Odin Carbon Dated and Proud
    Admin

    Apr 2, 2003
    What kind of installation do you have and do you have the cd in the cdrom drive while playing/starting it up ?
     
  15. The Dude

    The Dude First time out of the vault

    Apr 22, 2003
    @Per
    Don't be a wanker. It is almost as much as a tech issue as a mod issue. This way I didn't need to polute the forum with a new topic and might be able to help the TS to solve his problem. Feb 2004 isn't that old anyway.

    I mailed at enclavemail@wp.pl or something, but the guy doesn't have that email anymore. Hope someone else is able to fix this bug in the 1.04 patch.

    And why is it that my total # of posts are dropping? I went from 250 to this??
     
  16. Per

    Per Vault Consort Staff Member Admin

    Apr 1, 2004
    So you thought it was "almost" appropriate for the core game forum instead of the mod forum? Never mind, I noticed the post I referred to ("Den map probs still, using patch 1.05") is still lingering in the gameplay forum. Maybe Rosh's sticky posting guidelines are obsolete and should be taken down.
     
  17. jona0

    jona0 First time out of the vault

    Apr 4, 2003
    @Odin

    Thanky for your reply!
    I (almost) always make a full install, so I wont need the CD ;-)))

    I even tried the US-exe which was included in one of the mods....
    But it didnt help a bit....

    So I am still stuck with a crashy FO ;-(((



    Greetings
    Jona
     
  18. Todo

    Todo Still Mildly Glowing

    Jun 5, 2004
    Uninstall the game. Then try installing the humongous installation size then apply 1.05 and after the 1.05 update1. If I remember correct, you don't have to update the game with the official updates. 1.05 + update will do.