[FO1] Referenced memory error

Discussion in 'Fallout RPG Gameplay & Tech' started by takar_blackangel, Jul 25, 2009.

  1. takar_blackangel

    takar_blackangel First time out of the vault

    Jul 25, 2009
    Hey guys,

    I've started playing FO1 last week for the first time and I'm having a blast. However, I found quite a problem yesterday.

    I just scouted the military base, reported to the BoS, talked with the elders, stormed the base and entered the first level of the base. The problem is, I encounter this error whenever I begin to fight the mutants in the left part of the level :

    I tried a lot of things,

    *Patch, no patch
    *Using only one core for the game
    *Compatibility mode

    The only thing I haven't tried is to replace the military base file in my save game. I would do so, but it can't be done, since a new character would get brutally slaughtered before even setting foot near the base.

    So, anyone have an idea on how to sort this out? If the replacement of the military base is the only way, could someone send me the file?

    Thanks a lot,

  2. JayGrey

    JayGrey It Wandered In From the Wastes

    Jun 8, 2009
  3. takar_blackangel

    takar_blackangel First time out of the vault

    Jul 25, 2009
    Hehhh, still doesn't work.

    Well, if anyone has another idea, throw it in. I'll try it on Linux tomorrow, just in case.
  4. JayGrey

    JayGrey It Wandered In From the Wastes

    Jun 8, 2009
    This is a long shot I'm pulling from this page,

    "It seems that the problem is caused by corrupted master.dat file. To get around this, you must uninstall the game, delete manually all the files which were left by unistalling (one of those files is that master.dat) and after that install the game again.
    If you do not remove the files manually, then the corrupted master.dat file stays."

    Now, it's for Fallout 2 (most likely with the Children patch, and is for a lack of font being found, but perhaps it is the master.dat file that is corrupted, and when you uninstall/reinstall, the previous master.dat is never actually replaced. I don't know, it's a long shot, by the sound. I get the instruction referenced errors all the time, but they're seemingly random and go away when I restart Fallout . . . I don't know enough to help you. Someone know if there's a way to locate that instruction in the scripts or the executable, maybe using a hex editor? If memory has it, memory locations are essentially random, so only thing to go on would be the specific instruction . . . But then wouldn't that be tied to the machine code of his platform? Go C and dereference a pointer.

    On a side note, did you kill Killian (spell check), as opposed to icing Gizmo? His dog-tags are proto 00000056. More likely a useless bit of triva, then anything. (Source: the Vault wiki)

    A similar question asked here, http://www.gamespot.com/pc/rpg/fallout2/show_msgs.php?topic_id=m-1-44506419&pid=63576 suggests right clicking on the exe and disabling any compatibility mode's that are checked . . .

    Another possible solution: http://www.gog.com/en/forum/Fallout_Series/fallout_1_application_error/perm=2/#p_b_2
    Which involves renaming renaming falloutw.exe.

    This one, http://forums.penny-arcade.com/showthread.php?t=93061&page=26 indicates that it's your poor, innocent harddrive that's at fault . . . "That error sounds like a bad memory address, which could mean that your hard drive is starting to fail."

    . . .

    This reply is brought to you by ADD.
  5. takar_blackangel

    takar_blackangel First time out of the vault

    Jul 25, 2009
    Thanks a lot for your help man :).

    I've tried renaming falloutw.exe, didn't work.
    I removed any compatibility mode, to no avail.

    My hard drive is A1, I've checked it :P.

    Oh, BTW, I've killed Gizmo.

    I'll try the master.dat thingy, after my Linux try. I'll keep you informed.