"Running Fallout 2 Requires the CD!" ???

Discussion in 'Fallout RPG Gameplay & Tech' started by clownthought5, Jul 11, 2018.

  1. clownthought5

    clownthought5 sad individual

    Jul 11, 2018
    Yeahh, so as the title says, I keep getting that error every time I try to play the game. I wasn't able to purchase it on Steam due to gift card issues, so I instead bought it from some game retail store on Amazon. It's a brand new copy and everything.
    I did the humongous install, yes, and tried reinstalling it, restarting my computer. Nothing's worked so far, and I heard there are patches for this but the ones I've tried wouldn't run on my computer either? They were all UK or German, but I think I need something US, given I live here AND the game was shipped from somewhere nearby.
    I'm on a Windows 10 if it helps.
    Thank you so much.
  2. clownthought5

    clownthought5 sad individual

    Jul 11, 2018
    And yes, the disk is in my computer.
  3. Pwener

    Pwener FEV is the equivalent of a chest x-ray.

    Aug 15, 2017
    GOG's versions for both classics are the best in my experience. No nonsense like this happened to me I can tell you that. And isn't the Steam version like designed backwards or something? Don't touch that crap just to be safe.

    Anyway, I'm not saying you should go out and buy the game a second time. Hang in there, a senior member will come around and sort you out I'm sure.

    Edit: Also, welcome to NMA. Come for the bug fixing, stay for the ****posting.
  4. clownthought5

    clownthought5 sad individual

    Jul 11, 2018
    Thank you, I do intend on hanging around here after I get this silly little problem fixed. When I searched for this same problem online I was a bit surprised to see that not many experienced it, apparently? Dunno. Hopefully there's a fix. Thank you again!
  5. saphalline

    saphalline First time out of the vault

    Jul 12, 2018
    Not sure how much experience you have with playing older games on newer versions of Windows, but you didn't mention this so I'll ask:

    Did you run the game as administrator?
  6. clownthought5

    clownthought5 sad individual

    Jul 11, 2018
    Yep-- that was one of the first things I tried sadly. No use.
    I have very little experience in this area if I'm honest, the oldest games I've installed on my computer are like, 2008 era.
  7. Risewild

    Risewild Venerable Relic of the Wastes
    Modder Orderite

    Jun 14, 2014
    If you bought an old hardcopy disk of Fallout 2. Then yes, it is intended to ask for the CD when you start the game.
    Hurrah for DRM of the past!

    There should still exist no-cd's of the game around in some obscure part of the internet... But finding them could mean you have to risk getting malware or other dangers from shady sites.

    I will try to remember a not as dangerous way to fix this. I am pretty sure back in the late 90's I managed to run it without the CD by doing or installing something...

    Try using the Fallout 2 High Resolution Patch.
    Run the patch, and then use "f2_res_Config" to config your graphics to whatever you want to. After that try running Fallout 2 "As Admin" and see if it asks for the CD.

    I think that was one of the ways I used in the past to play CD hardcopy Fallout 1 and 2 before I got them on GOG.com.
    Last edited: Jul 12, 2018
  8. PlanHex

    PlanHex Useless layabout oTO Moderator Orderite

    Nov 4, 2007
    Try checking the config files to see if it is looking in the wrong folder for the dat files. Should be looking where you installed it, not in disc drive.

    Otherwise try doing a manual install. The guide for manual installs should be around here somewhere...
    Last edited: Jul 12, 2018
  9. FDO

    FDO It Wandered In From the Wastes

    Jul 4, 2018
    I also stopped to use my cd versions since I have the games on GOG, but I remember I was using CD images to let my disks at rest. Then installing the FIXT for Fallout 1 was solving the DRM problem, and the Killap unnoficial patch or the restoration project was doing the same for Fallout 2.

    Like Risewild wrote, the high resolution patch might just do the trick as well since it come with a new exe. You can still keep the original resolution with this patch.
    Still, I would say to install the unoficial patch or the RP, since both come fully patched, you don't need to install the official patch before or anything else. You can read on them in the sticky of the modding section to choose which one you prefer.
  10. clownthought5

    clownthought5 sad individual

    Jul 11, 2018
    I was able to run the patch and open the config, however I did notice I had this little error; upload_2018-7-12_10-51-55.png
    and once attempting to open the actual game from the folder it was locating in as an admin, it still gave me that darn CD error. Whoops.
    Considering the patch couldn't apparently find Fallout 2's executable file, maybe the root of the problem does lie in where the file is located , as I have seen others suggest.
    How might I fix this? I'm very bad at technology forgive me, so it's a bit hard for me at times to understand this all and carry out these things successfully.
  11. clownthought5

    clownthought5 sad individual

    Jul 11, 2018
    Oh! Hold on, I tried again and extracted the patch to the exact folder my game was located in and it seems to work now. Thanks a bunch everybody! You were all very helpful :D
  12. Risewild

    Risewild Venerable Relic of the Wastes
    Modder Orderite

    Jun 14, 2014
    Sorry, I forgot to warn you to run it in the game folder. I thought it came with instructions or a readme or something. :confused:

    Anyway, glad you made it work. Have fun playing Fallout 2. :ok: