Fallout 2 mod Unofficial Fo2 patch thread - problems, reports, suggestions

Discussion in 'Fallout General Modding' started by Per, Aug 15, 2007.

  1. Kanhef

    Kanhef Vault Dweller

    Sep 2, 2007
    In NCR, Karl doesn't unlock the cell door when you want to 'talk' to Oswald.

    The turbo plasma rifle costs 5 AP to fire, same as the regular one. Not sure if that's really a bug or trying to keep the game balanced. I really, really want to be able to fire it six times per round (agility 10, fast shot, bonus rate of fire, action boy x2),

    I'm used to games not having a Mac version at all, so not getting the RP wouldn't be too heartbreaking. I certainly don't want you to take any features out of the PC version to have just one to maintain.
  2. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Hmmm. I shall look. I fixed something regarding this a while back.

    No, that isn't what I meant. I was saying that the Mac version would have less features than the PC version. This probably won't be the case though since I can redo how they are done for the Mac version and leave them the way they are for the PC version.
  3. Kissker

    Kissker First time out of the vault

    May 23, 2008
    I just wanna say thanks again for this.

    I see so many patches/mods that are just... well ok to me they are crud. They imbalance the game toward a specific type of player, modding damages or something to that one players preferences instead of overall gameplay, which I hate, and they don't seem very "professional" Feel to them, just someone with time modding.

    Yours however seems like a real restoration (which you were going for ^^) including original content never released and such- and that I love so much.

    Got some personal problems with late-game play, but will have to wait for an appropriate mod to hit for downloading.

    Thanks again for all your hard work!

    Kinda makes me wish I had a map maker to start making some "Lost" vaults neither company ever included, after all there are 102 vaults mentioned, 0-101, and only a handful are ever "in game"
  4. Kanhef

    Kanhef Vault Dweller

    Sep 2, 2007
    When fighting Lo Pan, some of the Shi peasants still move around. Dr. Fung in particular comes running out to watch.

    Skynet tells you to retrieve the cybernetic brain and come back for further instructions. When you do, the terminal just gives you an error message, even if you haven't done anything with the robot yet. I'd expect it to say something about building the robot, perhaps hinting at where the bio med gel and robot motivator can be found.
  5. Maxrunner

    Maxrunner First time out of the vault

    Feb 21, 2008
    Does this patch work with the save's of the old one?

  6. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Yep. And they always will be unless I say so.
  7. Kanhef

    Kanhef Vault Dweller

    Sep 2, 2007
    In San Fran, I got hardened power armor and gave it to Dr. Jing, sending fuel to the Hubologists. When talking to Ken Lee, asking to see the Emperor made him complain that he didn't have any more fuel. Asking for fuel made him give me access to the Emperor.
    After that, Ken Lee wouldn't ask for vertibird plans or want me to kill AHS-9. The Hubologists didn't ask for the plans either, since they'd already gotten the fuel.

    On entering the tanker after re-spleening Chip, he briefly appears at the entrance, then disappears again. I'm guessing his script is still trying to leave.
  8. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Ok, new version up. I decided to go ahead and call this small update 1.02.25 instead of doing a silent update to 1.02.24.

    There are a few new fixes as well as a correction to a bug I had introduced in earlier patches. Timeslip's newest tweaks are also included which fixes quickload that broke as well as fixes the problem with the skilldex button turning black when too many pipboy entries are read. Overall, it is a worthwhile update. Since there was no news post at NMA regarding the 1.02.24 release, I will include the 1.02.24 changes below for those who might have missed it.

    As before, DO NOT install this over the Restoration Project. The upcoming 1.2 release of it will include my latest patch. I just wanted to remind everyone about this even though the installer will now refuse to install the patch if it detects that the Restoration Project is installed.

    Hopefully this will calm some of you until the 1.2 release of the Restoration Project which has been delayed a few days.

    Save games are fully compatible with previous patch versions.


    Windows Installer Version (recommended): download
    Windows Manual Version ("advanced users"): download
    Mac Version: download

    Unofficial patch source files: download

    1.02.25 change log:

    Fixes to bugs introduced in the unofficial patch
    • In Redding, killing all the wanamingos marks clear out the mine as completed. Buying the deed from the mayor sets it to active. So if you kill them before talking to the mayor, the quest gets reactivated and can never be crossed off. 
    • Restored quick load
    New fixes since the May 22 release: 
    • There's a bug in the Gecko reactor control computer script that lets you bypass the access code sequence.
    • Fixed a problem where the cell door to Oswald wouldn't open after saving/reloading the game.
    San Fran:
    • Moved a check in Ken Lee's script which would cause him no longer offer quests if you transfer fuel away from the Shi.
    • Fixed skilldex button from turning black after reading too many entries in the pipboy. Thanks to Timeslip and his tweaks!

    1.02.24 change log

    Fixes to bugs I introduced since the January 5th release: 
    • Error with Bess staying on the map despite you selling her for dry meat.
    • Fixed error message from appearing in message window after killing all the dogs in the protect brahmin quest in Modoc.
    • Fixed an error that would cause Myron's script to crash when not on the stable's map.
    • Fixed issue of there being two Laddies after bringing Johnny back to Modoc.
    • After successfully completing "rustle the brahmin" quest I talked to Duntons at their house and chose the first reply ("Sheesh, calm down...").They both gave me an "error" message, with the only reply choise being "error". This is fixed.
    • Fixed issue of Merk's guards freezing on Carlson's map.
    • Fixed issue of being unable to get sulik as a dumb character.
    • Fixed issue of Frankie asking you to destroy Becky's still despite you having already done so and telling him about this.
    • Fixed crash when entering Trapper town in Klamath.
    • When you complete the deal between the squatters and NCR, a new map is used for the Vault 15 squatter area. This revamped Vault 15 map has a bug, once you set foot on that map you lose your car. This is fixed.
    • Fixed issue with Slim and bartering through dialogue.
    • Removed all inclusions of Restoration Project which caused numerous npcs to give "Error" dialogue lines (Brain, Buckers, etc).
    New fixes since the January 5th release: 
    • The talking head background is the same for party members no matter if you're in the woods, in town, or in the caves. This is no longer the case.
    • When you call the Duntons dumb and ugly they will now attack you.
    • Completion of bartering with the Duntons would result in a blank response screen and an option of done which then takes you to the correct end barter response message from the Duntons. This is no longer the case and the irrelevant blank response has been removed.
    • The door in the north-eastern wall in Flick's room can now be locked/lockpicked like all the other doors.
    • Fixed dialogue bug with Metzger regarding Vic fixing the radio.
    • Hopefully fixed townspeople in the Den from becoming unresponsive when they travel between locations.
    • If you talk to Vic for the first time while stupid, you'll go to the wrong dialogue node. This is no longer the case.
    New Reno:
    • Casino dealers now correctly return to their tables after combat.
    • The talking slot machines in the "Desperado" sometimes give error messages when your character is drunk/drugged. This has been corrected.
    • You can't ask Dr Andrew for healing if you have crippled limbs but full HP. This also goes for Lenny, Dr Fung and some but not all dialogue nodes of Dr Troy. This has been addressed.
    • Party members now use the Adobe background like is used with Lynette.
    • Lynette's node 056 should reasonably have the same stupid options as in 053, so you can get thrown out even if she's angry.
    • Party members now use the Hub background like is used with Harold.
    • All the residents of Gecko now become hostile when you start making a ruckus. Before, only the Brain and his minions would.
    • Using a Doctor's Bag on Bess heals her leg and now correctly makes he get up like if you healed with your doctor skill.
    • Fixed a scripting error with Davin's script regarding sex.
    • Added prevention so it is less likely (hopefully impossible) to set off dynamite during the wedding.
    Broken Hills:
    • The old ghouls will no longer make old ghoul floats in combat.
    • If you anger Skynet (the terminal), then talk to it and ask why you should help it, the message says the door to the room slams shut, but in reality it doesn't. The door now closes.
    • Evil Skynet now kills your entire party rather than just stopping after killing only one party member.
    • Robot eyebots didn't spawn with any weapons. They now spawn with Robo Melee Weapon 1. Robot eyebots at the Enclave used Robo Melee Weapon 2, so this correction seems reasonable.
    • Pressing 0 in dialogue with Buster interferes with his inventory swap. This has been corrected.
    • Telling the Hubologist that you won't kill her for Merk causes you to get the letter quest without any message or explanation. This is no longer the case.
    • Party members now use the Adobe background like is used with Tandi.
    • Fixed a useless skill tag check in the Enlightened One's script.
    • The three inferior Brain Bots are now checked for weapons.
    San Fran:
    • Added prevention so it is no longer possible to set off explosives during the Badger cutscene.
    • Corrected party backgrounds. Underground backgrounds are now Militarybase instead of Junktown. Above ground backgrounds are now Wasteland instead of Militarybase. Junktown is now used at the Gas Station.
    • Corrected dialogue scripting bugs with Murray.
    • Convincing Murray to shut down the reactor, no longer causes him to still say "What's the alarm ringing about?"
    • It is no longer possible to stand on a computer terminal directly northwest of Murray. 
    • Added rockets to a rocketbot in the barracks area. Unlike the other bots, it carried no extras.
    Random Encounters:
    • Fixed bug where trappers would charge you the price of silver geckos when you buy the golden geckos.
    • Cavern maps use cavern lighting outside the cave, not outdoor lighting. This has been corrected.
    • Party members in the Unwashed Villagers and Cafe of Broken Dreams encounters now use the Necropolis background.
    • Fixed team ai issues with Dogmeat.
    • Perhaps fixed NPC apathy bug (Myron, Vic, etc)
    • When stopping your car and not being out of gas, there is no party background defined, so it uses the last one. This has been corrected and the Wasteland background is now used.
    • The original Brain Bot has no EMP protection at all, but it jumps to 500% as soon as it gains a level. It is now protected from the start.
    • Flares cost 0 AP to throw, which is increased to the minimum of 1 whether you aim your throws or not. The cost is now 1 so that aimed throws cost 1 more.
    • Fixed the save/load bug with the bonus move perk. This now works as intended thanks to Timeslip's engine tweaks.
  9. Kanhef

    Kanhef Vault Dweller

    Sep 2, 2007
    Still in 1.02.24:
    Using electronic lockpicks (mk 2, at least probably normal as well) on the doors in the Enclave trap room unlocks them, but also produces the 'that does nothing' message.

    After T-Ray installs the grav plates on the car, the messages "you got the car back without using violence. you gain 750 exp. points" appear.
  10. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Yep, found this. They forgot script_overrides when using items. Using skills on it won't produce that extra message.

    So, this can only happen if you are taking the car for the first time. Some variables seem to reset when you beat the game, so this is probably the result of this.
  11. Jabu

    Jabu It Wandered In From the Wastes

    Mar 5, 2008
    I've been playing through the latest version of the patch, a much less buggy experience, Thanks!

    I've had one or two hiccups though, not certain whether they're patch related or not.

    A few normally non-interactable characters will initiate dialouge when clicked upon, but say nothing more than Error, with you having a selection of choices of saying the same thing. Another time, Brain started talking similar gibberish, and than started acting as if he were Cassidy(?!)

    I got the Vorpal rat special encounter, which was unatainable before the patch, but I can't seem to kill it with the Holy Hand Grenade. Admitedly my Throwing skill is horrible, bet when I do hit it (with the HH Grenade), it takes marginal damage

    From Per's Nearly UF2G
    Am I doing something wrong? As in why doesn't the rat "automatically" die? (Wait, am I supposed to "use" it on the rat, I check back later) Additionally, I did manage to kill it with a critcal shot to the eyes with a normal weapon, I get the special message about it being lifted to the heavens, but no xp. Is that how it was supposed to be, is that a bug, or did you (Killap) think it was too much xp for so little effort?

    Last thing, again not certain if this is the patch's fault. I'm having problems with Myron (who doesn't?). I can only interact with him on the Stables map, anywhere else he doesn't even follow me, just stands still. I can't talk to him. Though Cassidy doesn't forget to taunt him.

    Hope these can be resolved.

    Just want to thank you for all the work with the patch, its now defintely a less frustrating experience.
  12. MrCanon

    MrCanon First time out of the vault

    Jun 1, 2008
    Hey Killap.
    Great work with these patches.

    Small note:
    For some reason, your 1.02.25 Windows Installer Version won't launch. I double click it and it does nothing.

    I had no problem with the 1.02.24 (May 22) installer though.

    Anyway, I used the manual version to patch it, but just wanted to point out this small issue.

  13. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    By latest do you mean 1.02.25?


    You are correct. Sigh, not sure how this slipped through. I am finding a fix for this now.
  14. Jabu

    Jabu It Wandered In From the Wastes

    Mar 5, 2008
    Must have downloaded the wrong file somehow. Never bothered to check. Its actually 1.02.22. I suppose upgrading whilst keeping saved games is not an option?

    Do you think the problems are related to the .22 version?

    If I gotta start over (again) I might try the Restoration mod instead, sounds like its got lots of intersting additions. Thanks for the prompt response.
  15. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Saves are fully compatible with the latest patch. Wait a minute or so until I upload the patch installer again - something was broken in the installer.

    EDIT: New installer up.


    Ok, I fixed the problem and am uploading the new file now. The installer was retarded and that problem should not have happened. Whatever, it is fixed now. Thanks for brining this to my attention btw.
  16. Jabu

    Jabu It Wandered In From the Wastes

    Mar 5, 2008
    Was about to edit my post, I just read the question answered above. I'll duly wait for the installer. EDIT: Installer already up!!! But you think this'll solve Myron's idle behavior?

    EDIT: I should read the update descriptors myself instead of asking. It was the apathy bug. Sorry for the bother.
  17. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    I believe so. If not, let me know.
  18. Grampy Bone Jr.

    Grampy Bone Jr. First time out of the vault

    Jun 1, 2008
    Hi guys! First post. Let me congratulate all you people for this fantastic community! :clap:

    Now, I have a big problem here. Last night I installed Fallout 2. It is a Sold-Out-Software re-release from Amazon.co.uk so I don't know if it is the UK or US version. The box graphics are, however, from the UK version.

    Installed, noticed it was patch 1.01 by default and started playing. Eventually got fucking annoyed at the Toxic Caves elevator being unlockable with Electronic Lock Pick MkII so I decided to forfeit my saves and upgrade to 1.02e UK and then I found this unofficial patch too. So I installed both. First I installed the official 1.02e UK, launched and everything worked fine. Then I downloaded the Killap unofficial patch from the downloads section, installed to default, launched and... boom!

    I get the loading image working and then it crashes back to desktop. I tried several times and that always happens. First time it did I got a balloon tip saying "Not enough physical memory" on my taskbar. Now I'm simply stuck. I want to get back to playing ASAP so do you have any ideas at this point?

    I am running this on my old laptop:
    -Windows XP SP2 with nLite
    -IBM T21 with Pentium 3 750MHz and 128MB PC-133 SDRAM
    -10GB hard drive and S3 Savage graphics.
    -Microsoft wired USB laser mouse
    -Integrated sound

    Absolutely no problems with vanilla installation.

    I also noticed that the edges around the game are now white instead of black. Since my screen cannot display the Fallout 2 680x480 resolution natively, it will show game as a window in a black background. After the unofficial patch, the background turned white, which is quite annoying. Could you please fix that too. Thanks
  19. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Remove the ddraw.dll from the main Fallout 2 directory. Does this do anytihing?
  20. NovaRain

    NovaRain Casual Modder

    Mar 10, 2007
    I got the same problem as Grampy Bone Jr. on my old laptop too. I set OverrideArtCacheSize=0 in ddraw.ini, and the problem solved.
    Maybe overriding the art_chache_size to 1024 for XP (I read this from Timeslip's tweak thread) is not suitable for old spec computers with WinXP?

    My laptop:
    -Windows XP SP2
    -Compaq Presario 2839TC with Pentium4 1.9GHz and 512MB PC-133 SDRAM
    -40GB hard drive and ATI Radeon 7500 Mobility graphic.

    Thank you for all your hard work and the patch, killap. :D