Fallout 2 mod Unofficial Fo2 patch thread - problems, reports, suggestions

Discussion in 'Fallout General Modding' started by Per, Aug 15, 2007.

  1. el_jefe_of_ny

    el_jefe_of_ny Still Mildly Glowing

    Jan 6, 2010
    Bugs after Killap's F2 Patch. Not many!

    Renesco: working him to pay tribute to a mob boss, he then offers to give you his stash for free in 1.02. You just clean out the buffout and all the nice pills and such for free if you will pay the tribute yourself. Of course the value is immense as you are give like 8000 caps worth of pills.

    After patch, just normal price or lil reduced?

    In NCR, after you knock out the brute in the bar, you dont get free drinks like you did in 1.02.

    So, vendor things dont work after patch.

    Also, hitting 0 at NCR gun shop up north, you dont get to see the gause ammo screen. Never shows up at all actually not even randomly like it did in 1.02 without hitting 0.
     
  2. BR4ZIL

    BR4ZIL Still Mildly Glowing

    Feb 22, 2008
    Not bug, you were not supposed to be able to loot all his stuff for free.

    You know you must be stupid to get the drinks right?

    Didint quite get it, Buster (i think thats his name) still have Gauss ammo for sale ,not 100% of the time, but i remember him having in the last time i played.
     
  3. Mr.Wolna

    Mr.Wolna Vault Senior Citizen

    Nov 15, 2007
    I think he is. :lol:


    (just fun^^)
     
  4. el_jefe_of_ny

    el_jefe_of_ny Still Mildly Glowing

    Jan 6, 2010
    how could a bug be in accordance with the story and work flawlessly? You take his drugs instead of the cash. That's the conversation, the tone, and it works. It's a one shot deal. same with alcohol, one shot deal. It doesnt work after the first threat and barter, which also fits the dialogue and story. Also, the NCR alcohol worked prior to killap patch on a 8 intelligence character, 1.02 steam version.

    I can see fixing the 0 thing, but i would imagine that's an easter egg if it were to be legit, but still is questionable.
     
  5. Lord Danath

    Lord Danath It Wandered In From the Wastes

    Jan 14, 2008
    You are not supposed to get his goods for free, only a discount.

    It's in the dialogue with him, he says he'll give you a Discount on his goods not that he will give them to you for free.

    I suggest you read the dialogue more carefully and you'll see what I'm talking about.

    Also if you want killap to notice the "bugs" you post you should do it in the thread of the Unnoficial Patch instead of on another thread.
     
  6. Per

    Per Vault Consort Staff Member Admin

    Apr 1, 2004
    Re: Bugs after Killap's F2 Patch. Not many!

    Hitting 0 probably causes him to use the same bookshelf for his inventory that he used last time. Search the shelf on the right and don't hit 0 to get the 2mm EC stuff.
     
  7. el_jefe_of_ny

    el_jefe_of_ny Still Mildly Glowing

    Jan 6, 2010
    Fighting mutants on 2nd floor of Military Base, after a few rounds, the game is just halted. It looks like combat is taking turns, but nothing is happening. this is the first crash or whatever it might be since installing it a couple of weeks ago.
     
  8. el_jefe_of_ny

    el_jefe_of_ny Still Mildly Glowing

    Jan 6, 2010
    Killed off Hubologists, they just kinda annoyed me and I got both armours hardened anways.

    Well, after leaving their area, went up, killed guards up there, then went to go back to San Francisco/China Town, and crashes each time. going over the green, wont load, black screen freeze.
     
  9. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Too Many Items Bug - Ever heard of it?
     
  10. el_jefe_of_ny

    el_jefe_of_ny Still Mildly Glowing

    Jan 6, 2010
    that is odd. supposedly a fixer for it. hm.
     
  11. daggerhammer

    daggerhammer First time out of the vault

    Feb 17, 2010
    Hi, i'm new here & i was hopeing someone could help me out with a quick question.

    Basically im playing fallout 2 and wanted the patch to fix the Gecko (Bug) & Tandi (Crash) problems. Problem is the official patch dosnt work for windows 7.

    So i installed the the killamp patch but it dosent mention the problems above in the fix list.

    So... can anyone tell me how i can fix these bugs or if killamp does fix them but just dosent mention it?

    Cheers!
     
  12. Dravean

    Dravean Where'd That 6th Toe Come From?

    Mar 6, 2005
    Care to be more specific? What exactly are the "Gecko (bug) & Tandi (Crash)" problems?
     
  13. daggerhammer

    daggerhammer First time out of the vault

    Feb 17, 2010
    Sorry, i'm referring to the bug where you are randomly attacked in Gecko after you fix the power plant & the Tandi problem where the game crashes when you speak to her.

    I just want to know if killamp's patch fixed these problems?
     
  14. Darek

    Darek is currently unavailable

    Jan 7, 2008
    @ daggerhammer,

    The official 1.02 patch is included in killap's unofficial patch.
    The bug fix list only mentions bugs fixed later, if I have understood it correctly.
     
  15. daggerhammer

    daggerhammer First time out of the vault

    Feb 17, 2010
    Excellent! Thanks for clearing that up for me!
     
  16. suicider

    suicider First time out of the vault

    Feb 24, 2010
    Hi!
    Im playing Fallout 2 with the unoff. patch and the restoration project and i get a game crash everytime i try to leave Kalamath on the North-West exit. Errorwindow says:

    "The instruction at 0048d9c4 referenced memory at 00000016
    The memory could not be read from"

    May this be related to the patch/mod or just some corrupted setup data?
    Thanks for help!
     
  17. Darek

    Darek is currently unavailable

    Jan 7, 2008
    @ suicider,

    German version? Probably need to get the blood patch.


    @ killap,

     
  18. suicider

    suicider First time out of the vault

    Feb 24, 2010
    Do you know where i can get a bloodpatch? All I've found where some deadlinks..

    Thanks again!

    ---------Edit----------
    Ok i found one and it works fine!
    Thanks for your help :)
     
  19. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Time for an unofficial patch update! This is a pretty hefty release this time around thanks to Haenlomal, who went through the entire game with a fine tooth comb and found nearly 100 bugs in the original game that were not get fixed by my patch. Big thanks to him for doing this. I didn't think another update would be necessary, but I was wrong. A major highlight of this update is a workaround for the too many items bug and a fix for Cassidy forgetting his combat settings.

    Another big change in this update is that the unofficial patch is now fully compatible with official 1.02 save games! This means that if you happened to start a game with the official 1.02 patch, run into a nasty bug, and want to fix it with my patch, you can now do so and don't have to start over! This of course comes at the cost of causing any previous save games with my unofficial patch to no longer work. I feel it is a worthwhile decision in the end though.

    I also spent time removing any added content that made it's way into the unofficial patch. As this is a bug fix only patch, no additional content should be present. These additions can of course all be found in my Restoration Project.

    As before, DO NOT install this over the Restoration Project, as it already includes my latest patch. I just wanted to remind everyone about this even though the patch installer will refuse to install if it detects that the Restoration Project is already installed.

    Enjoy!


    Windows Installer Version (highly recommended): download
    Windows Manual Version (advanced users): download
    Mac Version: download

    1.02.26 change log:

    Code:
    Fixes to bugs I introduced/Changes to the unofficial patch:
    
    
    • Finally got to the bottom of not being able to repair the emitters on the level 4 force fields. This was a bug I accidentally introduced.
    
    Note: The items below were all added by me at some point early on in the unofficial patch process. They have been removed and are found in the Restoration Project only.
    
    • The conversation about a character's "level" with the Enlightened One has been re-disabled. Now only part of the RP.
    • McGee in New Reno has been removed. Now only part of the RP.
    • Merk car stealing removed element. Now only part of the RP.
    • Removed endings that were added for the Elder, Marcus, President, Harold, and Hubologists, etc. Now only part of the RP.
    • Removed ability to get a happy ending for Vault 13. Now only part of the RP.
    
    Code:
    New Fixes:
    
    
    Redding:
    --------
    • Trying to bring up a detailed description of a citizen of Redding no longer causes "Error" to come up as the description.
    
    
    Vault City:
    -----------
    • Stark will no longer give floats directed towards the player if he cannot see the player.
    • Finally got to the bottom of the door in the Vault City's vault remaining closed, despite having opened it with bare strength/crowbar.
    
    
    Gecko:
    --------
    • Saving your game in the Gecko junkyard no longer causes Lumpy to teleport on game reload.
    • Wandering ghouls on the main Settlement map can no longer wander through the reactor doors into the area beyond it.
    
    
    New Reno:
    ---------
    • Using lockpick on locked doors at the Desperado basement or the second floor of Bishop's casino no longer cause the message "That does nothing." to come up regardless of whether or not you succeed in your lockpicking attempt.
    • Fixed dialogue errors with Majorie Reed when asking about jet.
    • Fixed issue with Stuart Little commenting on special boxing names.
    • You now correctly gain karma by getting the car non-violently from T-Ray rather than getting karma for tricking T-Ray into thinking you are one of Bishop's lieutenants.
    • Before, you did not correctly get experience for getting your car back non-violently from T-Ray until you talk to him again. This is no longer the case.
    • If you managed to fool T-Ray into thinking you are one of Bishop's lieutenants, you may not necessarily get the experience reward for doing so. This has been fixed.
    • If you kill off some of the chop shop boys, but not T-Ray, and then return and manage to get into a conversation with T-Ray without entering combat (i.e. sneak), you can gain experience for recovering the car "without using violence". This has been corrected
    • T-Ray now correctly uses his special warn dialogue lines (rather than the generic ones used in the game) when the player touches his containers.
    • Moved some JHP ammo on the 2nd floor of the Shark Club so that it is no longer blocked from view of the player.
    • Casino girls no longer make their random text floats in red.
    • Casino girls' floats for prizefighters and porn stars are no longer reversed.
    • Made man status is now removed after provoking a family into attacking rather than after returning a hit. This prevents some "interesting scenarios" from playing out.
    • In the end movie cutscenes, the Wrights are said to have violently taken over New Reno using pre-war technology, even if you had that little accident with the virus container in the Sierra Army Depot. This no longer happens.
    • When you are fighting the boxers in the ring, the game refers to them as "Boxer" instead of their actual names (Holyfield, etc). This is fixed.
    • The temporary bonus given by Miss Kitty to NPCs during sex is now correctly applied.
    
    
    Sierra Army Depot:
    ------------------
    • Skynet's combat floats when missing are now correctly about Skynet missing and not the enemy missing.
    • The alarm lights no longer continue to flash after the alarm is deactivated.
    • The security bots on level 4 are no longer activated if you set off the alert on another level and had not previously visited level 4.
    • Fixed several issues with the Munitions Access Terminal on level 2 and the forcefields/shock plates that can be disabled.
    • Disarming landmines and experiencing a critical failure would not cause the landmine to explode. This has been fixed.
    • Fixed a crash when using explosives to destroy a previously destroyed force field emitter.
    • Using a tool to disable a force field emitter now checks your repair skill rather than your science skill
    • Alarm terminals on level 1 and 2 after making Skynet angry no longer display "Error"
    • Fixed issues with the security bots on level 4 related to hiding/unhiding when the alarms are inactive/active
    • Skynet now correctly disables level 4 security (like he does with all the other levels) once he joins you.
    • Disabled robots will now correctly no longer join into battle if their non-disabled comrades attack the player or if the player attacks them directly.
    • If you lower a force field, and exit to another map before it comes back up, then the force field will stay permanently down. This is no longer possible.
    • Corrected some oddities with using the eyeballs on the scanners to the elevators on the various levels.
    • Corrected several issues with the extraction chamber on level 4.
     *Getting xp when no one is in the chamber
     *Getting human brains for non-human subjects (Goris, Dogmeat, etc). Instead no brain is removed.
     *Missing checks for K-9 and Laddie
     *Ability to kill the player
    • Cleaned up security message displayed by the level 2 security terminal. Text was bunched up and displayed a redundant line.
    • Forcefields connected to the Munitions Access Terminal now correctly go disabled after reading the "Penpal Greetings" e-mail.
    • If the player agrees to help Skynet, Skynet will tell the player to retrieve a brain from level 4 and then return for "further instructions". However, if the player does that, then all he or she gets is the message: "Error! Downloading file corrupted." This no longer happens and the correct message now shows up.
    • Getting locked out of the security terminals on level 1 no longer causes this to incorrectly happen on the 2nd level. The reverse was also possible. This has been fixed.
    • Reversed swapped dialogue responses for successful/failed second skill check attempt when hacking the terminal on level 1.
    	
    	
    Broken Hills:
    -------------
    • Fixed a dialogue error with Liz.
    • If you persist in trying to enter the basement without sneaking or killing Liz, you won't be able to enter, but Liz does not warn you off either. This has been addressed.
    • If you free Franc and Manson from the jail, accept the quest from Jacob to blow up the mine, return to Jacob and change your mind, then try to talk to Franc, you can get very broken dialog. This has been fixed.
    • If the player leaves conversation with Dan immediately after it was started, then the next time the player talks to Dan, he'll ask the player whether or not he found his wife, despite the fact that the subject of the missing wife was never brought up. This has been corrected.
    • Dan now correctly gives the promised $500 if the player initially rejects his offer but then reconsiders the decision.
    • Dan now correctly leaves Broken Hills after you persuade him to go. Before he would stay there forever despite saying he is leaving ASAP.
    • Phil the bartender no longer tells you about quests that you've already completed in Broken Hills.
    • Added a script to a door in Marcus' house which leads to his backyard.
    • If you double cross Franc and Manson and toss them back in jail, the jail door remains unlocked. This is no longer the case.
    
    
    NCR:
    ----
    • Offending the Enlightened One no longer causes the dialog to exit without any warning from her.
    • If you kill the Enlightened One having never spoken to Merk before, you no longer get a bonus for "taking care" of her for Merk.
    • "If you proved yourself to Merk by killing Lenny in the ring using the Mutagenic Serum, and then rejected his quest to retrieve Dr. Henry's paper, Merk will be pissed with you, and won't offer you the job again unless you prove yourself once more. However, in the list of options of proving yourself, the option to kill Lenny is still there. If you select this option, and follow the dialog to the end, Merk will try to arrange another fight, which will result in a crash!" This has been addressed.
    • It was possible to get Merk to ask you to complete tasks multiple times (kill Doofus once you've already killed him, retrieve Dr. Henry's papers, etc). This is no longer possible.
    • Killing Doofus for Merk now correctly makes him like you more.
    • Doofus is now correctly labeled as a neutral character rather than an evil one.
    • Trying to repair the terminal before dealing with Officer Jack could result in some broken behavior with Jack and Dorothy. This has been addressed.
    • Fixed issues with killing Jack when he is in jail.
    • Mira now correctly gives you booze on the house for letting Jack blow himself up.
    • Dusty no longer keeps giving you free booze for having beat Hoss up.
    • Dusty now acknowledges you having beat Hoss up if you beat him up so badly that he was rendered unconscious.
    • Your NPC companions no longer walk through the door to the craps dealer.
    • Felix no longer gives you a warning for picking the door to Westin's house if he clearly cannot see you.
    • Felix now correctly warns you if you try to open (not lockpick) the door to Westin's house without permission.
    • NCR peasants in NCR Downtown no longer walk out the gates of NCR, thus rendering them visible yet inaccessible to the player.
    • Time now correctly passes while guarding Westin's brahmin herds.
    • It is no longer possible for Oswald's jail cell to be locked and yet opened.
    • Grant, the gate guard to Westin's ranch, now correctly faces the gate after turning off the force field and returning to his post.
    
    
    Vault 13:
    ---------
    • Gordon now correctly gives you the "talk to Goris" quest.
    • There is no longer a blood patch for Dalia (after the V13 massacre) if you never told her to go to V13.
    
    
    San Fran:
    ------------
    • Fixed various issues with Ken Lee in regards to gaining access to the Emperor and killing AHS-9
    • Some entries in the Chemistry and Physics terminal now correctly advance time after reading them.
    • Chip no longer disappears forever after his spleen has been restored.
    • Corrected Chip's orientation when he returns back to the Tanker after getting a new spleen.
    • Fixed a dialogue issue with Chip and getting Dr. Fung to help for free.
    • Fixed dialogue issues with Suze during and after rescuing her.
    
    
    Enclave:
    --------
    • Corrected issues with the computer terminal at the entrance.
     *If you kill the President and swipe his passkey, but return and activate the Counter Insurgency Protocol before blowing up the reactor (i.e. Frank Horrigan hasn't shown up yet), then the terminal will still claim that it has located a target. This has been addressed.
     *The terminal no longer incorrectly checks your sneak skill when it should have been your science skill
     *Fixed some oddities related to logging in as Smith, J
    • Fixed some minor dialogue errors with Martin and talking about saving your tribe/blowing up the reactor.
    • The Elder no longer gives an incorrect dialogue response when asking her about the effects of FEV.
    • Corrected a dialogue error with Dr. Curling when talking about the player's claim of humanity.	
    • Corrected a dialogue error with the President when taking about releasing the toxin on the world.
    • Corrected a dialogue error when trying to take the President hostage.
    • Corrected issues with the President and the dialogue responses given depending on the type of armor the player is wearing.
    • Blowing up the reactor's controlling terminal now correctly damages K-9, Dogmeat, and other forgotten NPCs.
    • The Elder no longer has the Arroyo background when talking to her at the Enclave.
    
    
    Misc:
    -----
    • A work around is in place for the too many items bug. Hoarders rejoice!
    • Cassidy's combat settings no longer randomly reset!
    
     
  20. Jagermeister

    Jagermeister First time out of the vault

    Apr 1, 2010
    What luck in timing! I stumbled across Fallout 2 an hour or so ago and excitedly loaded the disk in for an install. I haven't played this game in years because I can't seem to run it on my Vista machine. I googled "fallout 2 vista patch" and eventually found this thread. Unfortunately even after installing this 2.0 patch released today (wow!), I still get the error message:

    "This program requires Windows 95 with DirectX 3.0a or later or Windows NT version 4.0 with Service Pack 3 or greater."

    I've been poking around but can't seem to find a fix for this. I should have way beyond DirectX 3.