Current EPA Project

Discussion in 'Fallout General Modding' started by Chris Parks, Jun 18, 2006.

  1. Crowley

    Crowley It Wandered In From the Wastes

    Dec 12, 2003
    I haven't gotten far into EPA yet, but some points I feel are worth mentioning so far:

    When trying to use lockpick skill on locked doors outside no message is displayed.

    Using the introductory pamphlet in the inventory leaves the inventory window open over the dialogue window. It can also block the text and response, making it only possible to exit the dialogue by pressing 1 or 0 on keyboard.

    Some of the descriptions and functions of objects are out of place. The mounds of dirt are graves which you can dig up and they give you the grave digger status. Seems to me that it would be best for digging them up to be disabled. The description of the door entry computer next to the elevator mentions vault door, which is of course nowhere around.

    The elevator is non-functional and described as damaged, so it would be nice if there was some kind of response for using science or repair on it. Just a minor detail.

    edit: Going deeper... Around the big computer on level three there are several green hexes with the letter 'W' in them. When looking at them I get the description that they are walls.

    The exit grid which leads to the warehouse outside is red while it should be green. Same for the grid leading away from it. I could also walk on parts of the exit grid at the warehouse without leaving the map. Seems like roughly the lower right half is like that.
  2. Chris Parks

    Chris Parks Vault Senior Citizen

    Jun 10, 2006
    Right, I've just had a look at these problems, Crowley.

    No message is displayed on the doors as this is how they are scripted. At the time, I didn't know much about doors... and thescripts were huge so I built my own. They can't be lockpicked which forces you to actually go into EPA and get the keys. It seemed daft if you visited late game with high skills and could loot the place without ever going in!

    Not sure exactly what the problem is with the pamphlets. Simple solution is not to use it in inventory.

    The door entry computer has been altered accordingly as have the gravesites.

    The elevator is supposed to be non-functional as detailed in the design documents. I will add some sort of message on use of skills though...

    Oops! I can't believe that one! I must have left the Toggle Block Object View on when it was saved. There not supposed to show.

    As for the exit grids, I had some real trouble getting them to work properly but they should do now.

    Thanks for the time flagging these faults to me. I'll alter all the problems in update 1.
  3. Crowley

    Crowley It Wandered In From the Wastes

    Dec 12, 2003
    Browsing around the files I was wondering why you didn't use the Fallout Tactics graphics for the gauss gatling?

    I'm not sure if it happened as a result of this mod, but for some reason the car in Den has disappeared except for the trunk. Searching the forums I couldn't find any mention of that happening, only the trunk disappearing. Never happened to me before...

    edit: Back to the EPA itself. The spore plants seem to be unable to shoot spikes. Is this intentional?

    In the poison-filled areas it would be good to have some message about the place being filled with poison gas. The room on the second floor with the wasps/fruit flies also lacks the fumes found in other such places.

    Any chance of making the power armors protect you from the gas as well? Since the environmental armor seems to be introduced by the mod, that should work as well. And vice versa, would it be possible to have the gas mask help in the Broken Hills mine? I suppose that might fall under the general expansion project, though.

    more edit: Car issue fixed now, but something else has turned up. In Klamath I get "error saving objects in kladwtwn.sav" when trying to leave the downtown map for the second time. Sometimes the message is accompanied with a crash, sometimes there's a crash without a message. Only happens with the EPA mod installed.
  4. Private Dobbs

    Private Dobbs First time out of the vault

    Jan 24, 2006
    Somone fill me in on how to install this mod please?
  5. nny_ix

    nny_ix First time out of the vault

    Aug 30, 2006
    ok, I got it to work and I was cruisin it, the fruit flies have an excellent death animation by the way. I can't seem to get anywhere, I guess my Science just isn't high enough, it is kinda confusing though when you think they way to the doctor's lab is an exit grid. I also noticed the pamphlet problem, I didn't know you could get out of it by pressing 0 or 1 but I guess knowing that is well enough.
    As for installation you'll wanna copy all the files from the EPA MOD folder into your Data folder, then Rename Patch000.dat to Patch000.000 or something like that then run the game and start a new game or you could always get FAME and put Patch000.dat in the patches folder that way it's there when you wanna run the patched game.
  6. Crowley

    Crowley It Wandered In From the Wastes

    Dec 12, 2003
    Oh yes, I should've mentioned to begin with that I am trying to run this with Killap's patch. Guess that is the source of my problems.

    edit: Okay, some more things... There is a room at the left side of level four with NINE lockers, all of them empty. That spot just screams for some content.

    Seems like the gas mask only works only if it is the currently active item. Having it in the off hand doesn't do anything. A bit too cruel since you do need to fight in poison-filled areas. Sunglasses do give the charisma bonus no matter which hand they are in...

    A typo in the warehouse doctor's dialogue when he asks you to get some raw materials:
    Seems like there is no spot set for the car to appear if you arrive at the EPA driving it. A big no-no in my book.
  7. Private Dobbs

    Private Dobbs First time out of the vault

    Jan 24, 2006
    I got it working now. You should probably pair this with the city limit patch. thankfully i had read this thread to find out it wouldn't work without it.

    I'm not that far into it yet, some things i spotted.

    The initial area i have had alot of trouble with mouse scrolling. somtimes it just doesn't want to scroll.

    when walking near the north end of the gray building there's some texture issues, and inside of it a generator can be seen thru the window, but i don't see it when i'm inside.

    there are a few typos in the computer interface, i can go back and get you more detail if you like.

    Same thing in the Dr.'s texts. like the one in the post above me here. Again, i can go back and find you some detail about what they are.

    Also the mini map when leaving and coming back. nothing has names on it.

    great mod so far.
  8. Running Doe

    Running Doe First time out of the vault

    Jul 16, 2006
    EPA How in gods creation do I get in?

    I have wandered all over the EPA map and I cannot find a single keycard or entrance that will allow me to leave the bloody map to another level. I have even dug up every bloody grave hoping to find something in them that may have helped me but they are all empty.... I am out of ideas. Would anyone be able to help me?
  9. Chris Parks

    Chris Parks Vault Senior Citizen

    Jun 10, 2006
    Hi guys,

    I'll take another look at the gas mask issue... It is coded to work in both of the slots, not just the active one. I'll also code the armour to protect people as well.

    As for the car, have you tried driving it to the EPA yet? The car is coded to work in the EPA and after thorough testing, I had no problems.

    Sorry about the generator issues! I'll sort those out.

    I don't know what the problem is with the minimap. Is anyone else having this problem? My minimap works fine and they all have place names. Did you mean the town map? That one doesn't have labels yet.

    To running doe...

    Try the vent on the bottom of the map outside the walled section.
  10. Crowley

    Crowley It Wandered In From the Wastes

    Dec 12, 2003
    There's an air vent outside the walls. The exit grid in the southeast corner also takes you into another area.

    Chris, maybe you should provide a walkthrough for the EPA in order to allow for testing it more smoothly. Possibly it is way too linear or obscure as it currently is. I got the information about what is wrong with the holograms from a computer, and located the hologram generator. However, I can't seem to do anything about it. I try using repair and science on the generator and that big computer next to it, but nothing happens. Similar thing for the light generator. I get the message "Maybe you could do something to repair it", but using repair does nothing. In the very least you should get a hint about what is wrong with the machine.

    edit: I guess then it is a conflict with Killap's patch that is causing many of my problems. Really should try without it.
  11. Chris Parks

    Chris Parks Vault Senior Citizen

    Jun 10, 2006
    No problem, I'll include a mini walkthrough when I release update One, which should be around the middle of this month.

    Just a few quick notes now if anybody is stuck. The Hologram's memories are being wiped by an magnetic field,which is caused by the computers in the room next door. Try those and see what happens.

    Also, science and speech and repair are so important in the EPA.

    As for the lights, look in the Doctors warehouse. There's loads of junk lying around in piles. Mabye those parts will help with fixing it.

    As for the mod, I have a list of about twenty minor things that I'm updating and changing. I've also altered the pamphlets so they won't work in the inventory.
  12. Crowley

    Crowley It Wandered In From the Wastes

    Dec 12, 2003
    Okay, now that I have a cleaner install I can be more helpful. The disappearing car was caused by some conflict with Killap's patch. Moving on to real problems. The off-hand gas mask still doesn't protect you. By the way, I have to commend you on finally making poison antidotes useful!

    Now that I fixed the holograms and spoke to them, one commended me on taking care of the plants and said he'd give me a key to storerooms on level one. However, there are no such things there. I guess he was supposed to say surface or ground level or something like that. A hologram physically giving you a key somewhat conflicts with the mentions that holograms cannot do physically anything themselves. Maybe you could add a mention of a drawer sliding open from the table with the key there or something.

    All the mentions the holograms make about unresponsive robots seem like they would warrant there actually being robots around other than the just the single depressed Mr. Handy. I'd say that it would be more interesting and give a better picture of a chaotic decay to have robots in different conditions. Some as "corpses" on the floor, some stuck in the recharge stations. Some could initiate combat with you, while others could fight alongside you against the animals. Maybe some just wander around aimlessly. Easy for me to say of course since I don't know how hard that would be to implement.

    There's another idea. Why not have a few more critters that have managed to enter the EPA? Going on about combat, I noticed that at least the mantis and scorpions you encounter in the ventilation ducts are a weaker variation of the critters. Considering the location of the EPA I think you could safely put stronger variations there.

    One final thought for now concerns the elevator 'interface'. I seem to remember that there was a four-floor elevator somewhere in the game that had that control panel with buttons and the animater pointer. Could that be implemented? Hard to remember where it was... maybe Sierra Army Depot or the Enclave oil rig.

    edit: Comments just keep on pouring in. I've noticed that where you need to use science or repair on something, in addition to getting the specific message you also get the standard message ("You fail to learn anything", "You can't repair that") in addition to it.

    On the third level in the room with the faulty hologram you can repair the computer using science, not repair.

    One very small idea: I think it would fit better if there was a ladder leading up from the ventilation ducts instead of a rope.

    more edit: Seems like I have more or less completed the whole EPA. Still couldn't find the gauss gatling, though. The Blue Level was quite a letdown. Not much to be found there. That line of lockers was a bit too much. Especially considering how little there actually is in there, I think it would be good to remove about half of them. Currently you can also walk through them.

    When you get a quest in the EPA, the message window displays "QUEST: <description>". The quests also are greatly lacking in experience rewards from completing them. When I bring the gecko pelts to the doctor, seems like they are not actually removed from my inventory. After finally completing all his quests, you can get the dialogue for getting the agility upgrade over and over.

    After getting the door code from the PR hologram, I can't use it on the locked doors on the east side of level four, though all other code-locked doors work fine.

    On the east side of level two there's a room at the north end with a Mona Lisa painting. Going to the north corner there most of the level gets blocked out as if covered by roof.

    Actually getting better lighting by fixing the generator is somehow glitchy for me. I managed to do it once when I tried using the parts before repair. In that case using repair brought up the lights, but when I used the parts they were dimmed again.

    I can't help wondering why there are Brotherhood armors in the EPA? At least the combat armor could be swapped for an ordinary one. Not so sure about what to do with the power armor. Maybe remove it completely. I'm having trouble seeing what it adds to the game anyway. The EPA is fairly close to other places where you can get power armors, and on the other hand it could be considered a location where you can get one too early. Finally, this is just a subjective opinion, but I think the solar scorcher deserves to be somewhere more special than just a storeroom in the middle of much more mundane stuff.

    last edit for now, I hope: The blue level follows a dark-light cycle as if it were outside. I tried stealing from the Doctor, only to find out I couldn't. After killing him I was unable to loot the body.
  13. Chris Parks

    Chris Parks Vault Senior Citizen

    Jun 10, 2006
    Thanks for those, I'll add them to the list.

    A few things there bothered me...

    The Doctor seems to have the wrong script. My version works all right, but the one in the mod doesn't work. He gives you the GGG from his inventory when all the quests are done and completed. (hence why you can't steal from him) Also, will adapt his script to clear up other faults.

    The PR Hologram is also a puzzler. I'll look into that further, as well as the generator issue.

    As for the mod, I've now added labels to the town map screen and have begun correcting the faults. Some things have just been altered for general cleanliness.
  14. Skynet

    Skynet Mildly Dipped

    Jun 5, 2003
    BTW, I looked the toaster msg file and my opinion is that there aren't any "possible copyright conflicts" in it. Sure there are some refences, but not clear enough to make any fuss. So I'd restore the toaster's script.
  15. Crowley

    Crowley It Wandered In From the Wastes

    Dec 12, 2003
    There must be a better way to do that. NPCs all over the game reward you with items they aren't physically carrying beforehand. Since nonlinearity is a major aspect of Fallout, I'd prefer the Doctor whipping out the GGG from thin air as opposed to disabling stealing and looting as they are extremely artificial limitations. The player can pretend he has it hidden away somewhere and only readies it when you're about to receive it or something.

    I haven't looked over those files myself, but I was wondering from the beginning about those copyright conflicts. The Fallout games contain plenty of small things borrowed from a variety of sources, and Interplay wasn't sued for infringing upon Monty Python or From Dusk till Dawn. Heck, directly lifting graphics from Fallout Tactics is probably a bigger copyright infringement.
  16. Chris Parks

    Chris Parks Vault Senior Citizen

    Jun 10, 2006
    Yeah, I see what you mean. I don't know much about game copyright issues, so I left it out. I know more about manuscript copyrights! I'll add it back in when I release the update.

    As for the Doctor, I'm working on his script again. Many of the things that need to be done with the game are easy but just tedious.

    Also added some deathclaws, aliens, floaters etc. to make it a little bit harder to get into.
  17. Oracle

    Oracle Water Chip? Been There, Done That

    May 19, 2003
    isn't there anything about the enemies that where supossed to be in the EPA in the bibles ?
  18. Chris Parks

    Chris Parks Vault Senior Citizen

    Jun 10, 2006

    I'm not sure what you mean by the enemies. I stuck to the design documents as rigidly as I could but the EPA was more or less deserted aside from the metion of plants, ants and a few manti. I've added these after posts saying it was too easy to enter.
  19. Crowley

    Crowley It Wandered In From the Wastes

    Dec 12, 2003
    What about the security robots? There are severa indirect mentions in the design documents, and plenty of recharge stations in the maps you've made. Out-of-ammo turrets are also mentioned. Thinking about the EPA, I think it might make more sense to have a few robots patrolling the main hallways while the critters are limited to some secluded spots, such as the poisonous storages. On another note, that terrarium on the east side of level four would seem like a prime spot for some deathclaws.

    I recently had an interesting idea regarding the robots: what if all the security robots simply disappear from the maps once you help the security hologram? If they were hostile, it would help the player, and the hologram apparently sending all the robots away would give a nice sinister feeling of puzzlement, I'd think. Simply making the robots stand down peacefully would be contrary to the hologram's personality.

    Going back to the design document there was a mention of setting the Doctor's experiments loose on him. However, currently you can't do anything about the force field generators in the EPA. You might take a look at making it possible to disable them with repair or explosives (like in the military base in Fallout 1) or adding a (hackable) computer to control the force fields.

    Any possibility of adding those colored stripes on the walls the design document mentions? I don't think it would be such a big project at least graphically, though I have no idea how hard it is to actually add new map graphics to the game. You could also maybe add descriptions of the levels to other places than just that one computer on the surface. Maybe a readable board next to each elevator explaining the areas you can reach with it.

    Talking about elevators, I notice you've used the elevator doors in some places to connect rooms. They are still described as elevator doors.

    I also have a couple of suggestions about the ventilation duct area. I had a hard time figuring out how to proceed from there until I remembered the design documents and thought of using that duct at the other end of the map. You might want to add some messages to make this area clearer to the player, such as something like "It looks like you might be able to squeeze through that duct." when approaching the grille. I checked the mapper, and I wonder why you didn't use scenery object #810 there? It matches up to the grille on the other side much better.

    edit: Playing around with the mapper I see you've added red puddles of chemicals. I don't recall them being used anywhere. It would be good to use them instead of the green stuff in the poisonous areas in order to not make the player think it's just a radiation hazard there. Another idea I had was to make new objects by altering existing ones slightly so you'd have barrels with biohazard sign instead of radiation. One final thing worth adding would be a message that it is in fact gas that's causing the poisoning, I think. Having it appear every time you get poisoned would be too much, though. Just when you are at the entrance give something like "There is an odd smell in the air here that burns your lungs with each breath." Oh yes, I just remembered that the poison room on level two doesn't have any steam in the air. That would be another nice touch.

    more edit: What is this? There is a floater at the corner of one of the Doctor's cells called "test (don't use)". The critters in the cells are odd in other ways as well. I can shoot through the force fields, but seems like I don't get any experience for the kills.
  20. Oracle

    Oracle Water Chip? Been There, Done That

    May 19, 2003
    I know but maybe it was intended to get in easy. You already metioned the you needed high a science skill to get the rewards. So its more about your skills then the enemies. Maybe the EPA should be an hidden location like the Sierra Army Depot to make it harder to enter.