Fallout 2 Restoration Project 1.1 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Jan 13, 2008.

Thread Status:
Not open for further replies.
  1. d3st

    d3st First time out of the vault

    2
    Jan 25, 2008
    Hi, thanks for the great work, I love it so far

    I have two major problems

    1.) Wiping out the slaver camp ranger quest:
    At the begining of the game after I finished Klamath and Den I immediately headed to the camp.
    Planted some explosives, blowed up the leader and some of them then shoot down the rest of the gang.
    I freed Sulik's sister and all the other captives.
    Few weeks later I also killed Metzger in the Den.

    Many months later I got to NCR where I got this task from the ranger girl to wipe out that camp. I was surprised since I already killed them off and freed the slaves.
    I told her to give me some fellow rangers. We arrived to the camp and nothing happened. The rangers just stood there, the camp was in that state I left it.
    I headed back to NCR. The quest was incomplete and I got the 'Please don't delay too long blabla' message from the questgiver.

    2.) I just can't get to the Ghost Farm:
    I have tried every dialogue options in Modoc and Den but it won't appear on the map.
    I have finished every quest in Modoc and Den. Do I have to show Laddie Jonny's BB Gun? Because I sold that one somewhere :P
     
  2. tomten

    tomten It Wandered In From the Wastes

    164
    Jan 6, 2008
    I used wget -r to download all the fixes, so I've installed this one too. I don't feel like re-installing the Expansion just to get the correct file (the one installed by the Expansion, right?); could someone please mail it to dcprosti@mailinator.com?
     
  3. Glovz

    Glovz Vault Dweller
    Modder

    735
    Sep 16, 2005
    Any critter/NPC might run if hit and damaged/hurt to a point where the AI recognizes another hit will kill the critter/NPC. If this happens (not always guaranteed) then the critter/NPC will not fight again until healed.

    This is just based on observation but I believe it also may have been discussed in the forum somewhere before.
     
  4. Glovz

    Glovz Vault Dweller
    Modder

    735
    Sep 16, 2005
    Take this to the [Fallout 2 Restoration Project Discussion (ideas/suggestions)] thread. Stop poluting this thread.
     
  5. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    About the dcprosti.int file.

    This is indeed for the prostitute at the Den Residential area during Tyler's party. There is NO reason why it would cause crashes with the verti papers. NO reason. I think your implementation of the scientific method is flawed. :wink: Seriously though, there just isn't any reason; the scripts are from two separate locations.
     
  6. agris

    agris Still Mildly Glowing

    245
    Jul 8, 2004
    I bet you're right Killap, it's either ddraw or the modified exe giving people the problems. For what it's worth, I'm up to level 15 and haven't crashed once (inspiron 1405 xp sp2 pro).

    Minor Bugs:
    -Broken Hills
    Female caravan guard infront of door to Chad / Bill is 'Error' in dialogue & inspection
    Entering Chad's house: "Carefully undoor the locking mechanism.."
     
  7. tomten

    tomten It Wandered In From the Wastes

    164
    Jan 6, 2008
    Hm, why does everyone post their computer manufacturer and Windows service pack revision instead of the stuff that actually matters? The only things so far that have been seen to make a difference are:
    1. Is your FO2 English (no ==> bad)
    2. Is your FO2 pre-patched above 1.0 (yes ==> bad)
    3. Did you install anything whatsoever before the Expansion (yes ==> bad)
    4. Did you install any optional mods with the Expansion (yes ==> bad)
     
  8. Ignaz

    Ignaz First time out of the vault

    1
    Jan 25, 2008
    hi there, you've done really good work. but i have a problem, i can't enter the military base. i blowed up the rocks but if want to enter the base itself the game crashes.
    Can someone please help me to fix the problem?
     
  9. Crowley

    Crowley It Wandered In From the Wastes

    180
    Dec 12, 2003
    That's one of the oddities here. He never makes any attempt to fight anyone. He just starts running right away like a jet addict who is caught in the crossfire. The only change I did to my game between this playthrough and the previous one is I installed all of killap's fixes before the second one.
     
  10. gregor_y

    gregor_y Where'd That 6th Toe Come From?

    405
    Jan 19, 2007
    Well cheak for your self i can even provide savegame im 99% sure this file makes crash when i want to give virtbidplans back to bos...

    No idea why your the modder but it realy makes this crash :)

    Any way i will send good file to tomten so he can cheak...

    @tomten i sended you this file replay if it helps...

    Look whos talking you polluted this thread more than me with stupid quoting and trying to be smart ass Killap is modderator and i moved my post my self to right section so buzz off...
     
  11. Grimhound

    Grimhound Still Mildly Glowing

    235
    Jan 22, 2008
    ERROR REPORT: Getting into encounters near the Primitive Village leaves me, once the encounter is over, over near The Den, or at other random map locations.
     
  12. tomten

    tomten It Wandered In From the Wastes

    164
    Jan 6, 2008
    Re: Minimal Install

    Wow, this sounds weird. Does anyone else have this experience? I have no crashes, so it wouldn't matter to me.

    This sounds alot like the report from Grimhound just above, even though Kaga wasn't involved there (right?).

    Are we supposed to install it or not? It's not in your official list, but it's in the fixes directory and has the same timestamp as all the other fixes... =]
     
  13. RainDaemon

    RainDaemon First time out of the vault

    3
    Jan 26, 2008
    Damned car bug...

    Hey everybody.
    Thanks to killap for this fantastic mod. i Will admit that this is the first mod i have tried for fallout 2.

    i'm Also experiencing this car bug that people are talking about.
    At a certain part of the game, the trunk becomes an item that your character can pick up (in some ways it behaves like bags did in fallout 1), i noticed it when my character complained that it was to heavy when i tried to access it (since i had less that 10lb left in carry weight)
    if there is enough available carry weight to pick it up, it gets added to your inventory as a blank and crashes the game with the "Error!: partyMemberPrepItemSaveAll: Can't find script!" error window if you try using the car while the trunk is in your inventory.

    i Tried playing around with some of my older saves and it seems the bug kicks in when i encounter Kaga after obtaining the car. If during the ensuing combat, i knock him out (and loot his passed-out ass) and reduce his health to the point where he runs off while he's still prone, the car becomes buggy. (Its fine if i don't knock him out or if he recovers before he chickens out)

    i Can make some of my savegames available if anybody wants to try them out.

    i Am using a humungous install with the latest official fallout patch and version 1.1 of the restoration project. i Also started a brand new character.

    i'm Gonna write bethsoft and ask them to add a new perk to FO3 called 'Buggy car' - 'No matter what vehicle you find in the wasteland, its bound to be a piece of sh*t.' :P
     
  14. Zaius238

    Zaius238 Sunburn

    147
    Jul 14, 2007
    Killap, your expansion change something in the Char screen?

    Because i found a bug in Expansion never happened in Fallout 2 v1.0:

    When i enter in char screen and click in the "Print" button, to copy the information of my player, the game crash imediately.



    Please fix this? :D
     
  15. gregor_y

    gregor_y Where'd That 6th Toe Come From?

    405
    Jan 19, 2007
    Um i think you got new karma title Virgin of the Wastes but my game has stoped crashing so im sure its not it...Fixes helped :)
     
  16. Norfrit

    Norfrit First time out of the vault

    3
    Jan 26, 2008
    Hi there. So - I got problem with this mod.
    I did clean, new install of fallout2 (english, 1.0). After that I applied patch (without additional mods) and it simply doesnt run. Screen turns black for a moment and then it returns to desktop. One time it showed first load screen but it still didnt work. Havent seen that someone else had problem like this too.

    Info - Windows XP x64, AMD64 x2 4800+, 2gb ram. (if that means anything)

    I also tried original fallout2 before patch - it runned well.
     
  17. gregor_y

    gregor_y Where'd That 6th Toe Come From?

    405
    Jan 19, 2007
    Dont install any patches only Resurection Project 1.1...
     
  18. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Did you grab the latest fixes from the first page of this thread? specifically the exe fixes.

    Also, though you cannot seem to even get to the main menu, this info was posted and seems to help people with dual/quad cores.

    Interesting. If you could send me a save game that would be cool.

    Hmm, this was reported before. I personally never use the print button, so it doesn't bother me. However, I just tested and I too get this crash. Though I could swear people reported this type of crashing before the expansion (ie when using my patch) I really don't know what could cause it. Still, though the game crashes, the character files saves correctly. Just go to Fallout2/data and look for a text file. It creates the file, but crashes when returning back to the game...
     
  19. Norfrit

    Norfrit First time out of the vault

    3
    Jan 26, 2008
    Well with patch I actually meant only restoration one :)
    And yeah, I readed about that dualcore fix (helps when dualcore timing fix doesnt) but it isn't really an option right now because process crashes instantly.
    I did apply small fixes, too.
     
  20. Jaesun

    Jaesun First time out of the vault

    57
    Jul 12, 2005
    Re: Damned car bug...

    Maybe because you installed the path AND THEN installed the Restoration Project (which includes the patch) may be causing your problem?
     
Thread Status:
Not open for further replies.