Fallout 2 Restoration Project 1.1 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Jan 13, 2008.

Thread Status:
Not open for further replies.
  1. agris

    agris Still Mildly Glowing

    245
    Jul 8, 2004
    It's the first printing english release (1.0) definitely not pre-patched. i did quick goris and b-team
     
  2. Crowley

    Crowley It Wandered In From the Wastes

    180
    Dec 12, 2003
    Odd bugs seem to keep cropping up. I have encountered the bug where quest items were not properly removed from you. It seems to affect only some. Before Modoc everything went fine. Jonny's BB gun and Cornelius' gold watch remained with me, as did the bottles of booze and beer for Vault City. On the other hand, Mr. Nixon and fake citizenship papers have been taken out of my hands. I vaguely remember this bug appearing quite some time ago with a different game version.

    Speaking of the fake papers, is it intentional that the Vault City gate guards no longer consider you a citizen if you buy a fake citizenship from Skeev, get inside once with it, and then turn him in?

    And these days I am working with a fresh install of the game with no patches other than killap's.

    edit: Okay, I searched for it and the bug with the quest items is related to having a container above them in your inventory, in this case the bag from Modoc. I'll arrange my inventory accordingly.
     
  3. Torniojaws

    Torniojaws First time out of the vault

    2
    Jan 27, 2008
    The game freezes every time I try to return the Vertibird plans to the BoS guy. I've got a savegame from that situation too: http://koti.mbnet.fi/juhau/save.rar Once you load it, just walk to the BoS guy and tell him you've got the plans, and *bam* the game freezes every time.

    I only have the v1.1 Restoration patch installed to a clean humongous installation with all the extra mods of v1.1 RP in it. Game version is English non-children prepatched v1.02d.
     
  4. laclongquan

    laclongquan Boned Hunter of Sister

    421
    Jan 11, 2008
    The bug that make you keep quest items (not lose through dialog use) is a known bug with Fallout 2, and 1 too. As long as you got the Bag in your inventory, it strangely affect quest items up(or down) from it. Still cant fix it in all the mods, last time I checked.

    It's a dear to packrats and item collectors :lol:
     
  5. Norfrit

    Norfrit First time out of the vault

    3
    Jan 26, 2008
    Everything is good for me but F2 still wont launch :(
     
  6. Cubik2k

    Cubik2k Where'd That 6th Toe Come From?
    Modder

    489
    Nov 22, 2005
    Problem with finishing the Orphanage Quest in Den Residental.

    The screenshot presents the problem:

     
  7. tomten

    tomten It Wandered In From the Wastes

    164
    Jan 6, 2008
    Pre-patched versions don't seem to work. Maybe this is why some people are getting the Verticrash and others aren't?

    Trying your savegame now...
    First crash I've ever gotten that wasn't because of combat-saving or unexpected FALCHE usage.

    EDIT: Maybe it's because your FO2 is a different version than mine? I have unpatched UK. I don't know how the engine works, but all the .pro files in your savegame are identical to the files I already had.
     
  8. tomten

    tomten It Wandered In From the Wastes

    164
    Jan 6, 2008
    Sounds like the kind of problem you can always run into in FO1/2, doesn't it? Is there even a way to fix this?
     
  9. Nimrod

    Nimrod It Wandered In From the Wastes

    196
    Sep 24, 2007
    In my experience you can also exploit it to duplicate items in the Den. If a kid pickpockets an item below a container, it stays in your inventory and a duplicate appears in the kid's inventory which you can then steal. I don't like to exploit bugs myself, but there it is anyway.
     
  10. Glovz

    Glovz Vault Dweller
    Modder

    735
    Sep 16, 2005
    Since the bag has been such a plague, why don't we just remove it form the game? Does anyone really need the bag? Yes that's not a fix, but let's just call it annoyance removal.

    EDIT:
    Just out of curiosity, to those who have been having the car trunk problem, did you happen to have the bag in your inventory at the time?
     
  11. Nimrod

    Nimrod It Wandered In From the Wastes

    196
    Sep 24, 2007
    I really like having the bag around, and would like a backpack and/or the rectangular bag added (I tend to cheat them in). I put all my drugs in the bag and quest items in the backpack, leaving the regular inventory open to just the most frequently used items. I personally don't like having to scroll through a dozen items to find the one I'm looking for.

    This is one point where I really think it's best to let people police themselves. If someone doesn't want to use a container, they can just not use a container.

    EDIT: I haven't had the car trunk problem, either with containers in my inventory or in the trunk.
     
  12. Chucky

    Chucky First time out of the vault

    58
    Jan 17, 2005
    Problems I experience :

    - Game Crashes to desktop If I try to use the black Elevator on the Chemical level of the EPA
    - The Gecko Powerplant problem solves itself automatically despite me not setting foot in reactor or even aquiring the Hydro-electric Magnetosphere Regulator
    - 'small, abandonded mine' that Traveler describes to me does not show up on world map.

    If I can remember any more I will list them
     
  13. Glovz

    Glovz Vault Dweller
    Modder

    735
    Sep 16, 2005
    I have noticed in the game files there are two different .pro files for the bag - 46.pro and 93.pro - just wondering if anyone has looked into whether or not this has anything to do with the problem. Plus given that the bag is handled by the engine (if I understand correctly) it is most likely out of killap's scope to ever fix.
     
  14. Nimrod

    Nimrod It Wandered In From the Wastes

    196
    Sep 24, 2007
    One is the round bag and one is the rectangular one which doesn't appear in F2. I believe the only difference is the art.
     
  15. Glovz

    Glovz Vault Dweller
    Modder

    735
    Sep 16, 2005
    The Back Pack is file 90.pro - the two files I mentioned before both reference the regular bag image and description, thus what is the need for two of them.

    I use F2Wedit to examine the files.
     
  16. gracul

    gracul It Wandered In From the Wastes

    100
    Jun 6, 2007
    I would like to see an exit world grid in the residential part of the Den. I have to admit it that i know about the problem with residential part changing after completing the orphanage quest.

    About the car problem, I still remember that odd bug with the player character sometimes trying to life up a bookcase, a locker, or something else instead of actually accessing it. What did the animation look like when you took the trunk in your inventory? Was it a lift-up animation?

    +1 to you, the bag is the main bug of the game atm, after all killap's fixes kicked in. The bag means broken quests (items staying in inv after finishing quest because bag was 1 slot above item), unlimited ammo, and not really that much of a help. What is the bag used for? mainly glitches, put dyno inside the bag and then put the bag on the ground so noone will enter combat mode pfff... None that want to play fair uses the bag, but even i got caught on it because the i picked the bag and cornelius watch and what happened when i turned the quest in? ofcz the watch stayed in my inv, i would reload if not that im playing a 1 slot savegame.
     
  17. Crowley

    Crowley It Wandered In From the Wastes

    180
    Dec 12, 2003
    The Doctor in the EPA cannot be pickpocketed for no apparent reason. I remember Chris saying he designed this intentionally so you couldn't steal rewards or quest items from the Doctor before you were supposed to get them. However, there must be some way in the game around this. Lots of NPCs give you stuff which they do not seem to be carrying beforehand if you try to pickpocket them.

    edit: The machine part you get to deliver in the Abbey to Max has the description of being a power armor part. I have no problem with the reused graphic, but I suppose the part is meant to be something for the printing press.

    more edit: I ran into more trouble when trying to solve the quest for the Abbey water pump. When I first spoke to the person trying to fix it, I had two dialogue options which both said "Here you go." After that the conversation proceeded to where I could offer to try and figure out what was wrong with the pump. Now if I use repair skill on the pump, I get the message that I need tools to install the pump part (which I do not have). Trying to use a tool or toolkit on the pump does nothing.
     
  18. popscythe

    popscythe First time out of the vault

    8
    Jul 8, 2007
    Same with everyone I know. I haven't tried it myself yet, but the 4 people I encouraged to check it out went right to nevarro and all froze.
     
  19. mechanon

    mechanon First time out of the vault

    7
    Jan 27, 2008
    I have Fallout 2 1.02.23 exp 1.1.

    I think it's a prepatched no kids version, its from some 'Fallout Ultimate Collection' box.

    I used the custom install guide somewhere in the beginning in one of the exp threads, and everything works...

    except for the elevators in EPA. I guess the custom script thing instead of the standard button graphic does not compute. Maybe remap the elevs like in SAD, where one goes lvl 1-3, the other 3-4 ? It feels to me like the poor old F2 engine can't take any more non-standard stuff... :)

    I also couldn't open the door to the other slaves in slave camp, unlock worked fine but open does nothing, only the anim, no message.
     
  20. SHADOW-XIII

    SHADOW-XIII First time out of the vault

    98
    Nov 19, 2007
    Small fix request:
    in NCR there are slavers that want you to bring ranger map
    if you agree you got entry in pipboy but if you kill them entry stays there not crossed out

    what's bad: slavers use mobile phones or e-mails since when I bring the map to them(in ncr) game kills all raiders in safe houses

    my idea: after bringing map, mission is complete as succesfull BUT "raiders are killed in safe houses whenever you leave location while slavers are still alive" - this will make possible to give them map and kill them constantly after that
     
Thread Status:
Not open for further replies.