Fallout 2 Restoration Project 1.2 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Jun 9, 2008.

Thread Status:
Not open for further replies.
  1. GlowHound

    GlowHound Look, Ma! Two Heads!

    311
    Jun 12, 2008
    Ahh.

    I ask because I decided to use the Environmental Armor just for kicks and I really like the animations. I mean I've played FOT but I thought it was cool to see that in Fallout 2. It made me feel like my character was special, weird as it sounds.

    And I was also wondering if someone would be willing to replace the hero model and all his/her animations with the ones from FOT, armor and all.
     
  2. 5h00n4y

    5h00n4y First time out of the vault

    36
    Jun 22, 2008
    Now that this stupid "it's-all-my-fault" bug was fixed, I've remembered I had trouble completing the "farm on the northeast of Modoc" quest.
    The real problem is, I'm in Vault City now and I don't have a previous save, so here's me story ;)

    1. I found about the farm quest, the farm appeared on map, I got there, found the glowing people, got the letter to the shopkeeper, he read it, and the next thing I was suppose to do is to find Karl the drunk in Den's bar.

    2. Obviously I did find him, but couldn't get him to return, he just fell asleep after a dialog.

    3.Returning to Modoc and talking with the shop keeper didn't help neither, he ignored the fact I found him ;)
    Also there was no dialog option about it, so how on earth could I tell him that? :/

    4. My only clue is, that this might happen because I've tried to talk to him nad gave him a drink the FIRST TIME I was in Den. He fell on the floor then, and never stood up, so I've just lost interest in this one quest...

    5. What was I suppose to do?
    The game only says "find Karl", so do the solutions...

    6. Anyone had such trouble with this quest after getting Karl drunk in Den before travelling to Modoc?

    7. Would this quest be solvable if I haven't got him drunk, when the first time in Den me was? :/

    8. I don't remember this quest the previous time I played FO2 (long time ago that was ;)), but hopefully it's not a bug?
     
  3. isfet

    isfet First time out of the vault

    74
    Jan 19, 2008
    @ 5h00n4y

    I'm sorry, but I belive the quest is busted if you got Karl drunk. You must keep him sober to complete the quest. And yes it was in the original FO2. BTW it is not a bug or anything
     
  4. 5h00n4y

    5h00n4y First time out of the vault

    36
    Jun 22, 2008
    Oh well, at least now that I know it is solvable I might try it next time...
    Thanks again, friend :)
     
  5. Morticia

    Morticia Look, Ma! Two Heads!

    372
    Mar 9, 2008
    After playing through over half way now, I only found two tiny possible bugs to report. Of course, nobody else has said anything about these, so probably just my game, or my imagination.

    First is a map error. The door in the side of Rose's Bed & Breakfast is outside of it's frame somehow. It wasn't that way in v1.1



    Second is a crazy cop in NCR that was really irritating me. Leave all my companions near Buster's since I'm always having problems with them arming weapons. I walk in, talk to several of the police including Dumont to make sure everything is OK. Once I get past the corner where Dumont is, this lunatic decides to attack, then everyone else joins in. Most of the time he starts before I even see him, but I finally figured out he's the one on the corner near the cantina.



    He did this 5-6 times in three separate saved games, before and after I'd been to clear out Vault 15. I had to sneak behind the hospital and run to the exit in order to bring the parts back to Tandi. Once I did, everything returned to normal and he was no longer mad at me.

    I haven't done anything wrong in NCR that I know of. Guarded Westin's brahmin, Killed Bishop for him, did the Ranger's quests, killed Jack. I didn't steal from anybody or even take Merk's jobs yet. No way this guy could have possibly caught a stray bullet and is still sore about it, unless he was a robber that ran off the map in a random encounter and joined up later with the police force.
     
  6. isfet

    isfet First time out of the vault

    74
    Jan 19, 2008
    @ Morticia

    Ive got the door problem in the vanilla and 1.1RP FO2 sometimes. in fact it used to happen with both doors of roses b'n'b and door on farrels house too. havent been to modoc in 1.2 yet (I hate college)

    EDIT: oh yeah. I just remembered that in the vannila FO it usually happened after blowing up the outhouse
     
  7. Gert

    Gert First time out of the vault

    5
    Jun 21, 2008
    found a little bug.


    When entering sierra army depot. On the first stage. The person that's with you enters the elivater from time to time when you stand in front of it.

    Is strange, because it's closed.
     
  8. 5h00n4y

    5h00n4y First time out of the vault

    36
    Jun 22, 2008
    Now that you mentioned it, I've remembered a similar thing.
    No idea what I've done bad, but one of the hookers in Den from time to time decided to trigger the fighting mode and run for it.
    It's not THAT irritating since I can easly press [end combat] when she's not-to-near, but... it is kinda irritating. ;)
    My last save should reproduce that.
     
  9. Morticia

    Morticia Look, Ma! Two Heads!

    372
    Mar 9, 2008
    @ isfet,
    Good to know that isn't a bug then. I had just blown up the outhouse and had never seen that happen before.

    @ 5h00n4y,
    That just happens sometimes and is not a bug. Most of those people in the Den are high on jet so they tend to freak out.
     
  10. Nicksherb

    Nicksherb First time out of the vault

    2
    Jun 23, 2008
    First. Killap. You are my God.. I stopped playing fallout 2 years ago and to see this community surviving in the wastes and achieving this... I am so impressed and best of all. back in it.

    Killap, I am about to play the SH*t out of your mod. I use VMware to get windows up and running.


    Its porbably been asked, but I can't get the search to work in NMA... is there a way to make this mod run native on the MAC build?

    again.

    rock 'n roll fallout 2
     
  11. Kanhef

    Kanhef Vault Dweller

    793
    Sep 2, 2007
    Unfortunately, we'll need a good hacker to make a Mac version work. It requires changing the hardcoded number of cities and uses some of Timeslip's engine tweaks.
     
  12. Ylenard

    Ylenard First time out of the vault

    16
    Sep 18, 2007
    Hello,

    I've encountered 2 bugs.

    1st - When I leveled up thanks to the exp reward for the "find two missing hunters" quest in primitive tribe, Sulik leveled with me, but immediatly deleveled. His HP indicator showed something like that: 103/93 HPs. I reloaded several times, but the outcome was always the same. Then I decided to wait a bit before doing the quest and level on some random encounters - Sulik leveled up normally. This was the only moment I encountered it, so maybe the blackout and "teleport" has something to do with it?

    2nd - Vault Village/The Brain problems. First I got some unfitting texts from The Brain - I repaired the plant, went to the village, brought them weapons and obtained talisman from them before meeting The Brain. When I met him, our conversation looked like that:

    -I smell my talisman on you, but I don't remember giving it to you.
    -I got them from people in Vault Village.
    -Do you want to renew?
    -...(I picked all the lines leading to him explaining me what exactly is renewal. When he told me everything he had to say about it I accepted)
    -I want to renew.
    -Then take this talisman.... why are you still standing here? don't you have something to do?
    -I better get that disc from Gordon.

    That's where the problem is. My character neither have met Gordon nor heard about the economic disc before.(minor bug)

    I talked to The Brain again and he said something like:
    -What now?
    -You promised you'd withdraw the molerats if I repair the plant. Fullfill your part of the deal.
    -I will if you optimise the plant.
    -screw you... I'm going to optimise it.

    Again - I haven't even met the brain before repairing the plant.

    Now for the bigger bug - I optimised the plant, and went to talk with The Brain about him withdrawing molerats, but I can't speak to him about it. He says: "good job, but now go away, Im busy d00d" and the only 2 lines I can choose from, simply mean "goodbye", and thus I can't finish Vault Village quest.


    Those are the only bugs I've encountered. I have one minor suggestion though. It would be great if you changed one thing about the "deliver weapons" in the primitive tribe quest, so that the Head Warrior wouldn't take the weapon you're currently equipped with when you have enough of them in your inventory. It was a bit annoying to discover that although I had 5 spears in my Inventory the Head Warrior took the sharpened spear I was equipped with :P.

    Anyway, great job on the expansion. It's simply awesome.
     
  13. encinodude

    encinodude It Wandered In From the Wastes

    174
    Jun 3, 2008
    That bug's been happening to some people. For some reason not everyone's experiencing it (or maybe they just haven't noticed). Killap and Timeslip are trying to get to the bottom of it, if I remember correctly.
     
  14. Touquet

    Touquet Look, Ma! Two Heads!

    328
    Apr 20, 2007
    Had the same bud, I use NCR1.sav from an previous save and it's happen no more.
    When exit by Westing Ranch area or just going to the Stockmen's Association, the two police officer in front of it were shooting at me for no reason... Don't know why but by replacing the . sav file the "bug" disappear.
     
  15. Nicksherb

    Nicksherb First time out of the vault

    2
    Jun 23, 2008
    That sounds very hard. Screw apple.


    PLayed into the wee hours of the morning. This is so good.
     
  16. Carib FMJ

    Carib FMJ Nuka-Cola Chaser

    Nov 8, 2003
    Great, now I have to purge the entire game... Well at least I know now... Saved me a lot of heart ache.
     
  17. Darek

    Darek is currently unavailable

    Jan 7, 2008
    @ killap

    I borrowed an old computer with win Me, so I could look at the primitive tribe crash. What I've found out so far:

    It's not sfall related cause the tribe01 map crashes in the mapper as well. (under win Me)
    It's only the first level of tribe01 that isn't working (woods area).
    Tested by using the *Clear Map Level* option in the mapper on my Vista machine, and then moving the map over to the win Me one.

    After that I tried to manually clear the map. I removed everything I could see (including invisible blockers), only a few tiles in the upper border that I couldn't reach were left. Moved it to win Me, still crashed.

    Then I figured out how to move the map around, so I could remove the tiles I missed earlier (weren't as few as I had thought).
    This time it worked, no crash. I also saw, with help of the resolution patch that I had missed removing at least one tile in a corner that was cloning itself.

    Now I don't really know what to think about this, is it something wrong with the tiles being used, is the map too big (area), or are some tiles in the wrong place (too far out in the edges)?

    I decided to remove the tiles all along the edges to make the map smaller, but as soon I tried to move the map, the mapper crashed.
    After removing lots of things from the map I was able to move it around. (I didn't bother figuring out exactly what made it crash, ie if the map was too stuffed or if it was something specific I removed.)
    Anyway I started to remove tiles only to find out that the stupid mapper is cloning new tile as I move the map around. Meh.
    Is there any way to stop it from cloning new tiles? As it is, it seems impossible to remove the edges only.

    I'm fucking confused and this probably don't make much sense.
    Do you have any ideas what might be wrong, or any ideas what I could try to do to solve this?
     
  18. Glovz

    Glovz Vault Dweller
    Modder

    737
    Sep 16, 2005
    I remember this happening even in vanilla Fallout 2, so I don't think this is RP change related.
     
  19. Ylenard

    Ylenard First time out of the vault

    16
    Sep 18, 2007
    Another small bug:
    When I talked to aunt Morlis about flint with a high speech character she said:
    "I'm sorry, but I seem to have misplaced the flint somewhere... I wish you a safe journey though". despite that I got the flint from her and recived 50 exp points.
     
  20. Darek

    Darek is currently unavailable

    Jan 7, 2008
    From tribe01.map, level 1:


    WTF? Of all the secret blocking hexes, only this particular, extra special one is responsible for making the Mapper crash when I try to move the map around.
     
Thread Status:
Not open for further replies.