Fallout 2 Restoration Project 2.1.2b (Unofficial Expansion)

Discussion in 'Fallout General Modding' started by killap, Sep 18, 2010.

Thread Status:
Not open for further replies.
  1. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Very good advice, SnapSlav.

    My problem is my continuous desire to cram as much as I can into a release. And I'm not talking about making a product that has everything and the kitchen sink, but more like making the first release the most complete and perfect release. It's something that I keep doing inside and outside of my job.
     
  2. .Pixote.

    .Pixote. Carbon Dated and Proud
    Modder

    Sep 14, 2009
    I'm sure everyone who worked on the RP will happy to finally finish it and move onto other projects, or just hang their boots up and enjoy other pursuits. If we had lots of time on our hands RP 2.2 would have been out last year, sadly we don't have that luxury anymore. :cry:

    It will be a nice update, with a few new things here and there, and lots of bugs fixed. :wink:
     
  3. scorptatious

    scorptatious Ugly Mutant

    81
    Oct 8, 2012
    I seem to be having problems with the terminals that control the turrets at the Oil Rig. I have the Presidential Key, but for some reason the option to use the key doesn't appear.

    So now I can't use the turrets.

    I also can't seem to convince the Enclave troopers before Frank Horrigan to help me even with speech at 100%. Does that have anything to do with the terminals as well?

    Help would definitely be appreciated.
     
  4. .Pixote.

    .Pixote. Carbon Dated and Proud
    Modder

    Sep 14, 2009
    There might be a science or repair skill check on the terminal, with the right numbers the options will come up.

    You need your speech skill to be about 120+ to work, the higher the better.
     
  5. scorptatious

    scorptatious Ugly Mutant

    81
    Oct 8, 2012
    Thanks. That makes sense, as I did have a rather high science skill on my first playthrough.

    I was able to get the enclave guys to help me though eventually, and I was able to beat Frank Horrigan without the turrets. T'was quite difficult however. 8/
     
  6. MrBlazzar

    MrBlazzar First time out of the vault

    1
    Oct 30, 2012
    I'm sorry if this has been answered before I didn't see it but I am having a issue with starting fallout 2 after installing the Fallout 2 Restoration project on a GOG install of the game.

    Every time I try running fallout 2 after installing the restoration project it doesn't start and tells me "Fallout appears to be running in compatibility mode." is this a problem on my end installing this? or is it a issue with the GOG version?

    Just in case its needed my operating system is windows 7 home premium 64 bit. I'm using the latest version from GOG and I installed 2.1.2b using the windows installer full installation in installer.

    Thanks for any assistance.
     
  7. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Did you check the compatibility settings of fallout2.exe?
    (right-click fallout2.exe, choose properties and then click the compatibility tab)
    I think the GOG version is set to run in 256 colors, so untick that and any other of the other boxes if needed and you should be fine.
     
  8. bozyn

    bozyn First time out of the vault

    5
    Oct 5, 2012
    Thank you for this great mod :) It gave me a reason to go back to this great game.

    However I have come across a problem with the Broken Hills ending.

    I remember that I exposed the anti-mutant conspirators to Marcus, fixed the mine's purifier, found the missing people and even got Marcus to join me. Yet I still got the "racial wars erupt" ending.

    Can you shed some light on this? Should I send you a save game? Thanks a lot in advance :)
     
  9. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    @bozyn
    If you want the "good" ending for Broken Hills (uranium runs out), now you also have to report Marcus about Dr. Henry's experiment.
    The current problem is if you recruit Marcus before that, you won't be able to report him, and the "good" ending gets locked out. Don't know if killap will change it in next RP 2.2 beta.
     
  10. Darek

    Darek is currently unavailable

    Jan 7, 2008
    killap said "You can now talk to Marcus about this while in Broken Hills and he is in your party." for the upcoming beta.
     
  11. ogwelx

    ogwelx First time out of the vault

    1
    Nov 3, 2012
    Sorry if this has been answered, but I've tried searching and so far have not found anything that worked for the "Error Loading Cities" prompt that comes up at startup.

    I've installed using the humongous install, then 2.1.2B windows installer, and everytime I load I get that same error and a ctd.

    I've tried the various fixes I've found in the forums- patching the mapper, updating sfall, trying to find a line that read Citylimitfix(or something like it) in ddraw.dll, but so far nothing has worked.

    F2 runs fine without the patch. I've positive its something small, so I've tried reinstalling both the game and the RP, but have not had any luck.

    Any help would be greatly appreciated.

    Edit: forgot to mention I also tried changing the Mode line in ddraw.dll, did not cure me. I'm running XP with SP3.
    Same exact error with Megamod, I'm convinced its an issue with sfall but have no idea how to go about fixing it. Dicking around with settings in ddraw.ini seem to do nothing. Is there something I should change in fallout2.cfg?
     
  12. Czaro

    Czaro First time out of the vault

    2
    Nov 3, 2012
    Hi there, I've just installed restoration project 2.1.2b version (full installation) and I have only one, but very big, problem. I can't load my saves from before I installed RP. When I try to load one of them, error pops with this message

    "Application error [my fallout 2 installation directory]
    The instruction at 004f11db referenced memory at 00000010
    The memory could not be read from
    Click on OK to terminate the application"

    Is there any way my older saves from original fallout 2 will work on RP?
     
  13. Metz_Villarreal

    Metz_Villarreal First time out of the vault

    8
    Dec 8, 2010
    My pitiful knowledge states, that the answer is: "NO", but let the Gods of Fallout speak...
     
  14. Foede

    Foede First time out of the vault

    2
    Nov 4, 2012
    I have recently encountered the EPA+skynet bug, the one about going down inside the facility, leaving the bot behind, but upon returning to the surface, my robotic lil fella is completely missing. Problem is, he was carrying all my quest related items, so it's kinda not cool to have him missing suddenly :(

    I went to the projects bug reports page on the wiki, and noticed that the bug was already reported, confirmed, and to my happy surprise, even fixed on an unreleased update.

    Now, on this thread, I'm reading about a release near Christmas. If that's correct, is there any other way to hot-fix this issue? maybe some command to re-create the NPC?

    I've tried with a save game editor, and now at least I can create the missing items if needed be, but I'm hoping there is something I can do about my missing companion.
     
  15. Elitech

    Elitech Still Mildly Glowing

    282
    Apr 22, 2008
    I agree with u, answer is no.
     
  16. Richwizard

    Richwizard I'm not dead! Orderite

    Jan 18, 2010
    It has been stated by Killap before. Saves from vanilla FO2 are not compatible with the RP. Even saves from earlier versions of the RP are not compatible with recent versions. You will need to start over when the RP is installed.
     
  17. perdue

    perdue First time out of the vault

    3
    Jul 24, 2010
    Same problem for me. As a Chosen one you have no reason to go to Navarro right after V 13. And still you will be blamed for intelligent deathlclaw genocide. Is there a chance to change this as suggestet, oh mighty Killap? ( trigger the attack after going to Navarro and talking to Shreber, not after going to Vault 13.)
     
  18. triikan

    triikan First time out of the vault

    1
    Nov 18, 2012
    From a storyline standpoint, it is perfectly reasonable to expect you to be at Navarro within the time frame.

    You get to Vault 13, retrieve the Geck, then go back to save your village. Its only then do you find out everybody has been kidnapped, and Hakunin tells you they were taken to Navarro.

    So, to save the deathclaws, your character has to be the type that is trying to save your village, instead of the type of character that finds out his village has been kidnapped and spends the next two weeks finding people's spleens.
     
  19. MisterCrit

    MisterCrit First time out of the vault

    8
    Dec 3, 2011
    Good point. I always like to do the Military Base, save Chip's spleen, free the Shi, gain access to the Brotherhood of Steel bunker in San Francisco (spending even more time improving my attributes) and gain about five or six levels before I head out to rescue the villagers. :mrgreen:
     
  20. Vandarion

    Vandarion First time out of the vault

    1
    Nov 27, 2012
    Hi!

    Thank you Killap & Co for the great mods and all the work! I'm just another happy camper playing Fallout 2 and RP 8-) Fallout 2 still going strong 2012-2013!
     
Thread Status:
Not open for further replies.