Fallout 2 Restoration Project 2.1 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Jul 25, 2010.

Thread Status:
Not open for further replies.
  1. Guardian of Nowhere

    Guardian of Nowhere First time out of the vault

    6
    Aug 4, 2010
    Hello everyone,

    just registered here. I read a lot here lately and played the Restoration Project, both 2.1 and 2.1.1, (after playing FO2 vanilla once again, as recommended), and I enjoyed the hell out of every second of it. The added content and locations make the game so much better, and some things finally make sense. Thank You Bear Dude and Everyone Else who was involved in making the RP a reality. :notworthy: :clap:

    No serious problems with 2.1.1 so far, but I encountered an odd bug at the Den. I helped Lara attack the church, and before heading off to Tyler's party, I saved the game. I didn't heal, just talked to her once more and continued the quest. At Tyler's party, there was no opening dialogue (which was there in 2.1) but combat began right away. After that, Lara didn't thank me and pay me and go to the church. She just stands there and says "let's go". Also there's four of them. One Lara at the church, one in their base in the east end and two (yes, two Laras. Couldn't believe it at first) at Tyler's Party Hut(tm).
    The quest is marked as finished, but Lara doesn't seem to agree.
    Any ideas what that is all about?

    Install was a fresh humongous FO2, RP 2.1.1 win installer with all options checked.
    I had Sulik, Vic and Cassidy with me.
    Right before entering the ToT, I set my unarmed skill to 85 using F2SE, to make said Temple more enjoyable (I'll get that for free later on anyway, right? It's not REALLY cheating, right? :hide: Oh, who am I kidding...).

    savegame -> http://www.4shared.com/file/jJfDyq2a/SLOT12.html
    This savegame is from much later in the game (power armor sure would have helped in that fight), but the situation in the Den hasn't changed.

    Again, many thanks to all those involved in making the RP.
    And please excuse the verbosity...


    EDIT:
    Redownloading the RP and reinstalling everything seem to have fixed it.
     
  2. DangerousDave

    DangerousDave First time out of the vault

    11
    Jul 11, 2010
    I just started an Unarmed master character, before klamath, i again ran into Kaga and his two outcast. Now Kaga is running away, hit him 3 times. But during the fight with the two outcasts, i managed to critical the male one 4 times, once in the eyes and three times in the head, all for 0 damage? is this a bug or do npcs have some kind of resistance to damage?
     
  3. Grunter

    Grunter First time out of the vault

    19
    Jun 11, 2008
    Minor one,

    In a previous visit to NCR I killed Marik & his two guards inside the house opposite the town hall. On this visit when I was going to the bar outside of town Marik and his guards were leaving the bar and heading for the gate. Checked where I had killed them before, the room was empty with bloodstains on the floor.
     
  4. SPC

    SPC First time out of the vault

    60
    Jan 20, 2007
    I'm not an expert on this but what you seem to have killed was his scripted animation. If you want him dead you'll have to shoot him while he is stationary either in his bazar bar or on the carlin ranch. My guess.

    Something similar happened to me outside the Abbey where you have to apprehend the crop thief for the local farmer there. After finishing the quest and when Tom was standing inside the farmers house, I saved the game. But obviously his position was not saved correctly because on loading that savegame he was still walking from the top right corner (this was where i told him to stop the thievery) of the map to the farmhouse.
     
  5. ColJack

    ColJack Where'd That 6th Toe Come From?

    422
    May 7, 2003
    Abbey..

    went exploring before seeing the head honcho, and found and killed the deathclaw in the basement..
    I went to talk with the head monk and immediately on talking to him i got this..


    no mention of a quest to find the bloke etc, just straight to "already did it.."..

    he says I can access the terminals now on the second floor but it says I don't have the acces card.. is he supposed to give it to me as the reward for the quest?
     
  6. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    I think you have to talk with one other npc before you can use a terminal. He then says something like "ah yeh, here is the terminal you can use, yadda-yadda." Run around and talk to every robed npc in the building again, then you should find it.
     
  7. ColJack

    ColJack Where'd That 6th Toe Come From?

    422
    May 7, 2003
    ah!! ok, found him, hard to see him in grey robes hiding next to a grey pilar...
     
  8. ColJack

    ColJack Where'd That 6th Toe Come From?

    422
    May 7, 2003
    ok, gone back to the EPA to get the botany files and the entrance level has been reset!!!!

    the plants are alive again and the rope is missing form the elevator...!!!

    my pip boy still registers as having done all of the quests in there..
     
  9. SPC

    SPC First time out of the vault

    60
    Jan 20, 2007
    Glad to see i'm not the only one seeing this piece of dialog to be a bit out of place. I had already reported this in the wiki but don't think it will be changed.
     
  10. Dravean

    Dravean Where'd That 6th Toe Come From?

    478
    Mar 6, 2005
    That's certainly a bug and should be fixed. That bit of dialogue is supposed to be in response to the Abbot saying this line (if the PC has already gone down there and killed the death claw):
    {408}{}{Brother Thomas has been missing for several day, ever since he went down to the caverns below the Abbey. [He sighs wearily.] You see, some of the Abbey’s residents claimed to have seen a huge beast lurking down there, and Brother Thomas was quite skeptical. He took it upon himself to go dispel these rumors, yet, as it turns out, his disappearance has only further validated them.}

    [Edit] Shit, I just noticed a typo in there. "day" should be "days".
     
  11. Tony Brasco

    Tony Brasco First time out of the vault

    55
    Mar 11, 2010
    Actually, fallout2.exe creates those empty directories, not necessarily the installers. If the directory in fallout2.cfg is wrong and does not exist (such as sound\music), fallout2.exe creates them. You can easily test this yourself if you edit the file and write a bogus directory.
     
  12. Brunzer

    Brunzer First time out of the vault

    92
    Apr 9, 2010
    In Klamath I am carrying an unstackable knife. I've picked this knife up either at the Kaga encounter from one of the two hostile tribals that accompany Kaga, or in the second level of the underground caves (the one where the rat god is) by the bookcase near the stairs to the third level.
    savegame in Klamath where I carry the knife

    In the basement of the abbey there are 2 unreachable tables in the printing press room.

    After delivering the machine part for Elaine she doesn't thank you, instead you get the initial dialogue where you can ask who she is. This seems a bit strange, it would be nice if a few extra lines were written, 1 where she thanks you, and a second where she acknowledges that she has met you before.

    The teams sometimes seem mixed up in random encounters. I've had an encounter of 'some highwaymen and robbers' who started shooting each other. And another one of 'some molerats fighting rats' in this case the molerats fought among each other,as did the pig rats and normal rat. There have been no accidental 'friendly hits'.
    savegame of the robber-battle
    savegame of the rat-battle
    I am using rp 2.1.1 on a humongous install.

    PS. Killap, your work and of those who assist you on this project is much appreciated :-)
     
  13. General Maxson

    General Maxson First time out of the vault

    2
    Aug 6, 2010
    I think I broke it... :( :clap: :oops:

    So yeah, here's the whole story.

    I was having major issues with my save games and, after 2.5 days of frustration, I fixed the problem.

    I was all ready to get my game on, but first! I think I'll see what I can do with the resolution mod.

    I set it up for a resolution that was a little too high and restarted the game getting an error:

    The instruction at 0184a373 referenced memory at 00000000
    The memory could not be read from


    So I figured I'd just do what I did before when I did this to other games: edit the fallout2.cfg file to restore the default resolution and all should be well.

    Not so much. It wasn't in there.

    I opened the file in Notepad and didn't find the resolution. I opened the f2_res.ini file also, but that already said 640x480.

    I was still getting the same error every time I tried to start the game. So I said screw it, completely removed RP2.1.1 and then FO2 itself.

    Reinstalled FO2 alone (still got the error) and then RP2.1.1 again. Same issue. I had completely removed the BlackIsle folder and I'm still getting this error.

    I think I may have totally screwed myself. Which makes this even worse, since before I did this, I had JUST fixed my previous issue.

    Please, I hope someone here can help me out with this.

    Oh, and just a clarification, I'm not saying that I think RP2.1.1 caused this issue, it was me messing with things I don't fully understand. I was just figuring this would be the best place to ask as I encountered the issue while using mods and probably everyone here knows more than I do about computers.

    I would REALLY appreciate anything anyone could do!!

    P.S. Killap, you are awesome! Not enough people are dedicated to non-profit projects like these and for someone to not only finish, but continuously update and work on it just for the pleasure of the fans (and, I'm sure a little bit for yourself) is beyond commendable. Cheers, mate!
     
  14. General Maxson

    General Maxson First time out of the vault

    2
    Aug 6, 2010
    Also, I'm an idiot.

    I switched the program to "Run as Administrator" and it worked.

    That's the first thing I should have done. Peace.
     
  15. utunnels

    utunnels First time out of the vault

    74
    Aug 2, 2010
    I'm not sure whether I completely understand your problem.
    But for the resolution problem, perhaps you can try editing ddraw.ini instead of fallout2.cfg
     
  16. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    The abbey dialogue is indeed out of place and will be addressed in 2.1.2.

    Also, there will be a fix in sfall that should resolve the .cfg sound path issue once and for all.

    While reporting issues to this thread is fine, I do hope people are making use of the RP bug wiki (I haven't checked it in a while, so I can't really say). If anyone notices issues reported here and they are not also posted on the wiki, I would appreciate it if someone can add them.

    RL is hella busy, so the above is all I can report at the moment.
     
  17. Adq

    Adq First time out of the vault

    19
    Jun 11, 2010
    There is a some problem [SOLVED]:

    I did clean install of FO2 and then installed 2.1.1.
    I launched FO2 and encountered severe hang on "Please Stand By" screen.
    Installed in non-programfiles directory, have unrestricted access to all files and dirs in game directory.
    My OS is Windows 7 Professional 64-bit.

    EDIT:
    Solved by manually setting in INI
    Mode=4
     
  18. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Question to all Vista/7 users:

    It seems that many of you have issues where the coloring in the game is messed up or there are odd hickups when launching the game. The problem seems to be fixed by making the ddraw.ini fix as stated above. Did all of you have to make this change? Should graphics mode be set to 4 by default for all Vista/7 users? I run XP and I never had such problems, so I'm wondering if just Vista/7 users are affected. Did any XP users have to make this graphics change to get the game to work? I want to try and make the installation process as automated and smooth as possible, so I'm willing to make that change but I don't want to do it unless it is really absolutely necessary
     
  19. Brunzer

    Brunzer First time out of the vault

    92
    Apr 9, 2010
    I use Vista 64bit, and the colors were messed up, though after adjusting the resolution and changing to 16bit the problem was solved.

    If graphics mode 4 is 16bit coloring than I don't think you could go wrong with that. Probably all people who play fallout nowadays have a machine that can run it smoothly with 16bit, the rare exception can always change it manually.
     
  20. Timeslip

    Timeslip Water Chip? Been There, Done That
    Modder

    921
    Aug 15, 2007
    Most vista/win7 users will have this problem. There's a couple of core windows components which make changes the the pallate, overwriting fallouts changes. (And windows lets them, even though fallout has the display set to exclusive mode...)

    Then again, it's not 'required' as such, since the res patche's 16 bit mode will fix it just as well. (There's also other more complicated workarounds, like killing anything that might change the palette, or doing something where windows stops trying to reset the palette all the time,) The default vista DirectX install isn't up to date enough to use sfall's dx9 mode, (not sure about win7,) which means that anyone installing the rp without any other new dx9 games or doing a DX update manually would have the missing d3d9x.dll error. Unless anyone knows of any problems with the res patches 16 bit mode, I'd suggest that as a better default-on option.
     
Thread Status:
Not open for further replies.