Fallout 2 Restoration Project 2.1 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Jul 25, 2010.

Thread Status:
Not open for further replies.
  1. Dravean

    Dravean Where'd That 6th Toe Come From?

    478
    Mar 6, 2005
    I went to try this, and found that it was already set to 1.
     
  2. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    I believe I have it set to that as default in the RP installer. I'm not entirely sure at the moment though and I can't check right now.

    EDIT: And it looks like I'm correct as per the post above.

    @Dravean
    Thanks for the information and taking the time to fiddle with the settings.
     
  3. Timeslip

    Timeslip Water Chip? Been There, Done That
    Modder

    921
    Aug 15, 2007
    That sounds like you've mismatched resolutions between sfall and the res patch. Make sure they're both the same. (Or if not, at the very least sfall's resolution should be greater than the res patches, and should be an integer multiple of it to avoid bluring.)
     
  4. Adq

    Adq First time out of the vault

    19
    Jun 11, 2010
    I don't see why mode 4 could cause some problems. On mine setup works very good. Maybe add the info that RP needs latest DirectX to be installed.
    Mode 0 8-bit crashes instantly here, but I can manually set resolution and 16-bit in ini so it isn't a problem.
    A cause I prefer Mode 4 is scaling. When I set native resolution (1920x1080) in mode 0 then everything is too small to read without getting your eyes burn. :)

    Is Kaga strength based on your char current level?
     
  5. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Yes. After you go up a few levels, he'll go up one. There are only 5 possible kaga encounters. He can die on any one of them, but it is rare that you'll kill him early on unless you exploit something.
     
  6. Dravean

    Dravean Where'd That 6th Toe Come From?

    478
    Mar 6, 2005
    Right you are. I didn't even think about that. I changed the resolution in ddraw to match what I had set up in-game, and now the game looks great. However, I should note that I still can't see the resolutions listed in the "Resolution" or the "Scaling" boxes.
     
  7. DangerousDave

    DangerousDave First time out of the vault

    11
    Jul 11, 2010
    Killap, two questions both in regards to kaga encounter

    1) i did 4 criticals on the male outcast with kaga, 3 times in the head and once in the eyes, all for 0 damage, is that a bug or what?
    This was using unarmed, which i had tagged and at 102.

    2) easy way to exploit encounter with kaga, is to hit him a few times first round, then he will run away, but dont run after him, leave him for sulik or another of your henchmen, they will then attack him until he is dead. As he only runs so far away from you, just keep combat running.
     
  8. Adq

    Adq First time out of the vault

    19
    Jun 11, 2010
    I encountered hang during the battle, exactly when my char should shoot. Fighting in cave with radscorpions with shotgun. I don't installed FO1 sounds.
    EDIT: It seems that also occurs when it's Vic turn to shoot from 10mm pistol.
    EDIT2: It hangs very randomly.
    EDIT3: It is somehow linked with missing and hitting the corpse... maybe script that checks when missed bullet hits corpse is buggy?

    hang = Fallout 2 is not responding.... needed to forcibly close via Process Explorer.
     
  9. Timeslip

    Timeslip Water Chip? Been There, Done That
    Modder

    921
    Aug 15, 2007
    Then since the only case of mode 4 not working turned out to be user error, I suggest we go back to killap's original plan. :P

    Actually, I should probably make sfall error out if people try doing that. Whereas there's sometimes good reason to have sfall at a higher res than fallout is running at, (I keep it at my monitors native res; it's going to blur either way, so I might as well get rid of the mode switching,) there's no reason at all to have it lower.

    I would expect that. The res patch doesn't pull its supported resolution list out of sfall, so using dx9 mode has no effect on what it sees.
     
  10. Fruit

    Fruit First time out of the vault

    5
    Oct 30, 2003
    I seem to be stuck with Vault Village quest.
    It's a bit complicated but I'll try to explain as well as I can.

    My character "knows" the Gecko brain rat is controlling the mole rats in Vault Village, however, only conversation option I get
    is where this brain rat tells me to give reactor disk to Festus.

    Festus only has conversation options that both end with "Goodbye".

    McClure also has no conversation threads regarding this reactor disk and using it with Vault City central computer gives me "that does nothing."

    I'm really at loss here, any ideas or is this a bug?
     
  11. Templayer

    Templayer Dark Templar of the New Brotherhood of Steel

    45
    Jul 25, 2010
    That could be the problem, when i did encouter crashes in battle, it was always a shoot over a dead body, in some cases a weird number showed instead of % chance of hitting. I did write that waay back in some post. It did only in 2.0 version, from 2.1 the crashes subsided. Maybe it has to do something with the ammo/ fight mods, but i cant be sure. Oh again i failed to pinpoint the problem :F. (It did happen mostly in caves, after killing several deathclaws almost on same spot (ie. in the same corridor)). It did happen when i did shoot, ended my turn, or entered the exit grid. Now it doesnt crash, i think before i did use some sort of ammo mod that could be setuped in the inis, like Gloves and stuff... but i dont remember.
     
  12. valcik

    valcik So Old I'm Losing Radiation Signs

    Dec 20, 2008
    Yes, something is wrong with the 14mm pistol. I'm playing RP 2.1.1 with "F1 gun sounds" installed and game crashes everytime, when Sulik uses the 14mm pistol. Also wrong sound is played - same one, like the FN FAL rifle uses. The .223 pistol works perfectly, however.
     
  13. John Hancock

    John Hancock First time out of the vault

    32
    Jun 4, 2005
    Just a small note (fresh Humongous install, RP 2.1.1 Windows installer, XP SP3, no other mods): The dialogue for nomad random encounters needs a bit of cleaning up. For example, when the shaman offers to turn broc flowers and xander roots into healing powder, he quotes a price that's missing the dollar sign.

    Additionally, I believe the dialogue in the Primitive Village (and possibly the other expansion areas; I haven't gotten that far yet) should be altered so that, when the characters are emoting something, they use parentheses instead of brackets. The original content uses parentheses for NPC emotes almost exclusively, so using brackets seems out-of-place to me.

    I've also noticed a few bugs: extra "Desert" areas appearing in Arroyo's automap list on the Pip-Boy (will crash the game if clicked), "Scrub" scenery items (with the flashing "?" icon) appearing in the PC's inventory during the Primitive Village stimpak mission, and a few other things.

    I know I need to report these bugs properly on the bugfix Wiki, and I will in my next play through... unfortunately, I didn't think about reporting them right away and no longer have the saved games, but I figure it's better I mention them briefly here than not at all (or months later, on my next play through).
     
  14. utunnels

    utunnels First time out of the vault

    74
    Aug 2, 2010
    I noticed that even if you get the GECK in Vault 13, you still get options for asking about Vault 13 or GECK. I guess fixing them all need to do too many things(all NPCs that talk about them), but I'm just curious.
     
  15. John Hancock

    John Hancock First time out of the vault

    32
    Jun 4, 2005
    Oh, in addition, the pit boss in the Shark will speak to the PC as though you've already won the old man's slot machine jackpot, even if you haven't done so yet. I can get a save file for that and put it on the bugfix wiki later today.
     
  16. SkuLL

    SkuLL Chad McRealman Orderite

    Sep 6, 2009
    Yeah, this always bugged me too. But it's to much work to expect from anyone, I guess.
     
  17. Skeezix

    Skeezix First time out of the vault

    8
    Aug 9, 2010
    Got a couple new (as far as I can determine) bugs to report in Broken Hills.

    My setup:
    WinXP SP3
    Humongous Install (US version), RP2.1.1 (windows installer)
    All options turned on



    Re: Break Manson and Franc out of prison
    I picked the lock to the cell with the Supermutant in "the drunk tank." Upon opening the door, I got the XP award and notification of performing the jailbreak. I haven't gotten the quest from Jacob, or even been inside the actual jail (where Manson and Franc are locked up) yet.

    (It seems all the locked cell doors are sharing the script/properties for the actual quest cell door, maybe?)

    edited to add: Same thing happens with the other, empty cells in that building. I picked the lock on one of the other cells, Cassidy wandered through the door, opening it, and I got the Jailbreak XP and Karma loss.

    Re: Beat Francis at armwrestling
    The first time I spoke to him, he responded something like, "I've heard of you, I don't talk to scum." I'm not a slaver, I've got positive Karma, I've done right by Gecko, hell I've even got Lenny in the party. Maybe he just doesn't like teenagers?

    edited once again to add:
    On an unrelated note, I can't smoke. I've got a pack of Commies, and (in the included savegame) there's a lighter in the trunk of the car. When I have both in inventory, and try to use the smokes within the inventory screen, or put them in one hand and "use on" myself outside of the inventory screen, in both cases I get the "that does nothing" response. If I try to use them without the lighter, I get the "you need a lighter" response. In a previous playthrough, I found they worked so long as I only had one lighter in inventory, but with more than one, I got the same "that does nothing" from the game.

    Savegame here, standing next to the drunk tank.

    (And like an idiot, I forgot to give large, buffout-enhanced, radioactive thanks to Killap, Timeslip, and everyone else who helped breathe life back into FO2.)
     
  18. Panzerkampfwagen

    Panzerkampfwagen First time out of the vault

    65
    Feb 15, 2010
    Hmmm, maybe he simply don't like guys with too high karma?
     
  19. jmarsh07

    jmarsh07 First time out of the vault

    29
    Apr 22, 2007
    Yeah, I'm running Win7 64 bit/ nvidia gtx 280 and the above settings work great. Any other settings and I got the crappy looking colours. 8-)
    And on a final note, I waited a long time to replay this. Every time I thought about replaying, there would be a new post saying a new rp release was upcoming. So I waited.
    So what I wanted to say was :clap: WAY TO GO KILAP :clap: THANK YOU :D
     
  20. Alas86

    Alas86 First time out of the vault

    6
    Apr 20, 2010
    I think this happened to me too when I tried to talk to Francis for the first time after I had exposed that guy who was skimming money from the caravans(Chad was it?). When I tried talking to him before doing that quest he talked to me normally.
     
Thread Status:
Not open for further replies.