Fallout 2 Restoration Project 2.2 - OPEN BETA (ie NOT FINAL)

Discussion in 'Fallout General Modding' started by killap, Jan 6, 2013.

Thread Status:
Not open for further replies.
  1. AelpirT

    AelpirT First time out of the vault

    23
    Feb 24, 2012
    Eyefinity

    So, this is mostly of academic interest, I think, but I did finally get around to trying Eyefinity with the RP (well, with the high-resolution patch, more specifically, I believe):

    It works!

    With bezel-compensation on my triple Dell U2412M setup, that's an astounding 6028x1200, BTW. So kudos to all who made this possible... :salute: :notworthy: :salute:

    However, the bezel-compensation makes the setup unusable, unfortunately. You see, the entire map fits in a single "screen" horizontally so there's no scrolling. Which leads to the bits of the map obscured by the bezels being permanently so. Which means bits of the map cannot be viewed.

    I do not consider this to be anything to be fixed, even if that were somehow possible: what reason can possibly exist to run Fallout at such unreal resolutions anyway, apart from the interesting technical exercise?
     
  2. Nibiru

    Nibiru First time out of the vault

    22
    Oct 12, 2012
    this should cost nothing to increase the compagnon limit , even if i don't give a damn of it
     
  3. kicker04

    kicker04 First time out of the vault

    29
    May 5, 2008
  4. wargus

    wargus First time out of the vault

    9
    Feb 4, 2013
    Re: Eyefinity

    Very cool test. Any way to make it work with x2 scaling? Then perhaps you will be able to scroll on most maps therefor eliminating the bezel-compensation problem.
     
  5. wargus

    wargus First time out of the vault

    9
    Feb 4, 2013
    Re: Eyefinity

    Also could you take a screenshot and post it, or a link to it?
     
  6. Mactab

    Mactab First time out of the vault

    33
    Jun 20, 2008
    My game crashes every time I try to talk to someone. This started happening after I got some healing powders made by Hakunin. I tried to talk to Klint, Sulik, and Ms. Buckner and the game crashes. The error:

    "Application Error C:\Fallout2\FALLOUT2.EXE

    The instruction at 1000c0f8 referenced memory at 00000040
    The memory could not be read from

    Click on OK to terminate the application"

    I read through each post in this thread but didn't see anyone with my specific problem.

    Is there any other information I can provide to aid debugging?

    Will my save game be backward compatible with 2.1.2?

    Here is a link to download my savegame, if this helps:
    http://sharesend.com/28ky6nlm
     
  7. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Your save game works perfectly fine on my computer.
    I would suggest you try to reinstall your game and try that save again.
    As for more information, how about what version of the game you have, windows version (or if mac, wine), install directory, other mods or changes you mat have done to game files etc. Also, did it crash every time or just sometimes?
     
  8. Mactab

    Mactab First time out of the vault

    33
    Jun 20, 2008
    First, thank you so much for taking the time to help me with my problem!

    I reinstalled FO2 and the mod from scratch into a clean directory. Then deployed the save and it still breaks.

    Version of game=1.0 (the installation instructions for the mod said it was not necessary to patch to 1.02 first)
    OS=Windows Vista
    No other mods or changes.

    It crashes EVERY time now that I talk to an NPC who engages in full dialogue, i.e. not just floating text. I can reproduce on Sulik, the Buckner gal, Klint. Doesn't happen with that misc guy in the Buckner house who only has floating text.

    I tried to install 2.1.2b instead of 2.2 but it looks like my save is not backward compatible.

    I've exhausted my own ideas ...
     
  9. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Strange. I haven't heard anything like this before.
    So I got a couple of questions.
    Does it happen every time in Klamath or just this save?
    Did it work flawlessly up to that point?
    Does it work fine without the RP?
    If you temporary move out the "Dialog" folder from your ...\DATA\Text\English\ folder, does it work then?
     
  10. Oppen

    Oppen FIXT n°1 fan

    Dec 26, 2011
    I want to inform that stupid character actually can get Sulik, I was just misunderstanding my own grunts so it made no sense. So sad I found out just after I got the water chip, an extra companion would have done it easier.
     
  11. Mactab

    Mactab First time out of the vault

    33
    Jun 20, 2008
    I reproduced the issue, and found a workaround. The issue is caused by using the start menu shortcut that I let Vista generate for me by right-clicking on the fallout executable and selecting "Pin to start menu". When I run the executeable directly, everything just works. One other consequence of the Start Menu pinned shortcut is that it always opens Fallout in low-res, while directly evoking the executable opens in high-res.

    To answer your questions: It didn't start happening until after I got healing powders made by Hakunin. Then it would break on every NPC I talked to who engages in dialogue. It was working flawlessly up until that point. I never tested it without the RP, but I can say in 15 years I've never seen this bug before in the base product. Then again, I only started playing on Vista 5 years ago.
     
  12. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Ah, so that was your problem. Interesting. Not many are using that thing.
    I tried to pin fallout2.exe myself and got the same crash.
    It's a problem with the high-res patch not loading properly. Low resolution, no extra save slots, and no hero appearance mod, in addition to that weird crash (probably a problem with calling up the dialog window).
    If you disable the high-res patch before pinning fallout2.exe, it will work fine and not crash, but I don't consider that a good option.

    Have seen a couple of bug reports earlier with a pinned Fallout2, but then it was sfall not working properly (error loading cities). I did not get that error now so maybe it has been fixed in sfall (something must have changed anyway).

    I have no idea how the whole pinning thing really works. But it does some strange things. Besides breaking the high-res patch and earlier sfall, it also makes it so you have to have exact folder paths in fallout2.cfg ("master_dat=master.dat" no longer works).
    Basically, when pinned, fallout2.exe is partly treated as if it is run from another folder than what you installed the game to.

    So for now, do not use "Pin to start menu".
     
  13. Mactab

    Mactab First time out of the vault

    33
    Jun 20, 2008
    Glad you were able to reproduce it yourself!

    Ah, thanks for the background. That's ridiculous that Windows works that way. I would expect it to just be a simple shortcut so there would be no difference between using the shortcut and the EXE. Like having one method that simply wraps another method: the output of the two should be consistent (intuitively).
     
  14. BLOK999

    BLOK999 First time out of the vault

    1
    Feb 27, 2013
    Hello, very interestingly to know the date of release of this excellent mod)
     
  15. Jerico

    Jerico First time out of the vault

    15
    Nov 30, 2006
    Has the 2.2 versio already been released, and have I missed it.....just asking since last post in this BETA thread is month old?
     
  16. Matthews

    Matthews It Wandered In From the Wastes

    193
    Aug 29, 2012
    Still working on it, as I reckon. He'll tell when it be done this time about.
     
  17. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Yeah still in beta. Busy with life and not in the mood to mod during my free time.

    It's so close though, so I'm going to buckle down soon and get this out. It's about damn time. 8-)
     
  18. wargus

    wargus First time out of the vault

    9
    Feb 4, 2013
    Damn real life... Always takes priority and slows people down :P

    Are you going to post on this board when you release 2.2 or are you going to start a new topic?

    You are the best Killap! I can't wait to see the finished product.
     
  19. kungfujoe

    kungfujoe First time out of the vault

    83
    Sep 28, 2008
    Historically, Killap has done both. He's posted to the old thread with a pointer to a new thread and locked it down, and then posted the full changelog and feature list in the new thread.
     
  20. memetics

    memetics ☢ Mysterious Stranger ☢

    214
    Jan 2, 2009
    Testing variants

    Fellow beta testers:

    I'm curious as to the thoroughness with which we've banged on this version so far. Can the testers confirm that someone has tested each of the extremes of character stats, for example:

    - ST 10
    - ST 1
    - PE 10
    - PE 1
    - EN 10
    - EN 1
    - CH 10
    - CH 1
    - IN 10
    - IN 1
    - AG 10
    - AG 1
    - LK 10
    - LK 1

    (Feel free to reply and mark which one you've tested.) What other specific things do we want to be sure to test, and document here... each of the operating systems we've installed the RP on, perhaps? Anything else, either that we've tried or that ought to be tried?

    -m
     
Thread Status:
Not open for further replies.