Fallout 2 mod Fallout 2 Restoration Project 2.2 (Unofficial Expansion)

Discussion in 'Fallout General Modding' started by killap, Jul 21, 2013.

Thread Status:
Not open for further replies.
  1. coldroll

    coldroll Fuck Bethesda

    189
    Jul 4, 2012
    I just tried it and it works for me. Are you using an old save game because that can cause new options in the installation to not work.
     
  2. .Pixote.

    .Pixote. Carbon Dated and Proud
    Modder

    Sep 14, 2009
    I think Timeslip removed that function in the last release of the Sfall, an earlier version might fix the problem.
     
  3. gvx

    gvx First time out of the vault

    86
    Apr 4, 2008
    Sfall http://sourceforge.net/p/sfall/code/244/
    Update project to visual studio 2012
    - HMODULE h=LoadLibraryEx("d3dx9_42.dll", 0, LOAD_LIBRARY_AS_DATAFILE);
    + HMODULE h=LoadLibraryEx("d3dx9_43.dll", 0, LOAD_LIBRARY_AS_DATAFILE);
     
  4. kungfujoe

    kungfujoe First time out of the vault

    83
    Sep 28, 2008
    Sticky mouse in FO2RP 2.2?

    I've finally had some time to install the new RP, on a fresh copy of Fallout 2, and I'm noticing that even on the main menu screen and options screens, I'm having a lot of mouse troubles. The mouse movement gets "sticky," just as it does when there's something partially blocking the sensor, and the mouse cursor will move freely and then get "stuck" until you shake the mouse. Unfortunately, this is only happening in the game, and not elsewhere in Windows, so it's unrelated to the mouse sensor itself. It makes the game pretty much unusable (i.e. it works, but the inconsistent cursor movement is unbearably frustrating).

    I don't remember having this problem in the previous release version (I never installed the 2.2beta).

    To make matters even more confusing, I'm seeing this problem on my desktop (Logitech G500 Gaming mouse) but not on my laptop installation with the machine's built-in trackpad. Both machines are running Win7 x64, both have the game installed in C:\Games\Fallout2, and both are installed from a physical disc copy of FO2 (1.02 - it's the one that was sold in the "Dual Jewel" pack along with Fallout)

    Any clue what's causing this? Is there a config setting I need to change in-game, or something I need to change in the mouse drivers?

    EDIT: I enabled the BackgroundMouse option in Sfall ddraw.ini, and that seemed to help a LITTLE bit, but there's still significant cursor lag.
     
  5. Mirak

    Mirak First time out of the vault

    51
    Jul 17, 2010
    Not really sure if it's a bug, but it's weird, because I don't think that vanilla F2 does this. It doesn't really occur every time I try this, but when I use Steal on one specific generic Arroyo tribesman I instantly lose 3 karma points. I didn't even try to steal anything, just using the Steal did that.

    The whole randomness of this got me thinking if this is some kind of failed Steal check that occurs when I use Steal on someone, but then again, it happens only with that certain tribesman.

    Here's the savegame (Charname stands near that villager), I report it to wiki once someone confirms that it's indeed a bug.

    https://www.4shared.com/rar/1FbGoIOR/SLOT01.html

    Edit: Ok, so it happens with other generic tribesmen as well (male and female).
     
  6. Michi

    Michi First time out of the vault

    60
    Dec 7, 2009
    Ok, it seems sfall v3.0.7 removed the control NPC ability, which is extremely sad.

    Will anything bad happen if I play RP2.2 with SFall v2.20?
     
  7. stex

    stex First time out of the vault

    3
    Jul 25, 2013
    I have two questions and I don't find the answers :
    - Should I install the official 1.02 patch before installing the RP ?
    - Can I install the RP on a French Fallout 2 ?
     
  8. theyellowlemon

    theyellowlemon First time out of the vault

    4
    May 15, 2009
    i think you may find both answers here: http://falloutmods.wikia.com/wiki/F2RP_Technical_Info

    now i have a question for someone. is anything like http://falloutmods.wikia.com/wiki/Global_Shaders already included in the RP? if not will this mod be compatible with the RP? im just trying to get the best looking fallout possible.
     
  9. gvx

    gvx First time out of the vault

    86
    Apr 4, 2008
    sFall + Multiplayer.cpp +Multiplaye.h
     
  10. BrecMadak

    BrecMadak First time out of the vault

    93
    Jul 5, 2010
    If this is valid, then indeed why in the first place this ability got removed, may I ask ?
     
  11. stex

    stex First time out of the vault

    3
    Jul 25, 2013
    Thx yellowlemon, it solved my problems.
     
  12. Matthews

    Matthews It Wandered In From the Wastes

    193
    Aug 29, 2012
    You're stealing from your own tribe in their time of need, resulting in loss of karma. You get loss of karma for looting cash in other areas as well if that cash was for something else, which makes me believe that this feature got added with the intent to further stress that you are to SAVE your tribe, not to make the situation worse by stealing from them.

    But that is just me guessing.[/list][/code]
     
  13. Michi

    Michi First time out of the vault

    60
    Dec 7, 2009
    I don't understand what "AmmoMod.cpp +AmmoMod.h" means ...
     
  14. Michi

    Michi First time out of the vault

    60
    Dec 7, 2009
    From what I can see, and I could be wrong, it was a casualty of SFALL removing the multi-player capability.
     
  15. gvx

    gvx First time out of the vault

    86
    Apr 4, 2008
    fcdokwrk.msg
    {125}{}{}
    {126}{}{}
    {127}{}{}
    {128}{}{}

    Is normal?
     
  16. gvx

    gvx First time out of the vault

    86
    Apr 4, 2008
    Multiplayer.cpp “ControlPartyMembers” https://dl.dropboxusercontent.com/u/69453016/Multiplayer.cpp
     
  17. gvx

    gvx First time out of the vault

    86
    Apr 4, 2008
    DCFLICK.MSG

    {260}{}{I'm a fuckin' provider, whaddya think? I'm like a good Samurai-itan guy.}


    #{410}{}{Well fuck me sideways, look who came by. The good samaritan who "saved the children" decided to grace me with his presence. You know, I'm a good Samurai-itan guy myself -- providin' fer them little paisanos and all. That is, until you came along and made that fuckin' orphanage idea a reality.}


    what is "a good Samurai-itan guy" ?

    I don't know the meaning of it?
     
  18. Glovz

    Glovz Vault Dweller
    Modder

    736
    Sep 16, 2005
  19. Guynemer

    Guynemer First time out of the vault

    1
    Jul 29, 2013
    Long time lurker, first time poster...

    I know this isn't a 2.2 issue, as no one else is having this problem; I know because I have looked everywhere, here and elsewhere on Google, and have only found one other report of this a few years ago, which seemed to self-resolved.


    After wiping out Metzger & crew and grabbing Vic, I am unable to leave the East Side of The Den. If I try to go to the world space, or the West Side, the game CTD. I've never had this on previous playthroughs with earlier versions of the RP (or just vanilla). I've tried everything I can think of, including trying to trick the game somehow by waiting, or entering into dialogue, or entering into combat and blowing up a junkie or three... no dice.

    Anyone here ever have anything like this happening? I'm only asking here because you guys on this thread seem like the most knowledgeable group of all the old timers. I could go back to my non-quick save (back in Arroyo), but I'd like to avoid that if at all possible to avoid going through all the Klamath stuff again.
     
  20. Nibiru

    Nibiru First time out of the vault

    22
    Oct 12, 2012
    at least the mod is out :clap:

    BUT two things disappoint me: why the fallout 1 sound of 14 mm and such is no longer an option, and why there is still no more skins for the hero ?

    Regards
     
Thread Status:
Not open for further replies.