Fallout 2 mod Fallout 2 Restoration Project 2.2 (Unofficial Expansion)

Discussion in 'Fallout General Modding' started by killap, Jul 21, 2013.

Thread Status:
Not open for further replies.
  1. Rez

    Rez First time out of the vault

    4
    Mar 17, 2012
    I am sorry, but I don't understand it either.
    What do you mean by this?
    Where should we put these files? I don't see them in the first place...
    Code:
    rez@pc00:/cygdrive/c/home/games/Fallout 2$ ls -lahR | grep AmmoMod
    rez@pc00:/cygdrive/c/home/games/Fallout 2$
    
    Are you suggesting we should recompile sfall from source? =)
    Could you please post step-by-step instructions if that is the case?
    Thank you in advance.
     
  2. kungfujoe

    kungfujoe First time out of the vault

    83
    Sep 28, 2008
    Re: Sticky mouse in FO2RP 2.2?

    No one has any idea how to address this mouse lag problem if it's not fixed by setting the BackgroundMouse setting in ddraw.ini? This issue unfortunately makes 2.2 unplayable on my primary machine. :(
     
  3. Cooper

    Cooper First time out of the vault

    3
    Jun 2, 2012
    wow this is great!

    I've followed, played and waited on this RP for many years.

    Thank all of you for your dedication and work to this game.

    At one point, there seemed we would never have a Fallout 3 or New Vegas and after having played F2 dozens of times, it was awesome to play again on the RP.

    BTW, this September marks the 15th anniversary of Fallout 2's release. How fitting the "gold copy" of the RP is released in time ;)

    I'll be spreading the word about this for certain!
     
  4. theyellowlemon

    theyellowlemon First time out of the vault

    4
    May 15, 2009
    Re: Sticky mouse in FO2RP 2.2?

    im actually having the same issue. its been years since ive last played so i dont recall if this happened in previous release of the RP. im also using a G500, not sure if that could be the cause.
     
  5. crazy_typ3r

    crazy_typ3r First time out of the vault

    10
    Jun 13, 2013
    WOW GUYS! I found a super sledge hammer hidden in the bush during special encounter with enclave troops. They came flying in their vertibird to find ahem "someone" who pissed one of them @ GECKO TERMINAL !!

    DEFINITELY not a cheat !
     
  6. Darek

    Darek is currently unavailable

    Jan 7, 2008
    I just wanted to say that I have updated the walkthrough for the RP to version 2.2

    Was a bit stressed to get it done before going on vacation, so there may be some errors or something I've missed. Please report anything strange here.

    Also, would be good if you could proof read it too, killap (since you asked for it). :wink:
     
  7. coldroll

    coldroll Fuck Bethesda

    189
    Jul 4, 2012
    Re: Sticky mouse in FO2RP 2.2?

    I get mouse lag too but not as bad as you're having what kind of mouse are you using? Also I was recently replaying fallout 1 with the Fallout 1 Megamod and noticed a really cool feature that would be great in this mod. When a npc is in the way you can tell them to get out of your way and the game moves them to another spot.
     
  8. Uaine

    Uaine First time out of the vault

    36
    Dec 2, 2004
    I'm not there yet so I can't really check, but does the neural interface in the hubologist stash have a purpose? You don't mention one, yet it is notable enough to list - will the purpose be obvious when I get there?

    To those with mouse issues - I haven't had any mouse latency issues. Do those problems still occur if you run from a clean copy of Fallout 2, prior to installing the RP?
     
  9. Philos

    Philos First time out of the vault

    25
    Jul 24, 2013
    FO2 Craashes

    For the first time I while playing FO2 I have since installing the RP 2.2 been experiencing a countless number of crashes that necessitate restarting my computer in order to continue playing the game. This became especially a problem while having to eradicate the Mordino family in New Reno after assassinating Mordino. This has also made me want to reinstall the previous version of of RP but unfortunately I deleted my copies of it.
     
  10. coldroll

    coldroll Fuck Bethesda

    189
    Jul 4, 2012
    You should make sure you've updated all the drivers for your PC, I haven't experienced any crashing on my PC so far. You should also get some compressed air and try cleaning your PC depending on how old it is.
     
  11. Philos

    Philos First time out of the vault

    25
    Jul 24, 2013
    FO2 Crashes

    It's only FO2 that has been crashing - I have had no crashes with any other program.
     
  12. Matthews

    Matthews It Wandered In From the Wastes

    193
    Aug 29, 2012
    HINT: Never, and I mean NEVER ask Marcus to remove his armour if you've got him that (unless you just hate the model, which is sad if so). Cannot re-equip it afterwards.
     
  13. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    He can re-equip the armor. It has to be done with dialogs, not the button in the combat interface.
     
  14. Matthews

    Matthews It Wandered In From the Wastes

    193
    Aug 29, 2012
    Ah, good to know that. Exact ways to do that (just to be certain)?
     
  15. Endocore

    Endocore Look, Ma! Two Heads!
    Modder

    365
    Mar 14, 2010
    Does the autoinstaller version of the mod use a precisely and in each and every tiniest detail identical fallout2.exe for Windows XP, Vista, and Windows 7 installations? Thanks.
     
  16. agris

    agris Still Mildly Glowing

    245
    Jul 8, 2004
    Just chiming in here regarding the 'sticky mouse' issue. I too have it, with my Logitech G5 (it's an oldie but a goodie). Win 7 64 (enhanced pointer precision is enabled on the Win mouse settings. Disabling it and running F2 w/ RP 2.2 re-enables it. Clue?) Using DX9, 16 bit color and 1280x800 in the high res patch config settings.

    I thought this was due to some sort of mouse acceleration being applied (i'm still not convinced it isn't at fault). Could this be a problem of the high resolution patch routing input through DX9 and applying some overly zealous mouse smoothing / acceleration?

    If those of you having the issue could post your high res settings, and mouse specs, it could help getting to the bottom of it.

    EDIT: Fixed! Go to f2_res.ini in your f2 install dir, and change

    'SCALE_BUTTONS_AND_TEXT_MENU=0' to
    'SCALE_BUTTONS_AND_TEXT_MENU=1'

    The mouse FELT like it was running along.. how to put this.. a lower resolution grid than what my screen was showing. It took more physical mouse movement than I thought was necessary to traverse diagonally, and up and down. Something with the scaling in the resolution patch is seriously fubar'ing mouse input. I bet how bad it is is related to the resolution you play at. The higher the resolution, the worse the mouse problem.

    Anyway, hope that helps others.

    Edit2: In the spirit of scientific inquiry, I disabled my fix (so the above = 0), and set a lower resolution (960x600). The problem was gone (or just didn't manifest at an observable level). I don't have the vocabulary to properly describe it, but the problem is clearly related to the resolution the mouse thinks it has, vs. what is rendered on screen.
     
  17. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Popping back in after crazy work deadlines and moving into a new place.

    I'm still not settled in yet (I always forget how much moving really, really sucks), but when I am, I'll release an update to address the installer issue with Steam and any current standing bugs. I was going to wait until the translations are done, but the Steam issue is too much to leave until then.

    So, expect a minor update soonish. 8-)

    @agris: Good find

    @everyone: Those bug reports better be finding their way to the wiki. ;) Wiki looks sparse, so I'm not sure I'm being listened to, since skimming this thread I'm seeing new issues only on here. Oh, and thanks everyone for helping each other out with questions. I'm not around enough to answer them all.
     
  18. Dravean

    Dravean Where'd That 6th Toe Come From?

    478
    Mar 6, 2005
    I only skimmed through some parts, but this error stood out to me:

    There are now three ways, including Dr. Sheng (as you note in the Dr. Sheng section of the walk-through).
     
  19. Mirak

    Mirak First time out of the vault

    51
    Jul 17, 2010
    Using the Anna's diary in Your inventory does nothing. I didn't get 100 exp. There's just a short excerpt from the diary (the clue) if You examine it.

    Also, in Figure out who is rustling the Brahmin quest, You don't need to confront Duntons about the limbs. You can just show them to Mrs. Buckner. (Although, I'm not 100 % sure about this and I don't have any savegame to confirm this, so I'm sorry if I'm mistaken)
     
  20. kungfujoe

    kungfujoe First time out of the vault

    83
    Sep 28, 2008
    Thanks for the reminder on the bug report wiki. I'll put something about the mouse stickiness in there. I can't confirm the fix, since I'm on business travel, away from my primary PC and the affected mouse, but I'll note it.

    Fortunately, I have other mice, so if the problem is really limited to the Logitech gaming mice, and the fix above doesn't work for me, hopefully I can hook up a secondary mouse for FO2. Not ideal, but totally workable.
     
Thread Status:
Not open for further replies.