Fallout 2 Restoration Project 2.3.2 (Unofficial Expansion)

Discussion in 'Fallout General Modding' started by killap, Jan 2, 2014.

Thread Status:
Not open for further replies.
  1. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Yup, save games will be compatible. Of course any map related fixes will require you enter the area for the first time for them to take effect, but there aren't really any important map fixes. I always highly suggest starting anew for the best experience, but it's not required.
  2. Chad669

    Chad669 Thank God i'm an atheist.

    Mar 31, 2014
    So i will start anew ;)

    Do you plan a lot of new/edited text lines?
    I ask cause i just offered help with polish translation and they seem like 95% done with RP 2.3.2

    EDIT: my bad, Juraszka finished 2days ago ;)
    Last edited: Apr 7, 2014
  3. Juraszka

    Juraszka Polish Translator

    Apr 7, 2014
    Welcome killap :wink:
    I finished work on the polish translation for Restoration Project 2.3.2 and like my friend from Vault 13 Community, I would like to know one little thing...
    Do you plan to modify or add new files with something that requires translation ... If yes, which files I will need to translate?
    Of course, this will be useful for another language translators!

    Thanks for all,
  4. Kane Vollstrecker

    Kane Vollstrecker First time out of the vault

    Feb 7, 2014
    This Mod is Translated in Polish,French,Russian,Brazilian...but German People are very Lazy and have not translated yet...:irked:
  5. soulmata

    soulmata First time out of the vault

    Jul 8, 2008
    I tried searching for this question, but found nothing, so my apologies if this is a dupe.

    I love FO2RP. There is one gripe I have that I can't find a solution for.

    With the RP installed, every random encounter I join puts me dead center in the middle of the encounter.

    In the original FO2, I recall that my PE affected how far away I was from the encounter itself. With high PE, I would be far enough away from the encounter that if i wanted to run, I could. Now, with the RP, even with 8 PE, I'm always spawned directly in the smack-dab-middle of it. This makes thing unreasonably difficult, particularly in the early game, since I quite often am spawned directly in the middle of a band of robbers or slavers packing SMGs. Last night, I was spawned literally adjacent to an SMG-wielding slaver that killed Sulik in the first round before I'd even acted.

    I have to say this seems like a bug to me. It's been around in the RP for a while, at least as far back as I remember using the RP, and doesn't seem to fit in with the entire purpose of PE and Outdoorsman.

    Has anyone else noticed this? Is there a way around this or to fix it?
  6. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    I don't believe I added any new text. Just typo fixes. I'll double check what text files were changed between the upcoming release and 2.3.2 though. I'll let you know. And if you don't hear back from me soon, please send me a pm.

    Where are these French and Brazilian translations you speak of? I know of an old French translation, but nothing for the 2.3 series. And there was an old German translation too, but it never got updated as far as I know.

    @ all translators
    If you do have a complete translation, I'd like to bundle it with the RP installer. We want to make everyone's lives easier you know. :)
  7. Felipefpl

    Felipefpl Look, Ma! Two Heads!

    Jun 17, 2010
    Hi killap, several entries on wikia dont have a status - NOT BUG, UNCONFIRMED, ETC, ETC - there are several entries there that didnt get your answer. ;)
  8. djdunn

    djdunn First time out of the vault

    Apr 10, 2014
    I cant believe that the RP keeps getting better and better.
  9. Chad669

    Chad669 Thank God i'm an atheist.

    Mar 31, 2014
    I know it's not a bugtracker but i don't know is that even as bug as just some engine anomaly of f2 itself (never seen it before doe, then again didn't played much either).
    Anyways it was strange enough to share i think,
    so on a change of map from vault city's courtyard to a downtown's main gate, i and up not in front of the gate but in klamath, on "helping Torr" map to be exact, WTF? xD

    Anyhow it worked properly on a reload, but still - xD
    Last edited: Apr 13, 2014
  10. Chad669

    Chad669 Thank God i'm an atheist.

    Mar 31, 2014
    Spotting Raiders thingy dosen't seem to work for me anymore.
    Anymore cause on the first day in the Vault City, when i was introduced to that perticular problem by the Stark, the "spotting Raiders" message pop uped on me on my way to Geco but i decided to leave it for later.
    So i'm now a pround citizen of VC(Vice City, lol xD), done all the quests i could, get the car.
    (but yeah i'm leaving the car, and walking out of VC)
    So i'm like completely ready to kick some raiders asses but i just can't trigger this again.

    Which brings me to a questions:
    -Is that spotting raiders is a one time thing only?
    If yes then... why the hell? ;) and is it possible to reset status for this one?
    -Or am i just missing something?
    Last edited: Apr 15, 2014
  11. NovaRain

    NovaRain Casual Modder Modder Moderator

    Mar 10, 2007
    It depends on the time of the day and your Outdoorsman skill.
    There's a link for RP walkthrough in the first post.
  12. Chad669

    Chad669 Thank God i'm an atheist.

    Mar 31, 2014
    Which i checked and fallowed,
    never the less no luck with another triggering of the "spotting".

    EDIT: Is it plausible that it is because i change status, i mean i'm a citizen now and it's like i don't need to prove anything to anyone there anymore ;P and the quest just gone death?
    Last edited: Apr 15, 2014
  13. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Your first guess was the correct one. It's a one time only thing. The reason is probably a technical one (using a map variable to save on the global variables), but I agree with you that you should be able to get it again as long as you haven't actually visited the raider base.

    You can reset the map variable with F12se.
    Choose your save. Press "World map" tab. Scroll down and select "VCTYCTYD.SAV". Press the edit button. On the new window that pops up, select "7:MVAR_Saw_Raiders" and change the "1" to a "0" in the value field. Press save and then press save again (probably not needed but just to be sure).
    • [Like] [Like] x 1
  14. Chad669

    Chad669 Thank God i'm an atheist.

    Mar 31, 2014
    Tested, works.
    Thank you @Darek that was exactly what i was looking for.

    All doe i'm in Broken Hill already and probably get Bishop map before going back to VC,
    i will keep this one in mind for RP 2.3.3 playthrough ;)

    EDIT: by the way the "second save" clicking that Darek point out is probably not so pointless actually, cause in my understanding first you save the variable of the edited .sav (so the element of the file you have well, on the table figuratively speaking) and the second save button in the main window actually changes the edited file over the original one.
    Didn't checked doe cause, ain't no body got time for that xD
    Last edited: Apr 16, 2014
  15. FOvet

    FOvet Wandering the Wastelands

    Aug 26, 2012
    Heya Beardude! I'm a long time fan of your RP, as you well know, and I always make sure to get your latest mod soon as I know it's out. Fantastic work!

    That said, for the first time, I'm being hit with some WEIRD effing bugs. Ever since I went to the Sierra Army Depot map, I've been having completely random game crashes!! The first time it happened, I was in the Sierra Army Depot map, the Battlefield--I was in the room with the Howitzer, and tried to search one of the shelves. My game just shut down.

    The second time it happened, it was in the control room where you talk to Skynet. I was just examining a computer, when the game just shut down. I haven't had the heart to try a third time, because I lost about an hour of game time during that last crash :c

    The only other mod I'm running is the latest Miria Mod. Although, I should note that I used F2SE to give my character extra chems so I could recruit both Kitsune AND Cat Jules, but I did that ages ago and never had any of these issues, so I don't really see that causing the issue.

    Finally, I'm using the Fallout 2 from GOG (though I also have my own installation CD I could use if GOG's version is the problem. Again tho, I don't think it is, given it JUST started happening). These crashes have so far only happened within the Sierra Army Depot. Figured I should report this, in case it's a bug within the RP :)
  16. DemonBlade

    DemonBlade First time out of the vault

    Apr 20, 2014
    Hello. Firstly i would like to thank those involved in making this mod especially Killap:cool:

    Ive recently started trying mods on some of my other games and it got me wondering if fallout2 had mods as well and here i am and the RP mod is exactly the kinda thing i was hoping for when i started looking however i am getting an error when i start up the game after installing the mod

    its "wmAreaInit:: Error loading cities!"
    The RP version is 2.3.2 From the Windows Installer

    Fallout2 is installed from the Double Pack CD at V 1.02

    Im Using Windows XP with i believe SP3

    I would appreciate any help with this issue as im dieing to play this mod
    Note: The game works fine without the RP
    Note2: I tried installing the RP with various settings including no extras and it still gave the error

    Thanks in advance to anyone who is willing to help

    • [Like] [Like] x 1
  17. Drobovik

    Drobovik Vault Archivarius Modder

    Jun 20, 2011
    Your fallout2.exe is not patched for extra locations added in RP. Try downloading manual install archive of RP from killaps signature and extract flies from folder Win xp-vista-7 into your RP installation folder replacing the files.

    EDIT: Could be an issue of fallout2.exe compatibility settings turned on. Right click on exe file and uncheck any options under ccompatibility tab.
    Last edited by a moderator: Jan 9, 2016
  18. Paul_cz

    Paul_cz Mildly Dipped

    Jun 11, 2008
    So... I just finished my last playthrough of Fallout 2, first one in some 5 years or so. First time with Restoration Pack (2.3.2).
    Gotta say, incredible work all around. All the new content, from quests to locations to features, is perfectly integrated and seems like it was always part of the game. The design and writing and all that, it could have been in the game from Black Isle and I would not know any different. So yeah, thanks.
    EPA and Abbey are both awesome locations. I love the music in Abbey, particularly. EPA has awesome pay off, with the three new possible companions. I saved and revived all three to see what they were like. Ended up with Kitsune, obviously :smile:.
    I did not encounter any bugs at all in my entire playthrough! And the only time the game crashed, was sometimes during meeting Kaga. So I just avoided him and did not kill him. But otherwise I did every single quest I could, these are my stats right when I arrived at the oil rig:

    Cassidy and his talking head is awesome. The voice acting took a while to get used to, but it is ok too.
    And the final special star wars themed encounter was awesome :).
  19. DemonBlade

    DemonBlade First time out of the vault

    Apr 20, 2014
    I did have a compatibility option for win 95 on...but when i take it off i get a "could not load directX" error message and thus still cant get anything to work

    I will try and download the manual install and see if i can make that work
  20. Drobovik

    Drobovik Vault Archivarius Modder

    Jun 20, 2011
    Ok, then to remedy the directx issue. Keep compatibility settings on off and from manual install archive, folder main, copy four d3dx9_xx.dll files (or you already have them in RP folder?) along with files from folder Windows XP-VISTA-7-8.

    To note, I can probably troubleshoot your problem better if you post a screenshot of your RP folder with all the files in it. There's just something prevents sfall tweaks (ddraw.dll) from kicking in.

    EDIT: Did a little testing. On my system, provided its not WinXP, but Win7, if I CHECK the Wind95 Compatibility option, then it gives me directx error. So, are you sure that you saved the off setting, when you closed the right click popup window?)
    Last edited: Apr 20, 2014
Thread Status:
Not open for further replies.