Megamod 2.43 technical issues and suggestions

Discussion in 'Fallout General Modding' started by MIB88, Dec 8, 2010.

  1. Stave

    Stave First time out of the vault

    26
    May 2, 2010
    Oka, I only hope that MIB also find the solution to the problem with save game, couse I saw that not only I have problem with that.
     
  2. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    Not sure what the heck is going on. The problem seems to persist regardless of what people do and occurs on a variety of operating systems. I've been going over the issue with Nirran, and we just can't find a solution.

    What makes it even harder to narrow down is the fact that I am not having this failure to load problem. My game is working without any problems.

    -Someone already tried removing the global/hook scripts, and that didn't stop the problem.
    -I think somebody said that they tried playing without Klint, and that didn't solve their problem.
    -Everyone seems to have all the critter proto files, so that is not the problem.

    I have another idea. If someone who is having problems could please temporarily remove from the data/scripts folder the following files and tell me if that resolves the issue, I would appreciate it: zicrtrnk.int, breakdwn.int, and obj_dude.int.

    Just move them to a different folder. If the fail to load persists, then we will have to check elsewhere. Note that removing these files will cause the default files to be used and remove a lot of content from the game. This is just to help narrow down if one of these files might be causing the problem. Thanks for your help.
     
  3. Stave

    Stave First time out of the vault

    26
    May 2, 2010
    I delete this files (moved to another folder) and ITS working baby GREAT - i load all that saves whit that problem - and its gone.......
    All save can be loaded, no CTD.
    Start New Game - in Temple no CTD - you can save and load whit no problem like before in 2.42.
     
  4. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    Ok, then it was most likely the obj_dude.int script. You should be able to add back the other two files without a problem.

    If you have an earlier version of that script (obj_dude.int) from a previous MM, then you can add it to your latest game. If others can also confirm this, please let me know.
     
  5. nasasha

    nasasha First time out of the vault

    3
    Dec 15, 2010
    Has put "obj_dude.int" with v2.4. problem with sawe was gone.
    (In Russian) - Поставил "obj_dude.int" с v2.4 проблема сохранениями пропала.
     
  6. Stave

    Stave First time out of the vault

    26
    May 2, 2010
    I put this 2 files back to the Script folder, and I take obj_dude.int from MM 2.42 to the same folder and its oki for now. No problem with loading games.
    THX MIB.
     
  7. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    Sorry for causing that problem. I was trying to add a new feature to the game, and I accidentally included my test dude_obj.int file.

    (For those who are curious, the test involved power armors. I was trying to come up with a way to make it so that, if the player character was hit with an EMP grenade/blast, the power armor would be destroyed and replaced with a piece of worthless armor.)
     
  8. bonczyk

    bonczyk First time out of the vault

    13
    Jul 27, 2007
    I think this error has already been reported but I haven't seen a solution - whenever I enter Broken Hills, I get memory error....


    EDIT

    sorry, its ok now, removing obj_dude.int from 2.43 and substituting it by obj_dude.int from 2.42 solved it:)

    I confirm that it also solved problem with corrupted saves - until now, I had to change my location each time after I made a save, because double saving in the same location caused the second save to be corrupted. Now the problem is over

    thanx
     
  9. yghern

    yghern First time out of the vault

    57
    Aug 7, 2007
    Well, technically, it still would be Power Armor, just without motivators running. You should remove STR bonus, add STR requirement and maybe reduce AP by one or two points. Its still would be a metal-ceramic heavy armor, far more protective than f.e. Metal Armor.
     
  10. Blackened

    Blackened I should set a cutom tite

    598
    Jun 29, 2008
    So, did you think of a way to destroy the armor? Would that work for critters? If yes, then would it be easy to make a specific type of weapon to destroy armors (or have a chance to destroy armors)?
     
  11. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    I can destroy the armor without a problem. And I can create the new armor, in the dude's inventory without a problem. The full plan was to destroy the power armor. Not 'destroy' how it is usually meant, but how it is meant within scripting. So:

    -The power armor would be destroyed, replaced with a piece of junk armor.
    -The armor could be worn and still provide a decent AC.
    -However, because all electronics are out, it would have to be moved by the player instead of being powered (i.e. the servomotors would not function, like yghern suggested).
    -While the armor could still be worn, it would not come with a strength bonus, of course. But, I took it even further, so that if the player character was wearing it, it would (temporarily) cripple all limbs. :twisted:
    -Possibly allow for the armor to be repaired by getting the right parts, having a proper work station, and/or having the right skills.

    I was just talking about more of this with Nirran a short time ago. He provided me with a code that should help me make the rest of my ideas a reality. Once I get it working on the player character, I'll try to get it working for party NPCs and other critters.

    As for making a weapon to destroy armors, let me get back to you after I get it working. I really want to get this idea working. Could you imagine the player, walking around the Wasteland thinking he is invincible in his power armor, suddenly shot by an EM turret that is defending some ancient base? Buh-bye power armor.
     
  12. Besprizornik

    Besprizornik First time out of the vault

    1
    Jan 13, 2011
    I have a new problem with mm. After when I cured lenny in BOS Research he is invisible. I can't talk with him etc. What can I do with it?
     
  13. mac402

    mac402 First time out of the vault

    6
    Jan 13, 2011
    I'd like to point out 2 issues that (I think) weren't mentioned yet:

    - the Poker-guy in Klamath has his answers text get permanently highlighted when pointed with the mouse

    - in a slaver camp (discovered from Metzger in Den), when the slave pen is open and the slaves run away the game crashes (something like with Whisky Bob in earlier post). I think it happens when the slave reaches the border of the map
    EDIT: seems not always, it didn't crash once and I don't know why

    Also I have selected an option in ddraw.ini that makes the NPCs automatically level up according to my PC level. I don't think this is happening - there is no text of levelling appearing. I boosted up my player level with an editor. Sulik has 85 hp, Vic has 70, Klint has 200 - is that ok? (I haven't played FO2 for a while)

    EDIT: Also the burst mode of weapons still is broken and doesn't hurt anyone.

    Another thing: Fire Geckos (in a cave in random encounter) sometimes drop their weapon when hit ("Fire Gecko Flame Breath" or something like that)

    OK, another update: seems the burst mode can be fixed by setting CorpseLineOfFireFix=1 instead of 2 in the ddraw.ini. The dropping weapons stuff is probably regulated by the damage.ini file... will try.
     
  14. Stave

    Stave First time out of the vault

    26
    May 2, 2010
    Hm nice idea MIB with this P. Armor.
    Now: in this ver. is still the same bug like in 2.42 - Sajag EXP. In Toxic C. you must kill Gekos and bring the palts to the chief of this EXP.
    EASY, but one of the GEKOS is inside the wall and you can't kill it. You need 5 kills but you can only do 4.
    When you enter to the cave you have one Geko, if you go deeper and turn left and than turn right you found another one, and near this one you will find this Geoko inside the wall.

    THX this little one you can't finish the evil way in Klamath.
     
  15. kkeciap

    kkeciap First time out of the vault

    2
    Jan 10, 2011
    Hello.
    I'd got some problems with megamod.

    1. Application error "An integer divide by zero was encountered at address xxxxx". I got this error in 3 cases.
    a. Lara's quest in den -- fight near the church
    b. slaver's camp location -- fight with slavers.
    Fo2 throws error right before my second turn. Removing data\scripts\hs_ondeath.int provides additional 1 or 2 turns, then crash.
    c. Situation "Female character with strength 5 puts Metal Armor Mark II on and does first step" also throws "Divide by zero" error.

    2. Problem with car's trunk. I buy car in den, smitty upgrades it, i load trunk with stuff and ride to any point of global map (1cm from Den for example) without random encounters. Trunk becomes empty. :[

    3. A little bug in collyweb. After quest "kill lumpen leader" you can talk with his brother Josie about his future life time after time and gain 130 XP repeatedly.

    Some details. Running on Win7 64bit, fo2 1.02d US, installer from nirran.com. (deleted patch.dat, all proto-files are read only), data\scripts\obj_dude.int from 2.42 to fix save\load "The memory could not be read from" error.

    Is there solution for 1. & 2.?
    Thanks.
     
  16. mac402

    mac402 First time out of the vault

    6
    Jan 13, 2011
    Kept on playing. I really like the mod and it's ideas. However here is more bugs:

    1. Dialog with Skeeter in Gecko freezes (not just crashes) the game when he is to make me a weapon mod for free in exchange for a 3-step plasma regulator. I also noticed that when I bring him the regulator and tell him that I will decide later what I want I still have the plasma regulator in my inventory.

    2. When I get the 2 car parts to Smitty in Den he says he will sell me the car for $5000 but actually it costs $2000. Also he does not take the fuel cell regulator. I can tell him to install it for $750, but I lose money and still have the regulator in my inventory.

    3. The car itself seems broken. The items you put in the truck dissapear. Also, the colors of the car are strange.

    Last time I played the MegaMod it was ver. 2.34 and I don't remember these 3 bugs. What gives?

    And I wrote that the guns burst fire can be fixed by changing the settings in ddraw.ini - it actually still is rather not reliable. Is this the fault of the sfall engine or this mod?

    Anyway I hope you guys will succeed with those bugs. Best regards.
     
  17. bonczyk

    bonczyk First time out of the vault

    13
    Jul 27, 2007
    I also had a problem with stuff dissapearing from car trunk, but only when I've put my stuff in there after I had bought the car, but BEFORE I started the engine for the first time (when the car was still in front of Smitty's house). Try not to use the trunk until you park your car somewhere else, it worked for me.

    regarding the burst mode - I confirm that it usually does no damage (even from such weapons as minigun)....
     
  18. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    Thank you all for the reports. I will get these issues resolved. A few things I will comment on now, though:

    Regarding leveling, sfall, and using an editor: It doesn't work like you think. Sfall (ddraw) checks to level the party NPCs when you level up. It doesn't just check your level. So, using an editor to level up won't impact what level your party NPCs are.

    As for the "breath weapon": That will need to be added to the list of weapons that are destroyed when dropped (much like the turret and deathclaw weapons).


    This will be resolved very soon. A couple of extras will be added to that map in the future, too... just in case.


    Not sure what is going on here. I'll look into this. Regarding putting on the metal armor mk II, though: Does this crash happen every time? What weapon are you holding? Have you added any new artwork to the game? The only time I have ever seen the error is when the player tries to move and there is no artwork for the situation.

    Yeah, the car and trunk have been altered a lot to allow for the Paint Job mod, car breakdown addition, and a few other things. The fix for this will be in the next release/patch.


    @mac402: I need to know something. You already said that you used a character editor to level up. Did you do anything else with the character? Did you just give yourself items too, without completing the quests?

    Regarding Skeeter, I can't replicate this problem.

    Regarding the price of the car, it is supposed to be $5000. I altered the dialog and the script, but then reverted to an earlier version of the script. It will be $5000 in the next release.
     
  19. kkeciap

    kkeciap First time out of the vault

    2
    Jan 10, 2011
    No, i have a clean megamod 2.43 from nirran's site. Yep, fo2 crashes every time, weapons are combat shotgun, magnum with speedloader and without weapon.
     
  20. mac402

    mac402 First time out of the vault

    6
    Jan 13, 2011
    You're right. It doesn't disappear after that. Thanks!

    For burst mode - it works normally now after I have deleted hs_combatdamage.int script and damage.ini.

    Oh, I understand now, got confused when they named it auto level-up in sfall.

    Yes, I used F2SE in the beggining to boost stats and add perks (only vanilla Fallout 2 stuff). I didn't change anything in items or globals etc. I added 3 items to artemple.map with the Map Editor: End Boss Gun & Knife and Frank Horrigan's armor, and I also replaced the item .pro file responsible for Horrigan's armor in Mega Mod but that's all. I got the item for Skeeter legitimately from Gecko power plant.

    The freeze happens every time when I talk to him and want to upgrade items, even before I got the plasma regulator (tried earlier saves). Upgrading works normally in Valeries workshop in VC.

    And here is some new report from me:

    - in the eastern part of Broken Hills (both outside and in the mine) when i click a place to go my character stops several times before going there uninterrupted. Sometimes a message that the way is blocked pops up in the small window but not always (it does not happen because of being blocked, the way is free, the character just stops when walking).

    - I stumbled upon it only once and it crashed my game so I can't give too much info but: I found a map with a letter in a mailbox. When I clicked the "use" icon on it (the letter) it crashed the game.