Fallout 2 mod Megamod version 2.46 Bug Reports and Suggestions - Closed

Discussion in 'Fallout General Modding' started by MIB88, Jun 25, 2014.

  1. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    I could have sworn I fixed that problem... a while ago, in fact. NPCs are not supposed to loot on that map. @NihilistyczneImie , are you using the latest version of the mod? And, you don't have to delete those two files, or else NPCs will not loot on any map. You can just temporarily remove them from the data/scripts folder and then replace them when the gang war is over. I will look at this again.
  2. NihilistyczneImie

    NihilistyczneImie First time out of the vault

    Jun 11, 2016
    Yea, i deleted and problem was solved. This game dont luv (cold heart quest about steal safe in Redding).
  3. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    Sorry, I forgot to answer this. I don't know what is the deal with this. I think I did include some damage calculation fixes. Check out the Damage.ini file to see if there is something there affecting your game. Also, there are two other files in the scripts folder: hs_tohit.int and hs_combatdamage.int. Maybe there is something in those files throwing off the damage calculations? I'll take apart those scripts when I can to see if there is anything inside throwing off the damage calculations.

    What do you mean? That error you posted is just the general crash message. What leads to the crash? Is it repeatable?What do you do that leads to the crash?
    • [Like] [Like] x 1
  4. Hanakoa

    Hanakoa First time out of the vault

    May 23, 2016
    Thanks MIB, will check that out!
  5. zxc-vbn

    zxc-vbn First time out of the vault

    Dec 6, 2007
    In these days, i have played rp2.3.3 with "Economy and combat rebalanced mod", I always got less monsy than befor when something was selled. For getting more monry, i become a true scavengers. it is very funny!
    So,maybe it is a good idea that integration the "Economy and combat rebalanced mod" into "MIB's MegaMod.
  6. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    Yeah, that is the plan to add the "Economy" mod by @phobos2077 . First, though, I have elements of the RP to add in as well as some RP Expansion elements from @Endocore . Eventually, though...
  7. Parto

    Parto It Wandered In From the Wastes

    Jun 20, 2016
    First I must thank you, this version looks much stabile, that previous one ...

    Second, still has some bugs:
    - doctor in SF Chinatown has empty inventory, when I ask him to sell me some stimpacks
    - this stealing script make most of crashes I ve seen in this version of game, like in Suliks village, Den helping Lara and also in RND encouters
    - drop weapon script is the second one that make crash, when some NPC fall and his weapon is droped in e.g. bed or under some crates etc., after that game says the memory could nod read from ... maybe is the same problem
    - when I made upgrade in NCR courtyard - scoped hunting rifle, my hero start rolling to the bootom of map, without move, just like he slide away ... very funny thing, when I start moving, the rolling down stops
    Last edited: Jun 22, 2016
  8. Parto

    Parto It Wandered In From the Wastes

    Jun 20, 2016
    Renesco dont have dialogue options for mine parts, neither for giving him glasses ?
    I talked to him befor I get this quests, so maybe that is the problem, but never seen this bug befor ...
  9. Parto

    Parto It Wandered In From the Wastes

    Jun 20, 2016
    found another one, this make game everytime crash (could not read from memory ...) and also the description of this map is wrong : Arroyo Fishing Area (sholud be Primitive Tribe Fishing Area). when you visit this map and wanna exit ...
  10. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    Thanks, @Parto , for the reports. I'll look at these... but, this bug with the Fishing Area is especially troubling...
  11. Drobovik

    Drobovik Vault Archivarius Modder

    Jun 20, 2011
    Bug with fishing area. No trouble there. Already fixed on my 2.46 setup.): The city.txt was missing an extra line for this map

    [Area 54]
    area_name=Primitive Tribe
    entrance_0=On,125,276,Umbra Tribe,-1,-1,0
    entrance_1=Off,225,170,Umbra Tribe,1,28711,5
    entrance_2=Off,345,230,Umbra Tribe Waterside,-1,-1,0
    Another funny thing happens when you enter coast map, male critters holster their spears and then pull them out again. Female by the tent stands up. Animation plays on map enter. Don't know why the script would play it in such manner? Savegame
  12. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    Thanks for the fix, @Drobovik.
    As for that script, it was made by @Nirran to fire so all the critters on a map with weapons in their inventories would wield them so they couldn't be pickpocketed. It may also have served to reload the weapons with the proper ammunition count, but I can't remember for sure. I don't know why it would cause the woman to stand up, though.
  13. Hanakoa

    Hanakoa First time out of the vault

    May 23, 2016
    I found an odd bug with Myron that locks up combat. It doesn't crash the game, it just continually has him highlighted and doesn't let his turn end like a continuous loop.

    Right now he is equipped with the pulse pistol, but I think it has to do with the doctors bag he is carrying. He will use it, sometimes take a shot or two, use the bag again and then put away his gun and then combat locks up. Also, since he has only 8 action points and some times he uses the doctors bag twice and fires the gun twice, I'm guessing the doctors bag right now takes 0 ap to use?
  14. Parto

    Parto It Wandered In From the Wastes

    Jun 20, 2016
    more bugs I saw in this version:
    - using stealth boy dont give bonus to stealth
    - sometimes in RND encouters in combat enemies attack simultaneously and they dont die, if you kill them then in next turn they stand up again and fight
    - raiders - peaceful solution dont work, the tribal there dont speak with me
    - in vault 23 when you enter elevator in combat mode, the game dont count XP for killed rats
    - english bobs quest - kill treasure hunter in Broken Hills - there is no option for do that, he has no dialogue for well and super stimpacks were disabled as i can see :D
    - when I visit second time the BOS research facility after some time for bio med gel quest, also having Skynet in group for another quest, the general on second floor start combat after 60 second ... so it means there is no way to visit this location twice ?
    - Pretty Boy Lloyds stash in Golgotha - grave isnt connected to the cave with locker, where is the stash, so this quest is also broken, you can still kill him and pay Salvatore from your own money
    Last edited: Jun 28, 2016
  15. Parto

    Parto It Wandered In From the Wastes

    Jun 20, 2016
    Myron - I cant even talk to him, cause game crash
    Carson City - everytime I visit this town game crash, by foot or with car is the same ...
  16. alatari

    alatari First time out of the vault

    Sep 4, 2007
    Cool. I stopped playing for a some weeks and was playing Colonization instead because it's easier to watch TV and play that game at the same time. But I just got a hankerin' to play Fallout 2 again and forgot where to find Sulik's sis so came on to look and noticed you had released 2.46!

    So I tried copying 2.46 over a working duplicate of 2.45.4 and adjusted the ddraw.ini manually. As it seemed like the first post said it was possible to play on old saves, since no files were deleted, I fired up my save game only to get the error:

    "The instruction at 004f11db referenced memory at 00000010"

    Any idea what causes this error?
    Did some searching and seen this error from 2010 and later and someone said something about reinstalling the Restoration Project but it doesn't really look like I can fix this without starting a new game... I'm level 20 and pre-Navarro and weeks of playtime dedicated so that's not happening.
  17. Parto

    Parto It Wandered In From the Wastes

    Jun 20, 2016
    now I tried talk to Myron befor I solved Redding jet problem and game dont crash, but his dialogue options are bugged, only error answers :D
    Wanna try EPA to see if there is everything o.k. but could not find right "error" code so Myron cat tell me that :DDD
  18. APAKane

    APAKane First time out of the vault

    Jun 25, 2016
    I'm having an issue with The Glow Level 4. The elevator which is supposed to take me down to the next level is inaccessible. I get the "You cannot get there" error, and I am unable to step on the hex in front of the door.

    Edit: Looks like this is intentional for now :(
    Last edited: Jun 30, 2016
  19. Dretnoth

    Dretnoth First time out of the vault

    Dec 9, 2015
    Hello, If we talking about EPA then:
    +Can you consider thinking to get entire EPA from different mod? Like RP? (If they alow it.)

    Here some pains...
    -Quest for Cleaning plants dint work. Probably dint count or wrong number to finish. The plants are right on entrance so every one wiped them out in beginning.
    -The aliens on surface have to far sense of detecting.
    -Mr. chemie. (reported.)
    -Toaster on blue level now can be opened like desk. If i remember Former version it do nothing.
    -Doctor: From some moment in discussion i cant ask doctor questions, so its hard to get all info from him.
    -In red level, in the room of Mona Lisa, when player walk on red carpet the surrounding space in room are covered by roof.

    Some Error:
    -In Green Level. There is bug when i can shoot the monsters even the force field is on. They can atack you if you are to close. You can even attack the Deatclaws from some position near the fortified dor.

    Then something else to think. How about something like:

    -Consummation of Alcohol (temporally decrease perception) but it also give temporal bonus Like
    +Bear +armor class
    +Boze +%overall damage resistance
    +Rot Gun (+critical damage chance)
    +Nuka Cola + sequence
    -Or it can have chance for player to poison him but not take perception

    Consummation: Meat or Other Food give Temporal (12h-36h or higher): +Healing Rate

    Buying meal like from mama in Den that heal player:
    -How about buy meal for all my friends or
    -repeat giving food for money until
    A: Player dint full heal
    B: Party dint heal (that script can be tricky)

    Oders to party when dint talk to them like: (Something like pressing key and they do it)
    H- hide weapon
    T- Loot the Area
    R- Regroup: Come to me!
    -Use melee weapons if you have
    -Use ranged weapons if you have
    -Prefer rapid fire
    -save ammo (not rapid fire if can)

    What happens to books for any skills? (one book for one skill) To OP?

    -About Miron: It work fine for me but i dint even visit the Redling yet.
    -About that pretty boy on Goldota: I followed him down and make from example and the gold was there. He says: "This is my money!" Maybe you dint find the hidden stash when you to pushy.

    -I notice when Vic shot out ammo from Plasma pistol it give multiple message "Vic dint have ammo for Ripper" He dint have razor in inv. Something similar i see in previous versions on Sulik, but he have more that one Ripper on inv. But sometimes he put it on even if is empty a dint have any cells.
    Last edited: Jul 5, 2016
  20. Tigran

    Tigran First time out of the vault

    Dec 28, 2013
    Yeah got this when I tried to get into the bridge area of Arroyo.

    Attached Files: