Fallout 2 mod Megamod version 2.46 Bug Reports and Suggestions - Closed

Discussion in 'Fallout General Modding' started by MIB88, Jun 25, 2014.

  1. Parto

    Parto It Wandered In From the Wastes

    Jun 20, 2016
    EPA is too heavy bugged, dont worth a visit at this time (missing dialogue options, unfinished quest options - holograms, useless items - brave little toaster - should teach you perk jinxed for repair, elevators running in empty space ...)
    yup the EPA in Restoation Project works fine, this one ...
  2. Adam Housego

    Adam Housego First time out of the vault

    Apr 14, 2016
    Massive appreciation to the tremendous work that's gone into this. Little help I possible. Can the restoration project and the megamod run concurrently. (ie will they make love or war) Cant get them to run together, apologies if this is a stupid question.
  3. Tigran

    Tigran First time out of the vault

    Dec 28, 2013
    I got the mod working, but I am noticing that I cannot get anyone to give me quests in redding, Like when I suggest that the sheriff could use someone to help him out, then the only reponse I have is to leave. The same goes for Mayor Ascotti.
  4. bombic85

    bombic85 First time out of the vault

    May 22, 2010
    Afair you need to be at a certain level(enough experience) to be able to get quests from the sheriff in Redding.
  5. Dretnoth

    Dretnoth First time out of the vault

    Dec 9, 2015
    Or maybe you have bad reputation.
    Somethin symiliar happens to me in NCR when i the 1. thing i do was wipe out the slavers,but then bad reputation and i can get the job from president or talk to police mens for jobs. Until i save the power plant and reputation got up.

    Okey, something else, i thing script for random encounter:
    *A pack of wild Dogs.
    have isue because include white alliens whit 200 hps. (Mostly 2-3 dogs and 3 aliens)
    Its near Valut city.
  6. Tigran

    Tigran First time out of the vault

    Dec 28, 2013
    I am at least level 11. My rep is 324.
  7. Parto

    Parto It Wandered In From the Wastes

    Jun 20, 2016
    I found the problem with Myron, this instalation ver. 2.46 is missing file Myron.msg
    Carson City problem is that this version is using the city map name "Lars City Settlement" and when you use the western exit you land suddenly in bunker 21, but I manage to go there only by editing saved game, cause normaly walk in just crash game...
  8. Worxolas

    Worxolas First time out of the vault

    Jul 7, 2016
    Yea there seems to be a problem where nhMyron.msg isn't missing but it doesn't seem to be assigned to him.
  9. MuffPillow

    MuffPillow Irradiated Kitteh

    Jul 8, 2016
    First and foremost I would like to thank @MIB88 and everyone else (too many of you on this thread and others to mention) for keeping this game alive through so many years. Being able to revisit my childhood favorite game (favorite of all time) is a blessing.

    With that said here's the part you guys love to hear, the gripe. Other than the insane amount of "Referenced memory" errors, each one different from the one prior. (which oddly enough i noted that the more often you save your game files the less often these occur, strange)

    Three issues. 1)Vic talking head fail. 2.a)BOS Bunker Map Buttons /.b Burke script broken 3)Marcus companion

    1) This not so important issue, Vic is NOT a talking head and his background bugs out sometimes being just random pixels or discoloration.

    2.a) And i saw this topic glanced over several times through out this (Massive) thread, but always dismissed as installation error (operator malfunction). well it would be insanely difficult to botch the current repack situation and no other mods running other than this one

    2.b) BOS bunker, i go save the scouts, because i'm a bad-ass by now (40+ hours in) and wouldn't bolt from an enclave encounter, however, upon returning to BOS Bunker, map pops up with no buttons. apparently can be worked around by taking vertibird to there, which i have not attempted nor acquired. UPDATE> The Vertibird confirmed gets back into top side BOS Bunker, however Burke's seems to be broken, Tried 15 different ways to load prior saves, and making first contact multiple ways, (on foot, in car, finally vertibird) also attempted dropping npc's before going either time still no speaking to Burke upon return from "fate of brotherhood scouts" mission. (Quest doesn't register as completed?)

    3) marcus says "too much going on, maybe when things calm down" even though all quests for BH have been completed. though I've not been able to find it again i feel that i skimmed past something before that mentions ensuring you get him BEFORE acquiring the mission to take out Westin in NCR. (?)
    EDIT SOLVED> Companion conflict, likely Klint (?) > Went back to Marcus without anyone in my party minus K-9 from Navarro, and he joined.

    Again thank you so much and none of these issues are a deal breaker in any way, stay awesome waste-landers!

    Perhaps i glanced over relevant information to fixing these as it would be easy to do, if so then i apologize, this post comes after hours upon hour of sifting through old patch bugs on this thread.
    Last edited: Jul 8, 2016
  10. Drobovik

    Drobovik Vault Archivarius Modder

    Jun 20, 2011
    Solution to Myron errors is in this post
  11. Worxolas

    Worxolas First time out of the vault

    Jul 7, 2016
    Hey man thanks, I'm loving the mod so thanks for helping the author patch.
  12. alatari

    alatari First time out of the vault

    Sep 4, 2007
    The changes to the ddraw.ini looked so interesting (like the carry weight only testing what's in hands giving unlimited pack carry to really speed up the game) that I started a fresh game.

    Two bugs I've encountered are both left over from the previous version:

    1) Level 4-6 random encounters of the death plants and giant rad scorpions with one cockroach always eventually crash to desktop. No error. Just the game drops out of RAM so you need to kill a couple things and run off map fast. No plants means making venom spears difficult.

    2) The Redding Caravans never show up. At least the 11th and the 21st caravans in Redding never show up even though waiting one hour increments or leaving the town and coming back to the miner area.

    A new bug I encountered. The claim jumpers don't use their light machine guns. Just punch me. Maybe setting their ST to 7 would fix the problem.
    Last edited: Jul 12, 2016
  13. Dretnoth

    Dretnoth First time out of the vault

    Dec 9, 2015
    Hi the NPC looting script have a problem. In Reno in bishop casino i see the guy tiring pick up the entire bookshelf. Of course ha cant, but still tiring to do, and it pop up the message: "You cannot pick that item. You are at you maximum weight capacity." (He have a loot in inventory.) But still try it even after load the save. And the message spamming even on upper floors. (I know it the same map but different layers but i cannot order him to move aside.)

    when i lefting EPA on world map, unless seeing the EPA coordination, it send mi view somewhere faar else.
    Same do it in EPA when i use left elevator to get on Maintenance floor (3) and view set on upper right corner of map.
  14. Worxolas

    Worxolas First time out of the vault

    Jul 7, 2016
    These reasons are why i stay away from the script, it's interesting to see interaction but in some maps such as the den residential it causes crashes
  15. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    Thank you all for the bug reports. I promise, when I have a little more time, I will address the comments of the past couple of pages.
    But, before I forget:
    1. If you want to disable NPC looting, just remove gl_test_loot1 and 2 from your data/scripts folder. I thought I had fixed the crashes relating to the Den Residential map... Turns out I just remembered wrong. I corrected the problem as it kept happening on the Slaver Camp map. However, it is an easy fix to add in the fix for the Den Residential map (and the slave pen area outside the NCR) and it will be added to the next patch.

    2. Definitely need to get that issue with Marcus fixed, too.

    3. The next version will also have the RP version of the Abbey, while the Abbey that is in the MM now will be moved to a different location, with a different name. (I am about 40% done with this conversion so far.)

    4. Vic's speech was disabled. The version that was made sounds robotic. Better to wait til some talented person comes along to voice him properly. However, the voice sounds great if it were instead used by Skynet.
    • [Like] [Like] x 2
  16. Worxolas

    Worxolas First time out of the vault

    Jul 7, 2016
    The Marcus issue is fixed easily in game all that is needed done is to dismiss all followers then pick him up, Abbey wasn't too much of a problem but again it wasn't too great for a large mod it wasn't much of a problem for me.
    • [Like] [Like] x 1
  17. MuffPillow

    MuffPillow Irradiated Kitteh

    Jul 8, 2016
    As mentioned, Vic is not a big issue, marcus is able to be worked around.

    However that whole BOS Bunker, missing map buttons and Burke being non responsive after you complete his mission thing, still seems to have no fix(?) nor suggestions. Have played it out many times over with different variables to no avail. (also not a deal breaker, just want in that darn bunker!)

    Just finally read through a guide however and Find out where the Enclave troops disappeared to is a quest given after the Discover the reconnaissance troop's fate. Could possibly be that i visited the old military base first and got all of the holodisks prior to meeting Burke? Don't see it really being that as it feels more like a missing interaction trigger but here goes nothing.

    Loading an older save now. back with a post edit soon!
    EDIT> 4:30 a.m. is too early, return in some hours with better edit.

    7/14 edit> So between posting this and finally getting back to playing, i installed F2WR mod and it broke those save game files Soon to be at BOS again, if the problem persists i'll get a Character editor and see if i can force my way into the bunker peacefully
    Last edited: Jul 15, 2016
  18. Dretnoth

    Dretnoth First time out of the vault

    Dec 9, 2015
    If i remember correctly one time i pick fight the enclave troops that siege the recon squad, after some turns, they come out and joint me.
    But even that i dint have right to enter the bunker.

    Something else. I think i have two places on Abey world map coordinates.

    If MIB88 implement even EPA then remember there is barking guy in Reno, seed for Arro and seeds for Doctor of plants people.

    So can someone remember which one file is for cockroach? I really dint like have the small ranged attack and the big more that one attack.

    Hmm. How hard it will be if i want Sarg in Navarro accept if i wearing some of combat armors, or Power armors? And change the Power armor in storage from Mk. II to Mk. I whit words its spare?

    Somthing else. I have jet addiction but the bar on main screen dint pop up i have it. It shoved only in charasteric screen and i have lowered the AG. i cannot rid it from me using jet cure.
    Have someone meet this?

    And. Is there a map editor that can work on W7,64x?
    Last edited: Jul 12, 2016
  19. Erhog

    Erhog First time out of the vault

    Jul 14, 2016
    Hello there,
    Found bug/exploit with trapper Smiley. First - you need get quest for resque him by Slim Picket or just get a Toxic Caves map from vertibird crush site, DON'T speak with Maida about Smiley, just stright go to caves and save him +1000 exp +50 karma. Go back to Klamath, speak with Smiley and get training outdoorsman +10. Now speak with Maida - she will ask you for resque Smiley even if he stays just before her. Speak with Smiley again - he's forget that he is in Klamath already and ask you to escort him from caves and start follows you like you in caves. Go to Toxic Caves, just move some steps forward and back and you get again +1000 exp and +50 karma. Now go back to Klamath - speak with Smiley again and he will give you another training, but now you can chose ANY skill you wanted and he will raise it for 10 points. Speak with Maida and copmplete quest. Now in Klamath Downtown will be 2 Smiley's: one in Maida market and 2nd will follow you while you in downtown location.
  20. Dretnoth

    Dretnoth First time out of the vault

    Dec 9, 2015
    -Do we know that Using Bug Spray from EPA on cockroach cause him drop the "cockroach Sit Weapon"?
    No weight and 999 ammo.

    -The model for lesser deathclaw (inmature) 50hp show as mature (big one).
    +But sm. though deatclaw 170hp (is small one)
    Can be the model for lesser switchet to small?