Fallout 2 mod Megamod version 2.46 Bug Reports and Suggestions - Closed

Discussion in 'Fallout General Modding' started by MIB88, Jun 25, 2014.

  1. MuffPillow

    MuffPillow Irradiated Kitteh

    Jul 8, 2016
    Find out the fate of the Brotherhood scouts (continued)
    1) dialogue doesn't trigger entry to BOS bunker (no access code upon completion of mission)
    2)"city map" buttons for BOS Bunker broken/unavailable (still have to ride vertibird to re-enter BOS bunker map)

    New character run through!!
    Turned it into Martin (not Burke, non talkative SOB that one), thanks me for helping them and welcomes to brotherhood, blah blah, click the door, [w/o the access code this elevator is not taking you anywhere]. check inventory, nothing.. talk to martin, he says all of "hello" as dialogue above his head, try Burke, he's still stoic as ever.

    So now i decided to break out a FO2 character editor, mostly just to see if any triggers failed to click, but everything is in order "joined brother hood etc" and i cannot force my way in by editing my quest lines to active for missions given inside the bunker. unfortunate that the pass-code didn't make it onto a misc. item with some typical old school fallout description like say, (piece of paper with access-code) "Wow his writing is more difficult to decipher than the code itself" as quest reward, would make this a real easy fix.

    Also, still no returning via any means other than vertibird, buttons for entering any level of BOS unavailable
  2. Parto

    Parto It Wandered In From the Wastes

    Jun 20, 2016
    have anyone saved game with working burke script ? I just wanna see, which variable should I change to restart it ... played two different characters and he dont speak to me ... know anyone which holodisk for profesor in BOS research facility should he give me ?

    Oh and both stairs in lv4 Vault 14 are bugged ... leads nowhere ... so if you came here you cant continue playing, I started reactor overload with computer and figure out that I cant escape ... funny thing :D
    Last edited: Jul 15, 2016
  3. alatari

    alatari First time out of the vault

    Sep 4, 2007
    So I made it down to NCR at level 5 (without dying) to get the Hubbologist +2 LK that's feasible, in game, if you trust the fortune teller's reading of the Tragic cards to head south and Jack(?) the drug dealer in The Den tells you the loc of New Reno, then in New Reno, Renescu gives you the location of NCR and says they might know about a GECK.

    1) Encountered rad scorpions with 2 large rad roaches near NCR and the same bug where hovering the mouse over a scorpion causes the game to crash to desktop without warning happens down there also. Just that random encounter and the plant encounter causes the crash.

    2) Tandi sent me on the Squat to work something out but didn't mark the loc of Vault 15 on the Pip Boy.

    3) The AK-198 assault rifle I found in an NCR locker should be Small Guns since it's just a fictional future version of an AK-47/AK-74/AK-101 for regular troops and requires a ST 5, but it's using the Big Guns skill or it's got a -40% penalty which would be odd for a long range, accurate, assault rifle. Maybe the ST requirement in the data table is actually set to 8 (my character's ST is 6 so that'd be -40%) while the description says 5? I'm not sure why it's got such a horrible penalty compared to the regular assault rifle.

    4) Took the Caravan job back to Redding because lvl 6 character is too low for that area. The Caravan job is messed up in a couple ways.
    a) After every encounter when you run to the exit grid the game puts you right back in the middle of the map of the encounter you just had so you have to run to the exit grid twice to actually get the next encounter.
    EDIT: OK, that's a bug from the original vanilla patch described in the Nearly Ultimate Fallout 2 Guide. Guess none of the modders attempted to fix the double map leave bug.
    b) Two guards and 4 bramin died on the way but the caravan master gave me the full $2000 plus a $1000 bonus instead of deducting the dead bramin cost and incompetence for letting guards die.
    Last edited: Jul 16, 2016
  4. Parto

    Parto It Wandered In From the Wastes

    Jun 20, 2016
    There is faster way to recieve luck bonus, if you find gauss pistol (Enclave troops near Navaro) you can give this weapon to Eldrige in New Reno and then go to Bunker 21, where is psychic nulifier the same as have hubologist in NCR, using this can upgrade your luck
  5. alatari

    alatari First time out of the vault

    Sep 4, 2007

    I have control NPC's turned on in ddraw.ini so I get to see the NPC's character sheets.

    Cassidy's base AC is 0, his sequence is 16 (normal for his PE of 8) and he only gets AC for the armor he wears and is missing his +8 AC for his 8 AG.

    So his base AC is messed up, or if he is supposed to have the Kamikaze trait, then his sequence should be 21 instead of 16.

    EDIT: This only effects the first level of Cassidy. Once he levels up he got his AG AC bonus.


    Character has 460 karma, no child killer or berserker, optimized Gecko powerplant, have an open slot but there is no dialog to get Lenny as a follower.
    I went down the dialog path with Harold about my ancestor and ended up with the super stims reward. Is the shared reward variable that covers both Lenny and Harold stopping the script that get's Lenny to join?
    Maybe it's a speech check and only at 65% and level 10. Will try at 75% when hitting lvl 11.

    EDIT: Level 12 and 85% Speech and still no dialog that gets Lenny to join. 900+ Karma. Not sure what I did wrong.
    Last edited: Jul 25, 2016
  6. Parto

    Parto It Wandered In From the Wastes

    Jun 20, 2016
    seems that modding still need someone to finish all the small things around ...

    INFO ObjectID for file proto\items\00000050.pro expected to be 592 but it is 49
    and so it goes up to :
    INFO ObjectID for file proto\items\00000050.pro expected to be 959 but it is 49
    also some missing items:
    WARNING Can't find file: proto\items\00000613.pro Creating dummy file.
    WARNING Can't find file: proto\items\00000614.pro Creating dummy file.
    WARNING Can't find file: proto\items\00000677.pro Creating dummy file.
    WARNING Can't find file: proto\items\00000678.pro Creating dummy file.
    WARNING Can't find file: proto\items\00000679.pro Creating dummy file.
    and many more up to:
    WARNING Can't find file: proto\items\00000829.pro Creating dummy file.
    INFO 969 items pro files loaded.
    WARNING Can't find file: proto\critters\00000611.pro Creating dummy file.
    WARNING Can't find file: proto\critters\00000619.pro Creating dummy file.
    INFO ObjectID for file proto\critters\00000633.pro expected to be 632 but it is 6329
    WARNING Can't find file: proto\critters\00000657.pro Creating dummy file.
    INFO 691 critters pro files loaded.

    Global variables seems o.k.8-)
    INFO 1701 GVARS loaded.

    and there seems some problems with keys:
    WARNING The key(60600) with the text(Skin Lotion) already exists(Smoking Pipe) in file: ...
    up to:
    WARNING The key(65201) with the text(Elise gave you this trophy. The inscription says 'NCR Ranger of the Year.') already exists ...

    WARNING The key(200) with the text(Desert) already exists(Boneyard) in file: ...
    up to:
    WARNING The key(255) with the text(Iron Mines) already exists(Dark Cave) in file: ...
  7. alatari

    alatari First time out of the vault

    Sep 4, 2007
    What's the Slaver Camp Speech requirement?

    I'm at 85% and no luck from Metzger or the slaves after he's dead.
  8. Parto

    Parto It Wandered In From the Wastes

    Jun 20, 2016
    hmm maybe bad karma, honestly I triger this location only using editor ... there is also slaver vault near arroyo, which you dont visit unless you are slaver and also member of Mordinos family ... so only for bad guys :D
  9. alatari

    alatari First time out of the vault

    Sep 4, 2007
    A bug and a possible bug:

    1)After the Fence in Coldheart's threatens to blackmail a woman and have he say my character raped her we end up in a gun fight and he dies and I lose 10 karma. The guy deals in assassinations, blackmail, other forms of crime and killing him doesn't get you positive karma of at least +50?
    Healing Bess' leg was +5 karma and reuniting Johnny with his parents +50 and killing Yakuza assassins is +5, so you'd think killing the head of the Coldheart Assassins would be comparable to reuniting Johnny with parents.

    2) The Megamod guide says Smythey wants 6 iron ore to create a set of metal armor but he takes 10 ore. That's the same as the guide's 6 ore for Metal I and +4 more to upgrade to Metal II. I had a set of Metal I and he did only take 4 to upgrade it to II.
    So is it really 10 ore for Metal I or should it be 6?

    My character's karma is over 500 so not bad karma.

    I've seen other people mention that you can get the information to get to the Slaver Camp without being a slaver with high Speech from either Metzger or the slaves after he's dead.
    Just trying to figure out how high and why so high so early in the game.
    The Megamod guide is completely wrong and says she's found in a tent in the Primitive Tribe area so I need details in order to correct the guide.
    Last edited: Jul 24, 2016
  10. alatari

    alatari First time out of the vault

    Sep 4, 2007
    Curious. I searched all forums on here for 'pregnancy cycle' and didn't find but a couple mentions that had nothing to do with Val or Megamod.

    Vic's daughter, Val, offers up a long dialog about her joining the pregnancy cycle and then another about her feelings about NCR and politics.
    What mod is that from? I couldn't convince her that NCR is a good choice (85% speech skill) but the info she gives about pregnancy cycles seems capable of helping out with the Phyllis quest.
  11. Dretnoth

    Dretnoth First time out of the vault

    Dec 9, 2015
    I cold harts dint get that senor Salvatore is dead, after
    -i put the leafing gas on it
    -Steal the normal one
    -steal the leafing a put the normal
    -but in some point after i decide to not kill him that way anyway.
  12. 666GaRRuS666

    666GaRRuS666 First time out of the vault

    Jun 16, 2015
    Has anyone found a solution for game crash when entering Carson City? Plus dunno why can't get Lenny in party - all the dialog lines are about helping Harold and providing healing (Cha checks are OK) or mb there's a special quest or something after completing which it'll be possible? Also there still are some lags w/ Sulic's sister, Metzger or slaves don't want to tell where slave camp is :(
  13. alatari

    alatari First time out of the vault

    Sep 4, 2007
    I have the same two issues.

    A new issue I'm having is recharging the car. Rt click and using the 54 SEC in inventory gets the message "that does nothing"
    I tried the old trick of charging the car by using the cells on an NPC and on Cassidy/Sulik get the message "You free the slave" and on Klint a funny message of "However much you may want to, you can not fill Klint with an electrical charge".

    Ah, I set CarChargingFix=1 in the ddraw.ini and found a reference to that breaking the charging.
    Leave CarChargingFix=0 in MegaMod!!!
    Last edited: Jul 31, 2016
  14. Darek

    Darek is currently unavailable

    Jan 7, 2008
    The Carson City map is either corrupt or some files needed are missing (can't even open it with the Mapper, so I can't tell what is wrong).
    Maybe possible to replace crsnmain.map with one from earlier version of Megamod, but haven't checked.

    I looked at Lenny's script and I think there has been a mistake with a global variable 629 check (in node001). The idea as I understood it was to prevent you from asking Lenny about the GECK when you have llready found it, but because of that mistake you can only talk about the GECK (and thus recruit him) after you have found it.
    So if you want Lenny you either have to wait until you have found the GECK, or change global variable 629 to 1 with the fallout2 savegame editor before you talk to him (don't forget to set it back to 0 after you have recruited him).

    About Metzger and his slaves...
    When you agree to help Sulik find his sister gvar 1123 is set to 1, so I expect that is what Metzger and his slaves would be looking for when telling you about the slave camp, but it's not. I haven't looked more at the quest and what all the gvars involved with it does, so I don't know how well it works or if it's broken. Anyway, if you want Mezger to tell you about the slave camp you need to set gvar 823 to 1, and if you want one of his slaves to do it, set gvar 1107 to 1. The fallout2 savegame editor or the Universal Fallout & Fallout 2 savegame editor is required for this.
  15. 666GaRRuS666

    666GaRRuS666 First time out of the vault

    Jun 16, 2015
    Ty, going to try what you said about Lenny, and temporary solution for Sulik's sister is to go to some F2 editor and reveal place of slave camp thru map editor, well I did this and it worked at least, also someone said that he replaced buggy Carson city with another, also in map editor, but i don't know with which one, mb will test it later
  16. 666GaRRuS666

    666GaRRuS666 First time out of the vault

    Jun 16, 2015
    Also someone who wrote about problems w/ vault 14 was right, you can't get out if you used stairs so have an extra save before this
  17. Darek

    Darek is currently unavailable

    Jan 7, 2008
    You can replace Carson City (crsnmain.map) with the map from megamod 2.45.3 (the last version that was working I believe). That works.

    What was suggested previously in this thread was to use lars1.map and lars2.map (a different version7design of Carson City) instead, but I wouldn't advice it as it's not really working. The exit grids between the two parts of town don't work and you will end up in bunker 21 instead. And when/if you manage to fix the exit grid in the Mapper, you will notice that those maps are not finished (all scripts are not properly assigned) and you can't really finish any quests.
  18. 666GaRRuS666

    666GaRRuS666 First time out of the vault

    Jun 16, 2015
    Ok, thanks for info then
    There're few more problemes 1) sometimes Sulik's head in dialog can disapperar when wearing APA Mark II and you'll be seing black screen instead.
    2) In BOS Facility on the lowest level when you are talking about visiting professor and say that your visit may take longer than 12 hours guys shoot at you if you attemt to go furher than entry of level
    3) Also in BOS Facility, but that might not be bug, can't find a way to get quests about gecko pelts and skynet AI, but mb they're not in the game or smthng
  19. wastelanDrifter

    wastelanDrifter First time out of the vault

    Aug 7, 2013
    I wanna try this mod but appearently there are lots of bugs. I hope they will be fixed soon.
  20. 666GaRRuS666

    666GaRRuS666 First time out of the vault

    Jun 16, 2015
    it's totally playable actually and you will notice this bags only if you want to complete all quests or something like this, when you're playing just for fun you likely won't have any of them or mb one or two, what's damn awesome for such a big mod you know
    • [Like] [Like] x 1