Fallout 2 mod Megamod version 2.47 Bug Reports and Suggestions

Discussion in 'Fallout General Modding' started by MIB88, Mar 20, 2017.

  1. Ranger117

    Ranger117 First time out of the vault

    Dec 31, 2016
  2. distermaster

    distermaster First time out of the vault

    Oct 14, 2020
    hi i always modify the proto files in fallout 2 and 1 whit mods or whitout the but whit this mod i cant do it please can you tell me how
  3. _Pyran_

    _Pyran_ Mildly Dipped

    Jan 31, 2017
    add proto files to '..\fallout 2\megamod\data' folder (with read only attribute).
  4. distermaster

    distermaster First time out of the vault

    Oct 14, 2020
  5. distermaster

    distermaster First time out of the vault

    Oct 14, 2020
    I did what you said and I get this

    Attached Files:

  6. Peter Dilema

    Peter Dilema First time out of the vault

    Oct 18, 2020
    Hi, first of all thank you for the great mod.
    While playing the latest version i encountered a dialog problem in the "siege" location. While in the pre-scripted dialogues between the BOS and Enclave guys there is just "Error" appearing over their heads and after that when i kill all the enclave guys the game crashes when a dialogue starts with the error GDialog::Error Grabbing text message!
    Can you please help me?
  7. SurpriseKamikaze

    SurpriseKamikaze First time out of the vault

    Oct 7, 2020
    How to fly the vertibird in Navarro? I talked to the guard, I talked to Maria. I can only access the trunk of the vertibird but I can't seem to fly it. Is this version unfinished? Also when doing the BOS quest about the reconnaissance, i.e. killing the Enclaves who has "Error" dialog crashes the game because it has "missing dialog". Please, help anyone
    Developers pls reply
  8. DPoiman

    DPoiman First time out of the vault

    Mar 13, 2019
    Fallout : steam version with 1.02 US patch
    Megamod : pyran installer version 2.47.5

    - When you enter EPA and save/load after some time it crashes, also it crashes when you leave and enter map again. Anyway its seem bugged, you cant use anything but only main "localization" computer and kill plants - any locked dors cant be opened, also stairs on right building teleport you out around base when used.

    - Myron always sound like he wear power armor.

    - Popup dialogue is bugged in slavers camp. with 1st slaver like also with Sulik sister.

    - Colly sometimes crashes... sometimes not, dunno what trigger crash, dont figure it out, total random.

    - Monastery - if you want to join up AFTER you bring verti plans to BOS - they automatic consider you like traitor and kills you.

    - Primitive tribe/umbra tribe - you "cant" sign alliance between tribes, quest is bugged and never finish - you can sign that pact forever.

    - highwayman looks like... burnt? its his "new" look?

    - in random containers you can find many times "reserved item" that looks like buffout.

    Also a question: there is an option to replace certain weapons sounds? i prefer old f2 revolwer/14mm/223. pistol sounds, not those from F1 :>

    edit: ah well fuck, Dobbs dissapear somewhere... when diggin in F12se, i notice he is listed in one town but cant find him anywhere... is there a some variables to edit to make him... appear again? i dont have save to rollback :<
    Last edited: Nov 11, 2020
  9. Silver-Lambda

    Silver-Lambda First time out of the vault

    Feb 2, 2020
    any updates ?
  10. _Pyran_

    _Pyran_ Mildly Dipped

    Jan 31, 2017
    Not planned for the near future.
    Only if we solve the problem together
    and fix what we can
  11. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    Hey! I'm still around! :P I have been making small fixes when I can, mostly fixing bugs given to me by @Muttie a little while back. However, I've been having A LOT overtime at work. Been super busy ever since April. So, updates will be slow. But, know that I haven't abandoned the MM.
    • [Rad] [Rad] x 4
  12. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    Thanks @DPoiman . I'll add your bugs to the list. A few comments, though:

    I'm working on these. @Muttie actually provided me a lot of useful information regarding Colly crashes. Hopefully I can fix these.

    The Monks do say not to give the plans to anyone else, don't they? (Although, thinking about it now, I need to add an option to be able to convincingly lie to the head monk.)

    I think I fixed this one for the next release.

    It is one of the newer looks. There are a few others too, as it can be painted.

    Two ways, I think: you can get a proto editor to change the sound file used. Or, you could get the sound file you like, and put it it the sound folder after renaming it to what the current weapon is set to.

    Um... I don't know what to do in that situation. The only place he should disappear to is New Reno.

    You said:
    Do you mean he only says float messages like he is wearing armor?
    Last edited: Nov 29, 2020
  13. DPoiman

    DPoiman First time out of the vault

    Mar 13, 2019
    - i get there AFTER i complete plot with BOS, in such situation, its kinda problematic.

    Sounds cool, do we have any tips where to paint them... or at least i could know? :>

    God bless you! I will try to poke around there a bit. Do you know meybe where is storaged a sound files? with proto menager i can only "swap" sounds between different weapons "in mod", but i cant find the old sound which appear somewhere on main F2 data...

    its very possible i miss him in reno... well, i play on "cult of personality" full party option, so when tons of ppl runs after you, its easly to miss one :D

    mine english is not good... well... for example - if Sulik wear normal armors - his voice sounds normal, ye, if you put a power armor on him, his sound is modified like he wear power armor - Myron have this voice even without wearing power armor, even his "meeting dialogue" sound like this.

    Somewhere was another quest related to "saving your village" and its also bugged like this one, but i rly dont renember where it is... in vault 13?

    Also i notice when you equip any armor on Lenny and when you "look" at him - messagebox says he is "ex-ghoul"

    another - when i run of petrol in car on wasteland, i dont have place "out of gas" only car disappear... completly, i do not repeat this to confirm its all time bug.

    And i have a question, Metzger in Den have bit more dialogue options, when we talk about seeling companions - dialogue mentions "Dex" and "Kitsune" - who's they?

    but what about EPA? in update earlier, its looks completly different... and well.. it works then.
    Last edited: Dec 2, 2020
  14. Nonocea

    Nonocea First time out of the vault

    Feb 12, 2020
    This has been going on for a long time now, and I don't think anyone's really tried to fix it. Most of the new Navarro content is completely broken from what I've played. Maria's dialogue loops, the toxic caves quest not being able to start at all, and of course the Vertibird now only featuring a storage trunk and no flight capabilities. I've also had the same problem with the BOS/Enclave siege you mentioned as well. Fingers crossed it gets fixed, but it doesn't seem like there's much love for the Enclave stuff.
  15. ThunderGod

    ThunderGod Have Hammer; Will Smite

    Oct 20, 2009
    - Stark in VC gives you a mission to go to a nearby village ( Vault Village ) for a rat problem; when you arrive, it is a black map. The maps for that location are in the wrong format, .GAM instead of .EDG/.MAP. They are vill.gam and vilmerch.gam [ maybe more ]. There are other maps that are only in .GAM format in the maps folder.

    -EPA entrance has incorrect scripts attached to the stairway and the elevator shaft; epai40.int and epai41.int do not exist in the scritpt folder.

    - EPA Elevator in the alien cave is set to go to MAP 158, which is the Mad Dog encounter. Most elevators in the EPA area do not make sense as to their settings.

    - After Marcus has armor from vault, game crashes when you ask him to wait, just after you close dialog with him.

    EDIT to add:

    - - BoS rescue in map "brhdhlp.map"
    - The dialog files for the BoS Knights and Paladin are not linked to their scripts properly, causing crash after fight
    - Enclave commander and troops do not have dialog files for their scripts, leading to "Error" floats

    Go to the one auto-repair place with an area where a car could be painted. You will need more than one can of paint, plus $2k and a week.

    I believe that you must do a primer job before the color paint. Frankly, I just used F12E to give myself the paint, so I don't know where to find it in-game.

    Primer paint will return the car to it's original, gray color. You can also find black, for that Made Man's Caddy look. I'm still searching for Kelly Green, Lapis Blue, Opalescent White and Candy Apple Red.
    Last edited: Dec 16, 2020
  16. Ghost Dog

    Ghost Dog First time out of the vault

    Dec 21, 2020
    Hello everyone, so I just finished Megamod version 2.47.5. If I had to rate it, I´d say 8/10. First I have to say kudos to creators of this mod. I enjoyed it very much. But here are some troubles I had to deal with during the game:

    1, The advice to save a lot turned out to be absolutly correct. I had lot of game crashes from the start till the end.

    2, Quest "Enter NCR and return to Stark" can be exploited for unlimited ammount of exp. Just keep asking him about more work and afterwards telll him that u already traveled to NCR. I ended up with 20 motion sensors in my bag. :)

    3, I had to skip the quest for the armor for Marcus. When he was equiped with this armor I was unable to leave him anywhere because everytime I tried the game crashed.

    4, EPA was bugged as hell and I had to skip it completly. When I arrived I found myself inside the main building instead of main gate and the car was parked between the big storage and the greenhouse or whatever the building on the right with non-functiong elevator is. I couldn´t get inside the facility because the rope on the elevator shaft just didn´t work. When I got back to my car and try to re-enter the location, the game crashed.

    5, In the quest "The Dragon wants you to take out Lo Pan - hand to hand" and vice versa, the game crashed everytime I got to the 5th fighter, no matter which side I fought against. So I had to go straight to one of those 2 and challanged them directly.

    6, After finishing the game in Monastery I felt kinda chetaed due to only 2 end game videos.

    But anyway I had a lot of fun during this mod and I absolutly want to give it another go. :)
  17. ThunderGod

    ThunderGod Have Hammer; Will Smite

    Oct 20, 2009
    Go back to your save just previous to finishing the Monastery. Complete the questline, but DO NOT activate the reactor overload using the FOB. Instead, go to San Francisco and complete the Tanker and Enclave questlines. The Monastery short-circuits most of the endings, which is why you only get two end videos.
  18. Oracle

    Oracle Vault Senior Citizen

    May 19, 2003
    how much of the unofficial patch and the restoration patch are in the megamod now? an estimate will do.
  19. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    Hmmm. Really hard to answer what from the RP is included. There's a ton of minor fixes to scripts that were made that weren't necessarily part of some new location. These are the new locations, right?
    • Slaver's Camp
    • Hubologist Stash
    • Submarine
    • Abbey
    • Vault Village
    • Ranger Safe Houses
    • Dr. Sheng's Hideout
    • EPA
    The Slaver's Camp, Submarine, Abbey, Ranger Safe Houses, and Vault Village have been added. (I just finished adding in Vault Village yesterday.) I really don't remember if I've added the Hubologist Stash and Sheng's Hideout, yet, but I will check. But those are all relatively small locations. I had the old EPA in the game. Redoing that location (mostly because of the new scenery) has been a beast to put into the MM. A lot of the individual scripts have been corrected.

    I'm going to say 65% of the RP has been added.

    And, just an FYI, from the latest readme:

    Changes/Fixes made since version 2.47.5:

    -Numerous dialog and grammar fixes
    -Minor corrections to various maps (especially with regards to walking through objects)
    -Cleaned up code in many scripts
    -Removed some more instances where killed enemies had two sets of armor
    -Corrected a number of scripts which had incorrect/missing variables regarding
    Sexpert, Gigolo and Virgin (Thanks to Muttie)
    -added story/character enhancements from Endocore
    -Asking Klint, Sulik, or Cassidy to wait will no longer corrupt saved games
    -Orphans in the Den really need to be watched: they'll attempt to steal from party NPCs too!
    -Corrected team issues with certain caravans
    -Numerous corrections to NPCs/quests in Colly
    -Can no longer repeat the Arroyo/Umbra pact repeatedly for experience
    -Corrected Dipper's script
    ---will not mention Vic or GECK if not appropriate
    ---added dumb dialog
    -Klint can still attempt to heal the PC, but only if he has plant components
    -Andy in VC now heals more party NPCs
    -Inclusion of Vault Village and related quests

    I'm going to fix/test a few more things. But, my plan is to release an update no later than the end this month.

    Also, thanks to all of you who have posted bug reports.
    • [Rad] [Rad] x 3
  20. Oracle

    Oracle Vault Senior Citizen

    May 19, 2003
    Tnx MIBB! guess you be also using the updated restoration patch by Burn to be integrated (somewhere in the future)

    was just added my own edits just into the megamod, guess I need to do it again with the upcoming release, lol