What the hell????

Discussion in 'Fallout RPG Gameplay & Tech' started by FalloutTroll, Feb 22, 2014.

  1. FalloutTroll

    FalloutTroll Mfw no snow

    121
    Apr 7, 2013
    I just fixed the goddamn poweplant at gecko using the robot and as i am about to leave the guy infront of the door starts shooting at me for no reason and everyone turns hostile and attacks me and i always die i cant leave! Why the hell do they start shooting at me????????
     
  2. Yamu

    Yamu Le Fromage Vieux oTO Moderator Orderite

    Jul 26, 2003
    You seem to have run into one of the most well-documented and reliable bugs Fallout 2 has to offer. Congratulations on reaching one of the milestones of classical RPG gaming. :mrgreen:

    You haven't done anything wrong; the guard aggros for no good reason whatsoever. It's possible to sneak around him, though it can get frustrating if you're not a skilled skulk. Alternately, you might have some luck with the combat spam exploit. If you're not familiar with the technique: when you're just beyond the distance he'll notice and aggro you at, start spamming the "A" key to begin hostilities yourself, use your action points to run as far as you can, click to end the combat (or hit "Enter,") and IMMEDIATELY, before the "Turn/Cmbt" box can even close, begin spamming "A" again. With any luck, you can chain your turns and manage to make the exit grid without the ghoul getting a chance to register that he's angry at you. It's cheap and cheesy, but in this case, it's justified.

    My memory is a bit rusty, but I think this is only an issue with unpatched/inadequately patched versions. If you're not patched all the way up to 1.02, I'd strongly recommend fixing that, though that won't help you during this playthrough as the patch is known to invalidate saves. For future reference, we generally recommend using Killap's Unofficial 1.02+ patch or something similar (or, if you're open to a smorgasbord of fan-restored cut content, Killap's Fallout 2 RP), as the modders behind them have spent a decade or better meticulously tracking down and eliminating all the bugs (some of them real doozies) that the official fixes overlooked.
     
    Last edited: Feb 22, 2014
    • [Like] [Like] x 2
  3. valcik

    valcik So Old I'm Losing Radiation Signs

    Dec 20, 2008
    Yup, I've never experienced this bug with killap's patch/RP. All the ghouls in Gecko plant do behave correctly after fixing their lovely reactor, tossing friendly green coloured floats at you instead of red ones.
     
  4. FalloutTroll

    FalloutTroll Mfw no snow

    121
    Apr 7, 2013
    Yamu could you make a video of that tehnique? Please
    I already tryed sneaking past him but he always sees me. Oh and by the way the sneak feature only works when i don't move, as soon as i do its over
     
  5. zegh8578

    zegh8578 Keeper of the trout Orderite

    Mar 11, 2012
    Do you have auto-running enabled? Sneaking works if you walk, not run.
     
  6. Yamu

    Yamu Le Fromage Vieux oTO Moderator Orderite

    Jul 26, 2003
    Aye, sounds like that might be the thing. You can disable auto-run in the options, or, alternately, you can hold down the shift key as you click to move, which will force your character to walk. (If you have autorunning disabled, you walk everywhere and holding down shift makes you run. This is my personal preference, but I usually play sneaky-types.)

    I've always had trouble recording game footage in the original Fallouts, and it's only gotten worse as the game's become more and more technologically outdated. I'll see if I can work up a tutorial vid in the next few days, but I'm afraid I can't make any promises.
     
    • [Like] [Like] x 1
  7. FalloutTroll

    FalloutTroll Mfw no snow

    121
    Apr 7, 2013
    Thanks, if you can't could you atleast post someone elses video
     
  8. Buxbaum666

    Buxbaum666 Heterostructured Nanorod oTO Orderite

    Dec 5, 2003
    You don't really need a video, you just press A to initiate combat and start moving towards the exit grit. As soon as your action points are depleted, combat should end automatically. Once that happens, just keep your finger on the A key until combat starts again. Repeat until you've reached the exit.
     
  9. Yamu

    Yamu Le Fromage Vieux oTO Moderator Orderite

    Jul 26, 2003
    Can you do it by holding down A? I haven't used that trick in years, but I always used to just keep frantically hammering on it.

    Heh. Good to know.
     
  10. Buxbaum666

    Buxbaum666 Heterostructured Nanorod oTO Orderite

    Dec 5, 2003
    Yeah, I'm pretty sure it works by just holding it down. I used to hold down A whenever a random encounter began and I hadn't saved my game in a while.
     
  11. J_Fred

    J_Fred Long time lurker

    286
    Dec 22, 2013
    I thought this was standard game practice... haha.
     
  12. Gaspard

    Gaspard Kasparov

    833
    May 7, 2009
    It worked better in Fallout 1 - in FO2 it doesn't always work for me. Haven't figured out a pattern yet, but I don't really play it that often anymore...
     
  13. Sduibek

    Sduibek Creator of Fallout Fixt Moderator Modder

    Oct 27, 2010
    My experience has been in Fo1 it can be done by just continually holding down the A key in 100% of situations.

    Fo2 however, in many situations you have to spam the button fast because holding it down don't work. Sometimes even that doesn't work for me. So the developers "fixed" this bug during the engine upgrade.
     
  14. Per

    Per Vault Consort Staff Member Admin

    Apr 1, 2004
    I think it works better if you end combat manually than if you let combat end automatically after running out of APs, but there are no guarantees in Fo2.
     
  15. FOvet

    FOvet Wandering the Wastelands

    344
    Aug 26, 2012
    I have never seen this bug...GOD that would suck, I feel for you--because in New Vegas I ran into a game breaking glitch that made me have to restart my game. Hope you manage to sort that out w/o having to start over D:
     
  16. zegh8578

    zegh8578 Keeper of the trout Orderite

    Mar 11, 2012
    I remember it from my first FO2 playthrough, since it was a totally clean install, right from disk, no internet connection or anything, so obviously no patch. I was confused, but begun to suspect it was an error.
    In fact, I found and printed out Per's guide from the city library :D And there confirmed that they are indeed not meant to go hostile on you :D