Fallout 2 Restoration Project 1.2 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Jun 9, 2008.

Thread Status:
Not open for further replies.
  1. Atombunker

    Atombunker First time out of the vault

    21
    Apr 7, 2008
    Well, just make a shortcut into your 'pinned' menu, whatever that is! :)

    EDIT: Okay, I reread, and saw that you tried that. Sort of. Your vocabulary is a bit strange there, what is the difference between removing and unpinning for you? Could you rephrase that with standard windows vocabulary?

     
  2. JOG

    JOG First time out of the vault

    36
    Dec 17, 2007
    Hmm. What I meant was that I thought there was only one of them in the original game: the quest reward from the tanner in Modoc, but well, maybe they were always sold in shops later on and I just didn't care about them anymore.
     
  3. Morticia

    Morticia Look, Ma! Two Heads!

    372
    Mar 9, 2008
    @ Kissker,

    Restoration Project v1.2 pins to the start menu just fine with XP pro SP2.

    {Might just be my suspicious paranoia, and NO software designer would ever consider doing such a thing, but how long was SP3 released after the introduction of Vista, the announcement of discontinuing XP, and the great disappointment of Microslop that so many people were preferring to stay away from their new OS? Does anyone really believe that SP3 was to improve a product already declared dead? I would bet that you're going to discover a lot of other Windows features don't work like they used to, and might just stop working altogether.}
     
  4. Kissker

    Kissker First time out of the vault

    31
    May 23, 2008
    actually, when I right click the .exe and say 'pin to start menu' without 1.2 installed , it works fine, even with 1.1 and other patches. I have had SP3 since it came out, although not sure when that hit.

    It's not SP3 that stopped the pinning working, trillian, firefox, and other things I have pinned work just fine. Even FO2, RP 1.2 'works' just gives city error after loading screen. I highly doubt that SP3 broke it. It could be a numerous amount of other things.

    If anything its a simple problem created by SP3 and compatibility with such and old game (even if the restore project is new) Remember the game says something like '95/98/NT' on the CD, before I did some system managing, it actually went Grayscale on me during game play for several seconds, over part of the screen. This was simply a Video card issue (Different card then what is in it now)
     
  5. BOS Man

    BOS Man First time out of the vault

    48
    Jul 7, 2008
    Hey, bear dude, I've been following your Restoration Project for a while now, and I have to say I admire what you're doing. I've been playing through with the latest patch and I have to say I have not had many problems so far. I've been keeping a log of issues I've been having, but I have to say the game runs smoother than ever. 99% of the problems I've found have been very minor, so I'll wait to submit what I have when I've finished the game and have a complete list. I have finally run into one issue that I thought shouldn't wait though:

    I challenged the Dragon to a friendly competition. I kicked the second opponent in the head and knocked him unconscious but the fight did not end. I continued hitting him until he died and the fight still did not end, trapping me inside the arena. After loading, it happened again but with the first opponent, and then a third time on the third opponent. I don’t think I can finish this quest at this rate. I don’t recall ever having this problem before the patch. I kept two saves of this, if you need them. One is before the fight and the other is after being stuck in the arena. Should I Rapidshare them or would you rather I email them to you directly?
     
  6. Darek

    Darek is currently unavailable

    Jan 7, 2008
    @ Kissker,

    Create a shortcut to Fallout2.exe in your fallout folder and then pin the shortcut, not the exe. That way works. For some reason when you pin the .exe nothing of the extras (ddraw, res.ini, whatever) can't be found.

    No problem bear, just trying to help out.
     
  7. Aero

    Aero First time out of the vault

    70
    May 7, 2008
    Gaaaaahhhhh

    Ok been deployed to Iraq for the last year and have been looking really forward to replaying Fallout 2 once again. There was a fire while I was gone and the house had to be "Cleaned" and repaired.

    So I go to my disks and I Can't FIND fallout 2. Found the book and disks to fallout 1 but can't find the box to either of them. Also my Daggerfall disk is gone.(still have the box though) Ny original Maniac Mansion and Zak McKracken boxes are gone as well.

    I'm rather perturbed. Guess I'll have to go rebuy it, but dang, it was an original prepatch box.

    Rao
     
  8. clones

    clones First time out of the vault

    16
    Jul 7, 2008
    Hi
    First Big Thx for @killap for produce mod to my favorite game :)

    I found some bugs (in version 1.2 in language "PL"):
    NEW RENO:
    Father Tully:
    In quest "Abbey Booze" - i can only give him when i have one in my inventory... when I didn't have (and back to him when i have) i can't find information how to give him alcohol.

    "Go visit Renesco the Rocketman and collect Mr. Salvatore's tribute" - I can't get "free" shopping (mabe it is correct but I remember that i have some items for 0$)

    When I talk to the man in suit in Shark Casino (Ms. Bishop) about mr. Gees there in dialog is 3 time error messages to choice.

    The wrights (in train station) when i ask them say : "Error"

    Broken Hills:
    when i ask someone in caravan who are you they say "I'm Error"

    Other:
    I think that : Assault Rifle, Minigun (guns with 7.62mm ammunition) was buged. I get 4 times hits from weapons (Kaga Minigun and SAD turrets) and there was no damage when I have Metal Armour!

    ps. Sory about my english it isn't my native leanguage.
     
  9. khing

    khing First time out of the vault

    4
    Jul 13, 2008
    At the risk of sounding ignorant, does this board allow me to upload files? Otherwise, is there an email address i can send the savegame to? Thanks.
     
  10. Darek

    Darek is currently unavailable

    Jan 7, 2008
    No, but there's free hosting sites such as http://www.mediafire.com/.
    killap's email address is in the readme.txt for the RP and I'll PM you mine.

    Not sure what you mean, but don't you just talk to him to give him the booze?
    The free shopping was a bug, which has been fixed, so it's no longer for free.
    You are probably using Glovz's ammo mod or tweak. You can change it back to normal in ddraw.ini.
     
  11. Glovz

    Glovz Vault Dweller
    Modder

    735
    Sep 16, 2005
    Haven't had much time recently, but I will be changing the turrets in my mod to do damage with my AP Ammo mod on.

    Sorry, but it's beyond my ability to have the AP Ammo Mod work perfectly without tweaking proto files. That's where my Combat Overhaul Mod comes in.
     
  12. clones

    clones First time out of the vault

    16
    Jul 7, 2008
    Hi @Darek I try to explain that.
    When i Ask him where he from then he tell me about Abbey and he will ask me about Abbey Wine...
    If I have that item in my inventory then give him that wine, but if not and choose option to deliver him that wine I don't have option in conversation to give him wine (barter or use on don't work - no EXP.). Have only option to talk about Samuel.. (maybe when I end that second quest that option will show up... don't no, but i have save game if someone want to look)
    I only instal full windows instaler Restoration Project (with all checkbox)

    Edit:
    I found another bug in reno:
    when i loose 3 boxing fight and want to fight another i automatic loose 4 fight when it starts. (have save if someone want see)

    When i got Porno Star and next PrizeFighter Bishops men talk "Error".
    When i exit with New Reno not by car... in world map i travel by car but when i stop in other town car disapir.
     
  13. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Ah, someone running a language other than English - excellent. So, all the "error" messages you are seeing means this was never translated from English to Polish. I will address these for RP 1.3. Please let me know if you encounter more.

    Never heard about the Reno boxing problem, but if you can upload the save somewhere that would help.
     
  14. Kanhef

    Kanhef Vault Dweller

    793
    Sep 2, 2007
    If you lose a round by critical failure, the game sometimes thinks you still need to miss your next turn. This will happen the next time you enter combat, so you lose the next round immediately. Entering combat before you box again will fix this.
     
  15. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Oh, if that is what he meant then yes, no bug here.
     
  16. clones

    clones First time out of the vault

    16
    Jul 7, 2008
    Ok i will upload or mail 2u that save tomorrow.
    I was critical miss and loose the 3rd fight...
    have only save when the 3rd fight is repeated and my character automatic loose it when it starts.
    ok when i find "Error" then i write some info about it.
     
  17. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    @clones
    Actually, no need for the save. Look at Kanhef's post.

    Also, did you use the installer and choose the Polish language or did you install the separate Polish language files found at NMA?
     
  18. Darek

    Darek is currently unavailable

    Jan 7, 2008
    @ khing,
    I tried your save. I talked to the BOS dude, went to Navarro, and nothing. It wouldn't crash for me.
    What else did you do before going to Navarro? And what map in there crashed?
     
  19. stoobs

    stoobs First time out of the vault

    4
    Jul 14, 2008
    Hey,

    Firstly, good job on the Restoration Project. Its looking great and has added a new lease of life to the game.

    I'm not sure if this has been mentioned before (theres 43 pages to go through!) but I have been playing with your full installer restoration mod (1.2). The latest one with all the boxes ticked.

    I am early on in the game and so to kill tough oppenents I am aiming at the head/eyes a lot and hoping for criticals. I also have the finesse trait. I find that quite often I hit critically for no damage killing the oppenent. Its fine for me normally, as they're dead, but it causes missions to not count as complete. It also does not allocate experience for killing them (inside a mission or otherwise).

    This has happened twice so far:
    -Killing the rat god in Klamath
    -Clearing the old mans garden in Modoc
    -As well as just general random encounters etc.

    Both times if I reload I can kill them normally and the missions complete fine.

    Thanks for your time,
    Stoobs

    P.S. I don't know if this happened in the original game, but if it did, I didn't notice it until now.
     
  20. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    I've gotten many 0 damage critical kills before in the original game. I don't think I ever got it during a quest kill though. Seems odd it doesn't register since the critter is indeed dead. I don't think anything can really be done about this since this is all hardcoded.

    If you are getting too many 0 damage hits, then you might want to reconsider what ammo you are using or disable the ap ammo mod in the ddraw.ini file.

    Still, 0 damage critical kills did happen in vanilla Fallout 2.
     
Thread Status:
Not open for further replies.