Fallout 2 Restoration Project 2.0 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Apr 1, 2010.

Thread Status:
Not open for further replies.
  1. Athlon

    Athlon First time out of the vault

    Apr 30, 2010
    mods =Party Orders add-on, Mira mod

    Fallout 2 1.02.26 RP 2.0
    Sfall 2.6c
    high Resolution patch
  2. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Basically I want the dude to see if an armed explosive has been placed on the map.
    That's item pids 206 and 209. Could you please write out the whole if statement, cause I don't quite understand what you mean?

    What I'm trying to do is fix the dynamite crash. This is what I have so far...

    It only crash when someone dies, wounded is not enough.
    It will not crash on a map you just loaded from a savegame.
    If you start combat mode and then exit, no crash will happen as long as you stay on the current map.

    So something happens when a map is entered (that will not happen when you load that map from a save), something that is removed/corrected when combat mode is started. Maybe the game loads something in memory that is not saved in a normal map save, and combat mode clears it?
    Anyway, I cleared a map in the Mapper, it was completely empty save for one critter. No scripts. When I went there in-game and blew her up the game still managed to crash. So it's nothing to do with any map enter scripts.

    I have a crude solution for this but I'm not sure it's suitable for the patch. An alternative fix would be preferable.

    Anyway, the idea is to start combat and force exit on every map you enter:
    procedure map_enter_p_proc
            set_local_var(6, 1);
    	attack_complex(dude_obj, 0, 1, 0, 0, 30000, 0, 0);
    procedure combat_p_proc
            if (local_var(6) == 1) then begin
                    set_local_var(6, 0);
            else begin
    Basically you start a fight against yourself and without the terminate_combat call there, you will hurt yourself. :lol:
    This ain't so good as it gets rather annoying with start/exit combat all the time, and it interferes with "multiple" random encounters (I think). Map exceptions can obviously be made for those.

    I want to improve this by only start/exit combat when you have a dynamite set to blow in your inventory. But only once at a time per map. I've got "procedure is_dropping_p_proc" working, the "obj_carrying_pid_obj" in "procedure critter_p_proc" is still a bit iffy, and finally I need to be able to tell if an explosive is on the ground as using a dynamite in your active inventory slot bypasses the first two checks.

    So what do you think, would this be possible?
  3. Mr. Bazooka

    Mr. Bazooka First time out of the vault

    Apr 21, 2010
    The green level of the epa is obscured as if the whole level were behind a stone wall. I can only see my PC in the cutaway graphic that shows when you're right behind a wall etc.
  4. .Pixote.

    .Pixote. Antediluvian as Feck

    Sep 14, 2009
    That is the roof tile…it has been removed for the future map release, so no more sticky roof problems. I’m sorry you will need to wait for RP 2.1. Try running around the world and come back to the EPA, it might settle the problem.
  5. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Going to another floor and coming back or even saving and reloading will often fix the problem.
  6. patsak

    patsak First time out of the vault

    Apr 29, 2010
    More bugs:
    In NCR sector Bazaar. When I go to ring with super mutant Lenny (from Bar) and when I kill him I can't get off the ring. I tried to load game 6-7 times but always I can't get off the ring

    In Abbey when I bought armor for Marcus - Marcus becomes invisible. (Mod without Armor for Marcus but dialogue about armor is present)

    PS Sorry for bad English
  7. ralphrepo

    ralphrepo First time out of the vault

    May 1, 2010
    Minor continuity issue: In Klamath, after receipt of the Whiskey Bob quest to refuel his still, if you betray the still's location to Sajag, owner of the Golden Gecko, Whiskey Bob afterwards will launch into a heated tirade if you try to speak with him again. However, in the midst of his verbal venom, you are still able to hit the Barter button and initiate trading with him. That really seems out of character continuity that he would still be willing to trade with you while he's screaming insults at you.

    Another issue with weapons balance: I had the CAWS shotgun with small arms tag skill around 110, and shooting the Metzger slaver guards (in the Den) at nearly point blank range (2 hexes) with burst fire would only return hits worth 4 to 6 HP's. I noticed this also with the regular 10mm SMG, where point blank burst fire would hit these guys for no damage at all. This had happened repeatedly. On previous occasions before the RP install, the SMG burst fire would toast these guys.

    Minor "bug" I remember from original FO2 remains: NPC's seem to be able to walk anywhere without triggering any hostile reactions. While sneaking into the New Reno weapons dealer's back room, your NPC's somehow become invisible to him and freely walk into his backroom from the front of his store where he is standing. I remember that this seemed rather odd to me 10 years ago and it still seems odd now. Why he reacts to you and not to the NPC's destroys the game's Suspension Of Disbelief, IMHO.

    Persistent bug: One of the long standing problems with NPC's has always been the "you're standing in my hex" complaint. If the NPC decides to set up house in a defile hex, you're stuck for good. I remember having to shoot my NPC's in order to get them out of a doorway or some other hex choke point. A "please get out of my way command" would be nice, or some overall background code that prevents the NPC from ever coming to permanent rest on one of those hexes. I remember once waiting for more than an hour for one of these guys to move out of the hex (as they often meander about on their own). I finally had to shoot him when I realized that he was never going to move again. It would really be helpful if they kept meandering a few hexes every 30 seconds or so.

    Favorites: I love what they they did with the 14mm and .223 pistol sound. The first time I heard the BOOM of the weapons retort I nearly wet my pants, LOL... On the flip side, the FN FAL sounded rather anemic, IMHO.

    Also new here; a big thanks to Killap, et al, for making FO2 a game worthy of replay, even after all these long years. Kudos to all concerned.
  8. Travesty

    Travesty First time out of the vault

    Apr 18, 2005
    Have you tried pushing them out from the doorway? Hold down the left mouse button and click the hand icon. This has always worked for me atleast. Or is there a bug that renders the pushing impossible?
  9. OutcastBOS

    OutcastBOS First time out of the vault

    Apr 5, 2010
    Can you put more female player character models in 2.1? I would love to play as one of the girls with a mohawk I see wandering around :)
  10. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Easier said than done. Like I said in another post, these critters don't have all the necessary animations needed for the player. What you see in the RP is basically all the full player critters that are available. Hopefully more will come some day.
  11. Herr Mike

    Herr Mike Look, Ma! Two Heads!

    Jul 28, 2008
    This has probably been reported:

    In the Den, when taking out Tyler's gang with Lara. If you leave the square after killing the guards at the church, you win the quest without having to go kill Tyler in the residential area. (Which is virtually impossible early in the game I found, at least on hard.)
  12. Muznick

    Muznick First time out of the vault

    Jan 23, 2009
    I just installed the restoration project 2.0 and it showed me 2.0.2d on the little rock and it was right because I hadn't downloaded 2.0.2e.

    Then I did download it, extracted it in the game directory and after that on the rock it still says 2.0.2d.

    What can I do ? :cry:
  13. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    You didn't extract the update correctly then. Did it ask to overwrite files? You want to make sure the contents of the .rar go to the main F2 directory (where the F2 exe is) Basically right click the .rar choose "extract files" and make sure the destination path is the main F2 directory.
  14. Muznick

    Muznick First time out of the vault

    Jan 23, 2009
    Okay I just uninstalled the whole thing, Fallout 2 included. So here we go from the begining:

    1. Install original Fallout 2 game (humongus).
    2. Install F2_Restoration_Project_2.0 in C:\Program Files\BlackIsle\Fallout2 (already exists)
    3. I extract the 2.0.2e update in C:\Program Files\BlackIsle\Fallout2

    4. It asks me if I want to move the read-only files "00000489.pro" I click Yes

    5. It asks me if I want to move the read-only files "00000490.pro" I click Yes

    6. It asks me if I want to replace the existing file named "ddraw.ddl" I click Yes

    7. I then start the game (for the first time since installation). New game. The rock still says I'm playing 2.0.2d

    Where did I go wrong ?
  15. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Hmm, it should ask you to overwrite several other files. Just take what is inside the /data directory of the .rar and copy it to your /data directory. patchinf.msg should be one of the files it wants to overwrite.
  16. ralphrepo

    ralphrepo First time out of the vault

    May 1, 2010
    (Ralph's big Face - Palm moment) Dang it... It's been so long since I've play this game that it obvious I don't remember how to play; I plum forgot about that feature in FO2. Thank you for allowing me to embarrass myself. Now I'll just slither back into my corner quietly, LOL...

    At any rate, another minor continuity bug: I did the Redding Winaminga Mine Clearance and returned the Retrieved Chip long before I'd ever talked to Mayor Ascorti. When I finally did speak with him, he nonetheless continues to tell me the mine is infested and offers to sell me the deed. I was thus able to purchase the deed from him. Immediately afterwards, I speak to him again and he asks me if I had cleared the mine. I tell him I did and he then offers to buy the deed back.

    At that point, it would seem rather inconsistent that Ascorti would ever offer the deed for sale, since the mine had long been cleaned out of Winamingas in the first place.

    Suggestion: It might be more in character if the mayor, upon seeing and speaking to you for the very first time, instead thanks you for turning his worthless property into a literal gold mine. He then gives you a money reward and offers to give you a permanent premium rate for whenever you happen to trade with his establishment. Or, maybe a better possibility for Karma and experience might be if you turn it down and tell Ascorti to forgive Widow Rooney's rent and let her live there rent free?

    Another thing, even if you killed off all the rats and winamingas in the well behind Widow Rooney's house before you speak with her, you nonetheless remain "curious" about the well and ask Rooney about it. She will still tell you about the "scratching" noises coming from the well. Again, since you've already been in the well and had already taken care of the problem, she would no longer have a reason to continue to say this, nor would you have any reason to ask such a question.

    Doc Johnson in Redding seems to retain the exact same barter items that I traded to him for weeks after. When I try to trade with him again, I find the exact same stuff that I'd given him before. He has no further medical supplies to sell, ie. he doesn't seem to have a renewable stock.
  17. Muznick

    Muznick First time out of the vault

    Jan 23, 2009
    OKay got it to work thank you. I just had to manually drag each file from the .rar into the appropriate folder in the data folder.

    Rock says 2.0.2e ! Thank you ! :D
  18. Crawley

    Crawley First time out of the vault

    May 2, 2010
    Why was the Chinese woman in the EPA cryotank given a Japanese name?
  19. thai1109

    thai1109 First time out of the vault

    Dec 28, 2008
    Minor bug:

    _ Can still skin gecko hides if they are burned black by Flamethrower or exploded to bits by Rocket Launcher.
  20. ralphrepo

    ralphrepo First time out of the vault

    May 1, 2010
    Odd thing, while looking through my inventory, I found an item that looked just like the Buffout Pills, but when I hovered the mouse over it, it was called "Reserved Item." I dropped it on the floor and it resulted in a red square with white text that said, "do not use."

    I haven't a clue where I found it.
Thread Status:
Not open for further replies.