Fallout 2 Restoration Project 2.0 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Apr 1, 2010.

Thread Status:
Not open for further replies.
  1. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    I answer this a few posts up:
    And yes, all known fixable bugs will be addressed in 2.1.

    Not quite sure. I know several people had a similar issue but got it resolved. Perhaps they can comment. Worst case, I'd say hold off until 2.1 is released.

    EDIT: See Mirr's comment on the bottom of the previous page. Perhaps it helps.
     
  2. zenitfan4life

    zenitfan4life First time out of the vault

    72
    May 27, 2008
    Awesome that the new RP version is finally released! Too bad it is released in critical time when finals and research papers are due, so no time to play for another few weeks. But good news is that I see that RP 2.1 is coming it then, so looks like everything works out well =)

    I just wanted to throw in a suggestion to start a new thread when RP 2.1 is released, seeing how this thread is already 60 pages and most of them are filled with questions about bugs, which will be eliminated by 2.1 (I assume?). Will make it a lot easier to communicate and discuss strictly 2.1 imo. But that's just my 2 cents :D

    Although I haven't played it yet, I've read and heard a lot of amazing things about this release and I just wanted to thank everyone who is involved in this project, especially the Killap and whoever did the additional graphics! Thanks a lot for keeping the greatest game ever alive and kicking!!!
     
  3. patsak

    patsak First time out of the vault

    9
    Apr 29, 2010
    Minor bug:

    After I helped Kuritsu leave slaver's camp and when I return to slaver's camp Kuritsu is here again and said "Thanks for help her"
    Kuritsu is in 2 places - in Primitive Tribe and in Slaver's camp at the same time
     
  4. patsak

    patsak First time out of the vault

    9
    Apr 29, 2010
    Else in encounters enemies are in the rocks often, so they are impassable
     
  5. jirik

    jirik First time out of the vault

    54
    Apr 25, 2010
    Hi i'm runnig linux as well and i had this issue when i was using windows installer RP version. It seems that wine handle the patching of master.dat not well..

    So I figured out this by letting windows installer package do its job and then manualy through the command line patch the master.dat with files from manual RP2 rar archive.

    My master.dat from working RP2.0e has 325620 kbytes with ext3 filesystem.

    And everything works well.
     
  6. muhku

    muhku First time out of the vault

    6
    Apr 12, 2010
    OS is Vista 32b so I don't think this applies here? My master.dat file is 333 098 563 bytes and there is no difference in the pre/post-RP files.

    Also tried installing FO2 in win98 compatible mode: the install happened about 4 times faster (odd?), but otherwise than that nothing changed. (I can save without RP though.)
     
  7. DGT

    DGT It Wandered In From the Wastes

    148
    Apr 7, 2006
    Not a bug, strictly speaking, but I can't imagine why it would be changed and the change makes it much more irritating -- the Magic 8-Ball is now "Use On" instead of just "Use" when you equip it. It still works, but the extra step of clicking on my character is probably going to keep me from using it much.
     
  8. ralphrepo

    ralphrepo First time out of the vault

    57
    May 1, 2010
    Just in case it wasn't already mentioned, but a portion of the dialog choices between the player and shopkeeper of the Abbey (regarding mutant armor) is transposed. What should be the player's word choices instead appear in the shopkeeper's dialog window, and vice versa.

    In the Abbey area, I was also able to find my way into the Death Claw cave and recover a book. I didn't know that this was a part of a quest. But when I finally speak to the head man on the third floor, he is ecstatic that I found it. My character then reacts as if I had known what it was about, all along or that I had already understood what the quest was.
     
  9. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    This is the result of the "fix" for the too many items bug. Nearly all items that have scripts attached to them have had their scripts removed and the relevant code placed in the dude_obj script. As a result, these items must now have the "use on" method rather than "use". It's something you'll have to live with to not experience the too many items bug. However, I believe you can right click the 8-ball in your inventory and "use" it. This way you don't have to keep clicking on the player. I might be wrong though.
     
  10. Brunzer

    Brunzer First time out of the vault

    97
    Apr 9, 2010
    Sulik has become unusable. He won't fight anymore, and when I put my mouse-pointer on him I get the 'hand-icon'. He basically has become a storage container that travels with me to each map.
    It happened in Klamath on the hunting grounds map. I was fighting gecko's and all went well, until Sulik just wouldn't move around anymore. When I travel to different maps, Sulik follows me, but remains in his storage-container-state. It's not a big deal on this playthrough, I'm going to sell him anyway.
    savegame: http://www.megaupload.com/?d=ZWNNBD15
     
  11. Ravager69

    Ravager69 Sonny, I Watched the Vault Bein' Built!

    Dec 21, 2007
    Two bugs - one, my PC won't use the custom sniper animation with a sniper rifle. I tried both normal and aimed shots, he just fires from the hip. I have the long-haired dude - does he have that animation at all? Also, I wear a Metal Armor MK2.

    Two, I got stuck after (game froze when it turned to Vic's turn) a fight with radscorpions in the Wasteland, while traveling from New Reno to NCR. Should I provide a savegame?
     
  12. Josan12

    Josan12 Vault Senior Citizen

    Oct 15, 2007
    Nope, sorry - no sniper animations for the Long Hair Dude. I may make them at some point but no promises i'm afraid.
     
  13. Darek

    Darek is currently unavailable

    Jan 7, 2008
    He's just "sleepwalking" after getting knocked out in combat. Start combat and then hit the next turn button. Do this a couple of times and he'll be back to normal.
     
  14. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Karma titles and their respective images are now implemented in the upcoming 2.1 release. They look great in game. Everyone should be quite pleased!
     
  15. Trokanis

    Trokanis First time out of the vault

    8
    May 3, 2010
    Thanks Killap for your reply, it was late and I guess I missed reading them.

    Again, uber awesome on all the work you and your team are doing.
     
  16. BgGuy

    BgGuy First time out of the vault

    6
    May 3, 2010
    I have found bug (I think it's bug :P)

    When you try to use small energy cell or microfusion cell on human it says "The car is already full of power." and uses 40 cells.
     
  17. Mirr

    Mirr First time out of the vault

    48
    May 1, 2010
    If there is no difference then it is not changed from the RP installer...I think here is your problem.

    *Edit: Try to replace MASTER.DAT with one from working RP install or use manual install to patch it yourself(see the readme file first).
     
  18. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Who did you try this on?
     
  19. Karmeck

    Karmeck First time out of the vault

    53
    Oct 18, 2007
    It's grate that you fix and add to the game and all but whats with the new paintings in navarro? And whats with the new explosions, is there a way to have the old once back?
     
  20. BgGuy

    BgGuy First time out of the vault

    6
    May 3, 2010
    Some random people in VC (the one at the entrace and the old man in tent)
     
Thread Status:
Not open for further replies.