Fallout 2 Restoration Project 2.0 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Apr 1, 2010.

Thread Status:
Not open for further replies.
  1. PainlessDocM

    PainlessDocM Sonny, I Watched the Vault Bein' Built!

    Feb 5, 2010
    Since I installed "Update 2e (2.0.2e)" I can't start the game anymore I get a "memory could not be read error" right after it shows the main menu for a fraction of a second.



    I'm on Vista X64
     
  2. Puokki

    Puokki Where'd That 6th Toe Come From?

    471
    Jun 4, 2008
    I found that excactly same item from San Francisco, from a wall locker (or a shelf, I'm not so sure) at the doctor's house. I'd like to know as well what is it.
     
  3. Mr. Bazooka

    Mr. Bazooka First time out of the vault

    14
    Apr 21, 2010
    Thanks killap! your mod kicks ass :clap:
     
  4. Brunzer

    Brunzer First time out of the vault

    97
    Apr 9, 2010
    Some New Reno bugs:

    I was doing the quest for mrs. Wright (destroy the stills). When she agreed to meet me at the church, she showed up the next morning on the southern exit grid (near New Reno Arms) yet didn't walk up to the church. I could get close enough to initiate dialogue, and besides the issue mentioned before the quest played out normally.

    savegame: http://www.megaupload.com/?d=T3PAG6E9
    screen: http://i380.photobucket.com/albums/oo245/Broenzer/mrswright.png

    On the Virgin street map when I order Cat Jules and Myron to wait, they keep holstering their weapons, only to pull them out again. In addition, Myron keeps spamming floating text which he normally would say when he's using drugs (although no drugs is actually used, and he even says those lines when his inventory is completely empty).

    savegame: http://www.megaupload.com/?d=95F6441S

    When starting a fight in the Shark Club (Bishop's casino) One of the casino patrons joins the fight on the side of Bishop's men. She is the only one who does this, and is unprovoked (tested this a few times). One time I managed to hurt her enough to flee, after the battle was over she did not engage in combat again, even after I healed her. It seems that she somehow is on the wrong team, yet not entirely.
    screen: http://i380.photobucket.com/albums/oo245/Broenzer/hostilepatron.png
    savegame: http://www.megaupload.com/?d=IM4BF6WO
    On a side note, the casino pit boss flees when the battle starts, and afterwards doesn't know his boss has just been wacked. It would be nice if he would say some line about the massacre.

    I've found two typo's in the EPA:
    This one is outside, looking at the door of the maintenance shack:
    screen: http://i380.photobucket.com/albums/oo245/Broenzer/typo3.jpg
    'scure' should read secure

    This one is on the outside map, on the computer in the centre of the main building:
    screen: http://i380.photobucket.com/albums/oo245/Broenzer/typo4.jpg
    'Thank you doing your part as a proud American!' should read 'Thank you for doing your part as a proud American!'

    I've found a problem with a Morton brother encounter. There was no Morton brother present, only 4 thugs.
    screen: http://i380.photobucket.com/albums/oo245/Broenzer/vreemdeboel.png

    This is not really a bug, but a bit strange nevertheless:
    Fire Gecko's can get out of ammo for their flame breath.
    screen: http://i380.photobucket.com/albums/oo245/Broenzer/flamebreath.png
     
  5. .Pixote.

    .Pixote. Antediluvian as Feck
    Modder

    Sep 14, 2009
    That is a reserved piece of art that looks exactly like Buffout Pills, it accidently slipped into the game…I will remove it but I need the exact location…anyone.


    * Mrs. Wright – the poor lady is being blocked in by some invisible blockers on the mapper, I will remove some blockers and give her room to move into position.

    * Fire Gecko's breath – is actually designed to be a weapon (like a gun with ammo) the magazine holds 4 shots. They run out of puff after 4 attacks.
     
  6. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    I already removed it in the batch of maps I sent you, Pixote.
     
  7. vorob

    vorob First time out of the vault

    11
    Jul 5, 2008
    Guys, i've got one single question:

    this mod only fixes bugs left from the official release of fallout 2 and restores some content that developers didn't finished? Thats all?

    Haven't killap add any things from himself?

    Oh, i see:
    "I admit that I had to make some judgment calls here and there, but the core of what you will see is something originally thought up by the Fallout 2 devs."
     
  8. vorob

    vorob First time out of the vault

    11
    Jul 5, 2008
  9. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    These are unique armor appearances for the followers you can get. Several members here did an amazing job creating them. Since they are not officially intended, they are part of the extras section of the installer. Basically, everything in the extras section is stuff not originally intended, but makes things much better. You don't have to install any of them. Do install the resolution patch though, as it is needed for several of the maps. You can still play at 640x480 if you so desire.

    EDIT: If you're still deciding whether to play, I'd suggest holding off for about 2 weeks. 2.1 should be out by then and fixes many important bugs.
     
  10. vorob

    vorob First time out of the vault

    11
    Jul 5, 2008
    Ok, thanks, i see.

    "Do install the resolution patch though, as it is needed for several of the maps. You can still play at 640x480 if you so desire."

    You mean i need to install it, but i don't need to rise resolution?
     
  11. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Correct. Just install it and never touch the resolution tab in the options menu.
     
  12. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Oh for fucks sake, does it ever end! :roll:
    It's a problem with the temp stat boost you get after having sex at the Cat's Paw (so Myron is in fact taking a drug, repeatedly).
    The game ignores a check to not take the drug when they are no longer in your crew.

    I fixed everything related to having fun at the Cat's Paw. Fix is here. Extract the files into the \DATA\Scripts folder.

    killap, I've altered the code like this:
    Code:
    Sulik as an example:
    
    procedure critter_p_proc
    begin
    	if ((cur_map_index == 54) and (self_obj == party_member_obj(16777313)) and (map_var(2) == party_member_obj(16777313))) then begin
                    set_map_var(2, 0);
                    if (get_critter_stat(self_obj, 0) < 10) then begin
                            use_obj_on_obj(create_object_sid(482, 0, 0, -1), self_obj);
                    end
            end
            else begin
     
  13. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Code:
    (self_obj == party_member_obj(16777313))
    Isn't this always true if it is called from Sulik's script? Are you trying to check if Sulik is in the player's party?

    Good sleuthing, Darek. I always appreciate the work you do. :clap:

    EDIT: Could you pm me all the changes you've made? I know you sent me stuff a little over a week ago, but I wouldn't mind having it all in one place. Thanks. :)
     
  14. patsak

    patsak First time out of the vault

    9
    Apr 29, 2010
    Minor bug: I can hire Marcus after first quest in Broken Hills
     
  15. BgGuy

    BgGuy First time out of the vault

    6
    May 3, 2010
    I think you need to make all quests in Broken Hill so Marcus won't be busy...
     
  16. patsak

    patsak First time out of the vault

    9
    Apr 29, 2010
    That's just the point that he joins at once even I didn't finish all quests
     
  17. Trokanis

    Trokanis First time out of the vault

    8
    May 3, 2010
    First of all let me say. OMG THANK YOU!!! Everyone who worked on this project it is by far above and beyond the call of duty!!! It's amazing!

    Now that I can pull my lips for all you Dev's collected cheeks. Question. Any idea how 2.1 is coming along, and will Marcus be fixed? I can assume so, I just got done reinstalling and saw these new bugs, so I'm kinda concerned about diving into the game again. Otherwise though honestly :clap: :clap: You guys are AMAZING. Thanks again.
     
  18. Brunzer

    Brunzer First time out of the vault

    97
    Apr 9, 2010
    I never went to the cat's paw, my character is afraid of sex :shock:

    The fix fixed my problem though, so thank you :-)
     
  19. muhku

    muhku First time out of the vault

    6
    Apr 12, 2010
    This mod seems amazing, but I'm afraid I won't be able to witness the awesomeness. I still can't save games, and I have tried every trick so far mentioned in the corresponding thread short of complete reinstallation of the OS. Which might or might not help.

    Do the devs have any idea what is the cause of this issue?
     
  20. Mirr

    Mirr First time out of the vault

    48
    May 1, 2010
    I think you have problem with last part of RP installer when MASTER.DAT is changed.Compare its size before and after RP install.What is your OS?When I try playing RP 2.0 under Debian with wine I was unable to save.Then I replace MASTER.DAT with one from Windows XP install and unable to save error disappeared.My Debian MASTER.DAT file was 333148322 bytes(after RP install) and one from Windows XP machine is 333149015 bytes.Also if you use wine you will need MSVCP60.DLL to use f2_res.dll.
     
Thread Status:
Not open for further replies.