Fallout 2 mod Megamod version 2.47 Bug Reports and Suggestions

Discussion in 'Fallout General Modding' started by MIB88, Mar 20, 2017.

  1. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!
    Modder

    Feb 22, 2005
    Thanks, @Muttie . Yeah, that stuff from Colly is... well, let's just say it has so many bugs that I hate to even look at those scripts. Same with those scripts involving those Brotherhood of Steel locations (even though I did go through the scripts regarding the BoS vs. Enclave soldiers a couple of weeks ago). And I'll need to check those town labels. If I remember correctly, there was a bug that caused all of the town markers after the Ghost Town to disappear when that tab was included for some reason. But I'll look at it again. I really do appreciate your help.

    My current project is actually trying to get the RP version of the EPA into the MM. This is probably going to be something that will take until next spring to finish. The maps are huge. There's just so much to work on from the maps, not to mention all of the other stuff regarding the scripts, critters, and items. And, while I do so like the maps (very much) that @.Pixote. worked on with the additional scenery, most of the time I am cursing his name because of all the additional work I have to do to incorporate those maps into the MM.

    (I hope everyone realizes that is a joke... mostly.)
     
  2. Penya1

    Penya1 First time out of the vault

    1
    Oct 13, 2019
    Hello!

    Though I downloaded and installed 2.47.4, I still have the previously mentioned bug doing the Sulik sister quest. When I want to talk with the girl or want to open the door, the dialog box jumps and I got the message ""GDialog::Error Grabbing text message!" and the game crashes. Do you have any idea how to solve this problem? Thanks for your help in advance!

    ps.: One more thing that would help, when I move the cursor to Sulik's sister, the game gives me an error message, as you can see on the attached picture.
     

    Attached Files:

    Last edited: Oct 13, 2019
  3. Muttie

    Muttie It Wandered In From the Wastes

    186
    Oct 9, 2017
    @MIB88 ;)

    Minor Fix:
    I saw @Foxx's fix for the Environment Armour (i.e. the error that “hit” & “dodge” are mixed up). I recently did the same, as I wanted to use the frames in LH, and there are two points: first, all the “weapon dodges” are hits, too, and also need to be replaced with dodge animations, and second, when I tested it in-game, only swapping AN with AO (and leave AP as it is), didn't look too good. In my opinion it wasn't clear what was a hit, and what was a dodge. So rather than having a “hit front”, “hit back” and “dodge” I decided to have one “hit” only, and separate the two dodges in “big dodge” and “small dodge”, with the big dodge being used with light weapons (unarmed (AN), knife (DE), club (EE), spear (GE), pistol (HE), smg (IE)), and the small dodge with heavy weapons (two handed: hammer (FE), rifle (JE), large rifle (KE), minigun (LE), rocket launcher (ME)). This way a light weapon has a more lively dodge (jerks back), while a heavy weapon results in a more encumbered dodge (ducks forward). And getting “hit” has one consistent frm, that can't be mistaken as anything else but a hit.
    Here's a short-time link with the frms I renamed: http://www.filedropper.com/fotacticsfrms
    In detail the changes I've made are:
    -haenroAN.frm (was originally “getting hit” is now “big dodge” aka the previous AP)
    -haenroAO.frm (was originally “small dodge” is now “getting hit front” aka the previous AN)
    -haenroAP.frm (was originally “big dodge” is now “getting hit back” aka the previous AN)
    -haenroDE.frm (was originally “getting hit” is now “big dodge” aka the previous AP)
    -haenroEE.frm (was originally “getting hit” is now “big dodge” aka the previous AP)
    -haenroFE.frm (was originally “getting hit” is now “small dodge” aka the previous AO)
    -haenroGE.frm (was originally “getting hit” is now “big dodge” aka the previous AP)
    -haenroHE.frm (was originally “getting hit” is now “big dodge” aka the previous AP)
    -haenroIE.frm (was originally “getting hit” is now “big dodge” aka the previous AP)
    -haenroJE.frm (was originally “getting hit” is now “small dodge” aka the previous AO)
    -haenroKE.frm (was originally “getting hit” is now “small dodge” aka the previous AO)
    -haenroLE.frm (was originally “getting hit” is now “small dodge” aka the previous AO)
    -haenroME.frm (was originally “getting hit” is now “small dodge” aka the previous AO)
    I think this is a good way of using all three frms, but not using a “dodge” as a “hit”.
    The link above includes all frms in MM that are originally from FoTactics (i.e. those models that use AN, AO, AP as "hit, dodge, dodge", rather than the "dodge, hit, hit" of Fo2), and I applied the same principle to them (i.e. swapped the hit & dodge animations around).


    And there are a few minor typos/errors in the “basic files”, that could get fixed (most of them are borrowed from RP):
    -In proto.msg:
    You could remove the spaces at the end of {622} to {626} (just as RP Mod did it).
    The problem is that the engine adds a space on its own (probably because of the ignored first “%s” in 621), so with that space at the end there is always too much room between 622/626 and 621 when the game combines them. (May simply copy lines {622 to 626} from RP, proto.msg).
    -In Combat.msg you may adjust the following:
    (this is a fix from RP, which is necessary, as the sentence combination makes no sense. In game it would appear as: {514}{}{%s critically missed} + {108}{}{ and } + {213}{}{your weapon destroyed} OR {214}{}{your weapon dropped}. And “You critically missed and destroyed/dropped your weapon.” sounds better than “...and your weapon destroyed/dropped”. (The full stop is added by the game). Replace with the following (again may compare to RP, which made all the fixes below, too, but forgot 414):
    {213}{}{destroyed your weapon}
    {214}{}{dropped your weapon}
    {263}{}{destroyed your weapon}
    {264}{}{dropped your weapon}
    {313}{}{destroyed his weapon}
    {314}{}{dropped his weapon}
    {413}{}{destroyed her weapon}
    {414}{}{dropped her weapon}
    -In pro_item msg you may fix two vanilla typos (Wakizashi missing Min ST) (and Pulse Rifle, having Min ST of 3, instead the correct 6.) (Also the Envenomed Throwing Knife got corrected and is now St 3 (like the standard version) instead 2, however, pro_item hasn't been adjusted yet.)
    May adjust with the following after confirming with proto files (I only added/adjusted the Min ST).
    {52200}{}{Wakizashi Blade}
    {52201}{}{A short finely crafted knife. The tip seems to be designed to pierce armor. Min ST: 2.}
    {39700}{}{YK42B Pulse Rifle}
    {39701}{}{The YK42B is an electrical pulse weapon that was developed by the Yuma Flats Energy Consortium. It is considered a far superior weapon to the YK32 pistol, having a greater charge capacity and range. Min ST: 6.}
    {70300}{}{Envenomed Throwing Knife}
    {70301}{}{This throwing knife is coated with venom. This one's deadly! Min ST: 3.}

    Anyway, all just minor stuff really...
     
  4. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!
    Modder

    Feb 22, 2005
    That error is usually the result of a missing text file.
    Check your data/scripts folder and make sure you have a file called rtribec7.int. Also, check your data/text/English/dialog folder for rtribec7.msg. If you don't see a file called rtribec7.msg, but you see one called tribec7.msg, then just rename it.

    @Muttie
    Thanks again. Those are simple enough fixes to add. Ill correct those items. At least then I'll feel like I'm making progress on the mod. Like I was saying earlier: adding in the RP version of the EPA is proving to be a beast. 8-)
     
  5. _Pyran_

    _Pyran_ First time out of the vault

    85
    Jan 31, 2017
    I'll correct the translation - please wait.
    G key - it worked (for me).
    Foxx fix for Env.Armor - present.
    HR_mainmenu.frm - works.
    HRP - works fine , default - enable.
    If possible, I will make an update.
     
    Last edited: Oct 27, 2019
  6. neptunehs

    neptunehs First time out of the vault

    4
    Nov 1, 2019
    I can't see any critical death in the game,is it a bug?If not,how can I open it?
     
  7. TL8ez

    TL8ez First time out of the vault

    7
    Apr 19, 2012
    @MIB88 First of all, I'd like to congratulate to this mod. It's great, expands the playability by a lot, in the last 3 days I almost constantly were on the game exploring things, and I'm sure I still missed out on a few. It's been a few years since I used this mod, then it was at 2.1 something, and in terms of bug fixes and content, it came a long way.

    I finished the playthrough now, and had a few problems along the way, nothing too major (in terms of breaking the possibility of completing the story), but some of them are annoying. I'm not sure which one was a bug or an intended feature, so I categorized them accordingly.

    Bugs that bigger, annoying, or breaks quests:

    - Arroyo: During the Hakunin "Walk the path of shaman" quest, he said that I should come back on a certain day. It was Aug 4th according to the statue in front of him. I made back by that time, he said come back later. I tried it in several different hours during the day, then tried at the 5th, 6th, 7th, 8th, but nothing happened. Then I left to Klamath, came back, and the quest already failed, and he was pissed at me.

    - Primitive Tribe: I managed to negotiate the merger of Umbra and Arroyo tribes with the Umbra Elder, but when I went back to Arroyo, I couldn't talk about it with the Elder. She just said I should get the GECK. Did this after I finished up in Klamath of course.

    - Den Residential Area: If I tried to get into the area by conventional means, it brought a memory reference message (can make a picture of it if you'd want to). Then I managed to get into there during the Fight Tyler's gang for Lara, but after the fight when I left the area, I got the memory reference message again.

    I could solve the quest though, by leaving the Temple area and coming back. Much later I came back into the Den, tried to go there again and it was successful, but when I tried to leave, memory reference came up again.

    - Dobbs: When I recruit him, during the first conversation, some error text shows up, but the it goes forward nonetheless and I recruited him fine. Later on (after I visited the BoS Research facility), I told him to wait, then when I wanted to re-recruit him, I got memory reference message. This happened almost all the time I tried, there was only one exception. Then I removed my armor, and I could have him re-join me, although there was no conversation about it, the windows just went down and up as if I asked him.

    Second or third time I had him rejoined, and moved onto a new map, for some reason, Goris was there with me, but he didn't move. Goris left for Vault 13 before, and I couldn't get him to move properly after he was there with me again, until I watched the holo recording of the events. Thing is though, that whenever there was a fight, he fought properly.

    Also, whenever I arrived into a map, the comments from Skynet appeared as well, even though he wasn't in my party. Skynet's infinite companion compatibility also broke, and only could get him to join after I dismissed most of my party. After that I left him behind again and the comments from him disappeared.

    - Dogmeat: After leaving him for the first time, then have him rejoin, he doesn't move, only fights, same as it was with Goris.

    - Broken Hills: Even before I stepped into the prison, the guard shouted at me and then attacked. I had no weapons on, nor did anyone else in my party, so I couldn't complete the first task for Jacob and Aileen properly.

    - Carson: After the first time I arrive to the town, I move back from another map, like a certain basement, npcs gets to be all over the place in town. The casino patron for example moves back eventually, but then he wanders away again, outside of the casino. During the quest for the Mayor, I couldn't find 2 of the 3 suspects, and I had to gather the clues twice (by that I mean reloading), to be able to confront him.

    - NCR: I killed the Hubologist as Merc asked (blew him up), but I can't progress with the quest. When I go back there's no option to tell him it's done. Probably I could bypass this with F12se but still.

    - Vault 13: If I use a Verti to get to the Vault, it puts the bird onto a place on the map where I can't access the cockpit, only the trunk.

    - Vault 14: After I got the location for Vault 14, I tried to speak with Marcus. I read in an older guide that's the thing I should do. There was no further option regarding the armor. I didn't get the random encounter with the 2 dead mutants for a long time either, so as the dirty ass cheater I am, I used the F12se to get the Master card. It worked, but when I entered the area, the screen went to white like when I die and put me on the starting screen. Much later, I got the encounter, got the card, and used that card to get into the base, it worked with it properly.

    As it happened with someone else in the forum, the Meris bug was a thing to me as well. The Doc agreed to give her to me, but then the texts disappeared, and only could click onto barter, which was empty as well. Couldn't do anything but quit the game.

    - Tanker: Badger didn't asked me to save his girlfriend at all, but if I did, or let her die, things progressed as it intended.

    - BoS Bunker: Now this is the biggest and most annoying for me personally, and I spent quite the time trying to figure this one out! Also this was a problem for me in the previous version I played, years ago as well. After I helped Matthew, I went to the Bunker, trying to join with the BoS. They gave me the reconnaissance quest which I completed by saving all of the soldiers. I went back, talked with the unnamed paladin, he welcomed me, and nothing happened. When I opened the door, and tried to used the elevator, it showed me the message that I need the elevator access. Then when I tried to talk with him again, he just said "Hello", but there was no conversation. I tried this several times but nothing happened.

    Then I decided to look at it in the F12se editor, if I can figure something out. Basically I just randomly pushed buttons as the Chosen One sometimes, and figured out that the even numbers at the GYVAR section for the quest values means the different outcomes, and 0 for the reset. I tried the option where they all died, where just some of them died, where I supposedly went up with the help from Matt, but in this cases, there wasn't even a "Welcome" text from the paladin, as it happens when I save all of them. I have a save file that is early on during the mission, the point where the fight with the Enclave troopers began, so I tried to actually play the scenarios that I saw in the convos. I ran away, went back to them, told them about the situation, they sent me to Matt, but when I talked to him about it, after he replied nothing happened. I had the option the tell him again, but with the same outcome. I visited the Siege, they were all dead, but I couldn't tell nor Matt or the paladin about it Then I played one where some of them died, or I let all of them, but got the same results as before, where I used the editor to achieve it. Basically, nothing that I tried worked, so I gave up on it.

    If we had an item for the elevator access, passcode, holodisk or something, it would be easy to bypass this, but as it is now, it's the end of the way as far the Bunker quests concerned, and of course for the Bounty Hunter alliance as well.

    - BoS Research Facility: I managed to get into it by a lie, but the bring 10 gecko pelt quest never appeared here, also this is the place where the Dobbs things started as mentioned above.

    - After I have Marcus have some fun in Reno, and ask him about the sterility, then quit the conversation screen, I can't talk with him again.


    Minor bugs I can live with:

    - During some conversations, mostly at modded content ones, when I move the arrow over an option, it gets highlighted and remains that way even after I move the arrow from it.

    - I read in of the readme-s that the Bridgekeeper shouldn't have 2 set of robes anymore, he still did.

    - Vault 23: When I went to the second floor, and the first round of fight was over, I got a memory reference message. I could get onto the 3rd though, and finish the quest properly.

    - Gecko: I pissed off the Enclave in Gecko deliberately but didn't get the encounter for a long time. It appeared only after I completed the story, and went to Gecko by car, also it appeared when I arrived on the Gecko tile on the worldmap.

    - I read somewhere that you met with a bug when the Den and Vault City caravans fight, but the members fight each other, most likely because of the Klint mod, same thing happened to me. It was quite funny :cool:

    - After I recruit Lenny, but long before he is cured, the game calls him Lenny, the ex-ghoul, then after he gets cured, he is called Lenny, Harolds assistant. Then it goes back to ex-ghoul again. Also the first time I cured him, he had the black skin look, like the cat-eyed companion from RP EPA, then the second time, he was the generic white guy with a leather jacket.

    - Sometimes when Sulik and Cass use the Advanced PA, the talking head (great addition by the way, especially with the voice changed), the screen is just black. I can talk with them, hear the sound, etc. If I talk with them again, it works though.

    - First time the Verti arrived at Navarro, the screen faded black and the Verti landed right on me, where I couldn't move from. I had to reload this, otherwise I get stuck.

    - The Brotherhood Power Armor and Professional Power Armor (I got them with the editor), given to the companions, makes them disappear (the companions I mean).

    - Sometimes removing power armor makes companions disappear (this happened with Myron for example).

    - There was one time, where after arriving to Reno, Dobbs randomly disappeared from my party.

    - At the green area on the lowest EPA floor, where the creatures are, they start combat with me even though they are locked away. My companions can shoot them fine, but if I do, I get a memory reference message.

    - I can ask for a fuel refill with the unnamed paladin at the BoS Bunker, the same one that gives the reconnaissance quest, even though when my Verti is not there.

    Things I'm not sure if a bug or feature:

    - Lower level enemies do massive damages with average weapons. The Bishop and Mordino family members, both with the ones with combat shotgun, and the ones with Tommy guns and their usual weapons as well, did a number on me and my companions, when we were already wearing power armors. I had a PA on, and a Bishop guy with a Combat Shotgun did a 75 burst damage on me, and we weren't even that close to each other.Same thing happened the big dudes with the Tommys, which was an even bigger surprise. I mean come on, I was wearing a PA.

    Then the Hubologist guards with their AKs made 30-40/shot on my companions, who were wearing Advanced Power Armors. Once a Super Mutant, from the border of his shooting range, made 200 on me while I was wearing Advanced PA and had like 50 something Armor Class, with his Minigun. During the Redding run for the NCR trader, the guard with us made a 120 burst damage on Cassidy while he was wearing PA, with a Jackhammer only. I get that Enclave patrols, BoS soldiers and co makes high damage even while wearing a PA, with Gauss rifles and such, but these cases mentioned above makes PA almost useless.

    - BoS Research Facility and The Glow: I talked with the scientist that started to talk about FEV, but text said I don't know enough for this kind of talk. I had Intelligent at 10, and 120 science already. I put points onto my science until it reached 201, and I still got the same thing. I guess this dude would give me a Glow related quest, not sure if this isn't implemented yet or was a bugged.

    When I went to the Glow, Moloch or Melech's body wasn't accessible, I could only use the googles on him, but when I went up close, it took away my action points, like when I loot during combat. I also had to reach the other end of the first floor in combat mode, because for some reason I couldn't finish the combat until I killed everyone.

    I was wearing a PA and took Rad X to the point where it had no effect, and still got massive dose of rads randomly (I guess this is somewhat intended), then after radiation reached a point, the doses just stopped. This doesn't makes much sense, because in Fallout 1, without PA, and only with Rad X, you only get a mild dose of rads at the Glow.

    - At the lower floor of the Tanker, Suze gets targeted the moment the fight begins. Also the floaters there were basically immune to energy weapons, just as the big rat in Vault 23, where Cass with a Combat Shotgun did more damage than me with a Plasma Rifle. I don't know of these is intentional nerf or not, but it seems a bit unrealistic that something tears through Frank Horrigan (Pulse Rifle) can't properly damage a floater.

    - At some places, Pulse Rifle completely obliterates enemies along with their weapons and armors, no black dust, no loot. Usually this came up in the mod areas and with mod enemies, like the Siege map, or Vault 14, but sometimes it happened at vanilla places.

    - During the New Reno Prizefighter quest chain, I decided to disqualify myself from the ring against the Masticator, since I had no special gloves and such. Then I got them, the dude was still at the Bishop basement, but when got back into fight with Stuart, I got the first fighter as an opponent, and after I beat him, I became the champion.

    - Even though I was completely respectful with Lynette, had high enough Charisma and Speech skills, I still couldn't get to be the Captain of the Guard title in Vault City.

    - Even after cured and wearing a PA, the Vault City guards still count Lenny as a Ghoul.

    - Lenny's talking head image, and conversation options remains the same after being cured, also Myron doesn't have an Advanced Power Armored version.

    - The Monastery guys attacked me after I gave the Vertibird plans to others, and they hit 100-200 damage points, while I was wearing Advanced PA, also the head monk had a massive amount of Action Points.

    - I couldn't get the info from the NCR computer for the Monastery. I used the computer and it said needs some key, after the download stopped at 15%, but I couldn't find any key on Merc or Carson, nor in the building. The same thing happened when I used the Abbey Holodisk on the computer.

    - At the Primitive Tribe, I didn't get the weapon collecting quest from the Chief Warrior at all, although the first time I went there was when I rescued Sulik's sister.

    - I used the Ranger map but the Safehouse locations haven't showed up at all. (I read somewhere that this is already implemented.)

    - I got the Super Mutant Armor from the Abbey merchant, then I could get it from Vault 14 as well, are these stacking or should I just bother with only one of them?

    - I read about the Ghoul and Environmental Armor at the EPA, but couldn't find any of them, only through F12se.

    - I had sex with a girl called healthy slave in Carson, then she just used generic npc lines without able to talk with her again, it turns out she's the girlfriend of that Hunter, but could only ask about her from the Motel owner, nothing more, and then tell lies to the guy or admit I had sex with her and the he attacked me.

    Well, these are the issues that came up during my playthrough. It became a much bigger text than I planned, but I think I got most of the ones I saw pegged down in it. Honestly, even the bigger or quest breaker ones are the kind which I can get over, but that BoS Bunker thing really bugs me. I'd appreciate it if you could give some pointers on that if something can be done with it.:nod:
     
    Last edited: Nov 1, 2019
  8. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!
    Modder

    Feb 22, 2005
    Holy moly, @TL8ez , that's a lot to address! Thank you very much for this list. I'll look into these and post answers as I find/correct them. I will say that most of the bug fixes will have to wait until my current project is finished: adding in the version of the EPA from the RP. (On the bright side, I've gotten those maps to finally open in my MM game.) It's a big project, and not one I want to stop in the middle of. However, a few things:

    I need to check the scenery description. It's the evening. You have to report to him on the 4th, but in the evening. It has to be around midnight, I think, although you might be able to do it a little earlier. I would need to check the script to give you the exact range of times. However, the shaman path does work.

    I keep seeing people mention this bug, but I cannot replicate it at all. I never have a problem with the Den Residential area crashing. I'll start another game and see if I can get the crash.

    I hope I fixed this in the latest version. These are two separate tribes. Sulik's sister isn't supposed to play a part in both of them. The tribe that Sulik and his sister are from isn't supposed to have that quest.

    Carlson does have a key (item 585) to operate that computer.

    I've just added code to allow Lenny to enter Vault City if he is human.
    I haven't yet added code to allow him to get past the guards while wearing a robe (like Goris does) or power armors. And, I don't really know if I should. I need to think about that one a little more.

    I don't have any images for Lenny after he has been turned back into a human. And I have just fixed (as in 15 minutes ago) the artwork for Myon's talking head while in advanced power armors.

    I can't remember exactly when they will show up. At most it is only a day. Leave Gecko and go somewhere else. When you return to Gecko, go to the 'settlement' location, NOT the Junkyard. You will never encounter them if you enter Gecko via the Junkyard map. It has its own map, as it technically is supposed to occur just outside of Gecko.

    I added the code to the script, but added it incorrectly. It should work fine for the next release. (Just edited the script a couple of minutes ago.)

    The BoS areas... these are full of bugs. When I decide to tackle those areas, I know I'll have to completely rewrite how things work. I'm not looking forward to that.

    The Glow is definitely a work in progress... One of mine. No quests or overlap with the BoS as of now. Another area that I want to add to... in time.

    Regarding Lynette and the Captain of the Guard: I know it works. I can't remember exactly what you have to do. Best thing would be to check Per Jorner's ultimate Fallout 2 guide.

    The armors for Marcus do not stack. You only need to get one of them.

    EDIT:
    That's pretty much all you can do regarding her. (Well, there is one other minor optional story, I think, but the end result is basically the same.) She is not a major character. She is only there to give you a chance t make friends with or an enemy of Leon the bounty hunter.
     
    Last edited: Nov 3, 2019
  9. neptunehs

    neptunehs First time out of the vault

    4
    Nov 1, 2019
    Breaking down car events have some bugs:
    1.I encount it when I don't using a car(leaving somewhere,no fuel);
    2.When I encounted it again with car,and I leave this map,chosen one still driving his car to Den;
    3.After I fix car then save and load,car become broken again.

    And I have no way to finish "Plant the laughing gas on Salvatore." quest after plant poison tank,and not like Megamod Guide in Vault-Tec Labs wiki,I can't see Salvatore die laughing.

    Something not important:
    1.I don't know why but karma become exp in logs.
    2.Sewers in the desert,I can enter it without open cover.
    3.KAGA AMBUSH Player series encounter not have Counter:1 and has a high Chance,annoying and dangerous in early game.
    4.

    And some questions:
    1.Again,how can I re-open crit death?I have trouble to kill Vorpal Rat(not like RP,Holy Hand Grenade only make 10~20 damage when throwing skill is low) and the man in bridge.
    2.Smitty not sell Micro Fusion Cells now,is it feature?
    3.Can I get YK42B around Modoc after using this mod?I spend hours to try but only deathclaw/pigrat/firegecko/radscorpion in the cavern.

    At last,thanks for making a great mod.
     
    Last edited: Nov 3, 2019
  10. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!
    Modder

    Feb 22, 2005
    I will look at this. Obviously, you should not encounter that map if the car is not being used (i.e., if it is not in your party).


    Yes, I can't figure out how to resolve that issue. When your car breaks down, the random map is created. However, when you leave that map, the game still acts as though you are still driving until you enter another map. After that, everything works as it should. The only thing I can think of to fix that, which I thought of just now, is to force another encounter as soon as you leave that map. Oh! Yes... and I think I have just the thing... :newevil:

    It is just a random chance. Are you saying it beaks immediately EVERY time after you fix it?


    Um. No. I'm not changing that. If you want to be able to plant laughing gas on Salvatore, then you'll have to do it BEFORE you kill him. However, it does raise an interesting question: Without that quest, you can't become a full-fledged member of the Thieves Guild. Hmm. Mabe I'll devise an alternate quest. Or, maybe that is just the price someone pays for killing him. I'll give it some thought.

    I don't understand what you mean by this.

    I'll test this out. I've never noticed anything like that. An, honestly, I don't know how I could fix it if the artwork is somehow not working properly.

    I've already decreased the chances for Kaga encounters for the next release. Yeah, it was annoying. But, it's not supposed to only happen one time.

    I don't know about this bug. I've never encountered it. I haven't changed anything with regards to critical deaths. Do you have the violence setting turned down?

    I don't remember that he ever did. The only person who I thought sold fusion cells was T-Ray.

    Again, something else I don't remember changing. Was this something from the RP?
     
  11. neptunehs

    neptunehs First time out of the vault

    4
    Nov 1, 2019
    First,apologize for my poor and rude English.

    After I fix it,if I save without leaving this map,than load this save,it will break again.

    https://imgur.com/a/W5nU9Vm

    https://imgur.com/a/FoF2aXh

    and according https://falloutmods.fandom.com/wiki/Critical_hit_statistics
    Eyes:

    Message Effects Chance Count
    Doing some extra damage due to the sensitive location. Damage x2 bypassing armor 17.96% 37
    Summoning this creature to the great ratcatcher in the sky. Damage x2, instant death 51.46% 106
    Summoning this creature to the great ratcatcher in the sky. Damage x3, instant death 30.58% 63

    "Summoning this creature to the great ratcatcher in the sky" will cause insstant death,but now rat still alive,and suffers 10 hp and an unknown crippled limbs.

    From The Nearly Ultimate Fallout 2 Guide Written and coded by Per Jorner
    Get car part for Smitty.

    Smitty in the junkyard has a car to sell you, only it doesn't work. Bring a Fuel Cell Controller (which you can get later) and he'll install it and give you the car for only $2000. If you have the Fuel Cell Regulator from Klamath, he'll install that too for $750, and the car will need 50% less fuel. Once you install the Controller you may want to trade for Smitty's Micro Fusion Cells (you'll likely have surplus weaponry at this point), which he restocks every 3-5 days.

    Or maybe I misunderstanding because my poor English?

    My fault,I didn’t make it clear.
    I mean,I can get YK42B from raiders inside cavern in random encounter.

    [Encounter Table 19]
    lookup_name=Mod_M ; Areas around Modoc
    maps=Mountain Encounter 6, Mountain Encounter 5, Mountain Encounter 3, Cavern Encounter 4,Cavern Encounter 5

    Maybe from Cavern Encounter 4 or Cavern Encounter 5,but as I try,megamod has same maps between Cavern Encounter 4 and Cavern Encounter 5,and original fallout 2 not.Well it's really rare,maybe not enough trials...

    Something not important:
    1.Everyone in Scraptown will not turn hostile when you have been caught stealing.
    2.Refrigerator in Scraptown will be locked everytime load a savedata,even it is opened.

    By the way,how to open these ice chests?
    https://imgur.com/a/aWsj4dT

    Thanks.
     
    Last edited: Nov 5, 2019
  12. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!
    Modder

    Feb 22, 2005
    @neptunehs

    First, don't EVER apologize for not speaking another language as well as your native language. You made an effort more than most people make. Your English is just fine. (And, I can't judge, because I've forgotten most of the other languages I studied.)

    Scraptown. Old scripts. I don't think they care if you steal from them. Kind of like the kids in the Den. However, they SHOULD care. I will modify their scripts. I'll also check the script for the refrigerator.

    Regarding the rats and that message: Is it all rats? Or, is it only the new creatures, like the rats in vault 23? It could be a problem with how the newer files which control critical hits for new critters.

    I don't know what is going on regarding the save/load and repairing the car. I'll look at the scripts involved. But, in the meantime, just make sure to leave the map before you save! :P

    Regarding Smitty and the fuel cells, you understood the guide correctly. I either just forgot about that or never knew it. I'll look at Smitty's script. The fuel cells may be something that was removed by accident.

    Regarding that YK42B, you can't get it anymore. I don't remember when it was changed, though. But, I've looked at the worldmap file, and I don't see it created in any random encounters.

    Regarding the ice chests in Redding, you are not supposed to be able to open them. Those are the chests which hold the inventory for the doctor and the mayor.
     
  13. neptunehs

    neptunehs First time out of the vault

    4
    Nov 1, 2019
    I never see instant death in all creatures,except floater,centures,coach or fruit fly I don't try.
    And I don't know if it is relevant,but everytext in kills are broken except coach or fruit fly.



    Some encounter between Modoc and Vault City will cause crush.


    I don't know why but I get stuck in Broken Hills mine after enter combat mode...

    Sorry,I found Smitty sold batteries now,maybe just rare.

    Something not important:
    1.Computer in the Gecko reactor,I choose B or C then Oops than I can get into robot action,I forgot is it right?
    2.No reward from the quest "Liberate some of Salvatore's guns."

    3.Everyone in Raiders have two set of armor.

    4.All locks in SAD have no effect,and using repair to disable robots are not effect too,feature?
    5.Jack in Cold Heart Farm says trader in SF have big money and don't care you stole(like original FO2),but of course I can't.
    6.Nessa (Ghost in Primitive Tribe) will pick up a knife.
     
    Last edited: Nov 18, 2019 at 3:31 PM
  14. FalloutBruhMoments

    FalloutBruhMoments First time out of the vault

    42
    Nov 8, 2019
    Bruh Killap hasnt been active since 2016 but you're still here to this day on this mod kudos to you, im yet to try your mod but currently downloading, also you should fix the links on the main install page (the one recommended when you go on fallout 2 downloads) as it has a very out of date and broken link, i had to go on the wiki to find 2.47.1 as your actual newest version says "access denied" when you go on the link.
     
  15. FalloutBruhMoments

    FalloutBruhMoments First time out of the vault

    42
    Nov 8, 2019
    Aaaaaaaaaaaand i have an issue


    I didnt have this problem in the RP, how do i extend the screen to correctly match my 1366x768 resolution? the game itself runs in that but the screen is in this rectangular box.
     
  16. Lexx

    Lexx Background Radiant
    Moderator

    Apr 24, 2005
    The RP is using different (modified) maps and map borders. The Megamod doesn't, which is why your screen looks the way it does.
     
  17. FalloutBruhMoments

    FalloutBruhMoments First time out of the vault

    42
    Nov 8, 2019
    so basically there's no way around this and i have to play the game like this.

    back to the rp then
     
  18. Matt Drax

    Matt Drax Smart Ass

    99
    Sep 4, 2010
    Dude, it's literally just one of a very few too small maps...
     
  19. FalloutBruhMoments

    FalloutBruhMoments First time out of the vault

    42
    Nov 8, 2019
    So how many of the maps are tiny?
     
  20. Lexx

    Lexx Background Radiant
    Moderator

    Apr 24, 2005
    Dunno. Find out while playing? You aren't for very long in these maps anyway... does it really matter?