Fallout 2 mod Unofficial Fo2 patch thread - problems, reports, suggestions

Discussion in 'Fallout General Modding' started by Per, Aug 15, 2007.

  1. Bluejay

    Bluejay First time out of the vault

    2
    Jul 11, 2013
    white screen after turning DX9 "off"

    Hi,

    I just asked this in another thread here (and over at the wiki). I'm sorry if this is not the right place to ask.

    I installed the game OK and it seemed to work fine, until I turned the DX9 mode to "off" on the SFall screen options. Since then, the game shows only a white screen on startup; I can hear the intro sounds and music, and can even skip the intro by mouse clicks and exit the game by "Esc" once the intro has ended, but the video never shows anything but a white screen. I already did the ddraw edit (graphics = 4) and tried all other graphic modes, including editing the F2_res.ini; the bug persists even after uninstalling and reinstalling both the mod and game from scratch. I have Windows 7 Professional SP 1, Fallout 2 humongous install, only mod is F2RP 2.1.2b with windows installer.

    Can you help me? thank you!
     
  2. Darek

    Darek is currently unavailable

    Jan 7, 2008
    @ Bluejay

    Did you try to restart your computer?
    Sounds to me like something graphics related has crashed.
     
  3. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Another update to the unofficial patch! Even more vanilla bugs were found, in addition to corrections to some bugs I introduced. As mentioned in the RP thread, this is likely the last update that will be made.

    As before, DO NOT install this over the Restoration Project, as it already includes my latest patch. I just wanted to remind everyone about this even though the patch installer will refuse to install if it detects that the Restoration Project is already installed.

    Enjoy!

    Windows Installer Version (highly recommended): download
    Windows Manual Version (advanced users): download
    Mac Version: download


    1.02.28 change log:

    Code:
    Arroyo:
    -------
    • It was possible for the inner door to Cameron's chamber to remain locked even after completing the Temple of Trials.
    • It was possible for critters in the Temple of Trials to wander outside player reachable areas.
    • Corrected a dialogue inconsistency with Hakunin about his garden when you have negative karma.
    
    
    Broken Hills:
    -------------
    • If your reputation is low enough, Liz in the General Store says she won't sell you anything, yet you can still Barter if you press the button on the right. This is no longer the case.
    • Liz's shelves still restock even after she dies. This no longer happens.
    • You could still fail a steal check on Liz's shelf even after she is dead. This is no longer the case.
    • Tweaked the way Doc Holiday checks for hurt followers to be in line with other doctors in the game.
    • Confronting Francis about the missing people now properly removes the note you find on one of them.
    
    
    Den:
    ----
    • Two kids outside The Hole were invisible because of female critter mix-up from the RP.
    • When you sleep with Sheyla, she initiates dialogue shortly afterwards. If you talk with her again before that and choose to sleep with her a second time, the game then locks up. This is no longer the case.
    • Attempting to talk to Metzger (clicking on him) in combat and then killing him causes his script to break.
    
    
    Klamath:
    --------
    • Goo in toxic caves no longer mutates you if you are wearing any type of power armor (before you would only be protected with just regular power armor)
    • If you drive the car to Toxic Cave, you won't be able to access the car trunk. This has been fixed.
    • The description of the broken down car with the regulator in the backseat did not change even after picking up the item.
    
    
    Military Base:
    -----------
    • You can no longer use lockpick, traps, or science to repair to repair the generator on the first level. Only repair skill works (or repair tools).
    
    
    Modoc:
    ------
    • You can no longer steal infinite shotgun shells from Grisham (correctiont to bug on my part).
    • After completing the quest, you can no longer still tell Cornelius that Farrel has the watch in his safe.
    
    
    NCR:
    ----
    • Fixed issue where you have to provide the door password to Duppo's backroom to exit the backdoor even though you're already inside.
    
    
    New Reno:
    ---------
    • Some of the slot machines in New Reno casinos cannot be accessed because 'somebody blocks them' - even though nobody is. This has finally been addressed!
    • Attempting to talk to Pretty Boy Lloyd (clicking on him) in combat and then killing him causes his script to break.
    • Fixed minor dialogue error after asking Myron to take off his armor.
    
    
    Redding:
    --------
    • Removed any references in scripts/dialogue to the Fannie jet problem. This was left over stuff that had moved to the RP, but was never fully removed from the UP.
    
    
    San Fran:
    ---------
    • The Shi people now properly give their dialog floats when you kill ASH-9, rather than always giving the floats about the challenge between Lo Pan / Dragon.
    
    
    Sierra Army Depot:
    ------------------
    • One of the mines near the shack with a howitzer can't be disarmed or triggered. This has been fixed.
    
    
    Vault 15:
    ---------
    • The guard on level 2 with the hunting rifle now has the correct ammunition.
    
    
    Vault City:
    -----------
    • Choosing the option "Search the archives for location of Vault 13" with the Vault 8 computer would exit dialogue immediately.
    • If you insert the hydro-mag part into the powerplant's maintenance terminal AND then log-off immediately, on another log-in the part is not there anymore. In that cause, it's impossible to repair the reactor. This is no longer the case.
    
    
    Misc:
    -----
    • Numerous fixes to caravan runs.
    • Map fixes: Map holes (BOS bunker in San Fran), improved player position when exiting Sierra Army Depot, walking into shelves (Wright's house), stacking flares in Hubologist base in San Fran, and other such fixes.
    • Critically failing to disarm traps now properly sets them off.
    • Various typos fixed.
    • Sfall updated to 3.1, which fixes the crash bug when planting explosive on critters.
    
     
  4. mishalgunner

    mishalgunner First time out of the vault

    3
    Jul 22, 2013
    Hey Killap - amazing work!

    I use the Mac version of FO2, from GOG -

    Can someone please help me - I'm useles in this stuff (and I've tried searching)

    1. Can I add the Restoration Pack 2.2 on my Mac GOG Fallout 2? If so, how?

    2. If I cannot add the Restoration Pack on my Mac version, than atleast I can add the patch (most recent) - will this improve the game on the GOG version of FO2 for Mac?

    Please help!

    Thanks
     
  5. MaxV

    MaxV First time out of the vault

    3
    Jul 22, 2013
    Hi, everyone.

    I've encountered, as it seems, famous no restocking bug, when all merchants stop to restock all of their items, including money. All of the stuff that i sold to them stays in their inventory forever. It happens exactly in the mid of june in 2248 for me and first was spotted in SF. Then i traveled to NCR and it was the same, merchants don't restock.

    I've been searching information about the solution of this problem and found nothing, except the fact that such problem exist and people who already encountered the same bug and posted about it.

    I'vo got clear FO2 english version with official 1.02 patch installed and latest version of unofficial killap's patch. Win XP SP3. When i first encountered this bug it was patched with killap's patch v1.02.27.3.

    This problem was described here by topicstarter already http://www.nma-fallout.com/forum/viewtopic.php?p=776439&sid=1ff7ca5a7a5f9f39978099665236ca8b, but there was no solution for it.

    So, any help would be much appreciated, 'cause i'm stuck on my first playthrough of FO2.
     
  6. Darek

    Darek is currently unavailable

    Jan 7, 2008
    This has been fixed. Here's the details if you are interested.
    Wait, looking at the files I see this is only implemented for the Restoration Project, not the patch.

    Hm, was this by choice killap?
     
  7. MaxV

    MaxV First time out of the vault

    3
    Jul 22, 2013
    Darek, thanks for your reply.

    So, if i'm correct the only option now to resolve this problem is to install Restoration Project and start the game from the beginning, or the savefiles from the original game will work with the RP as well?
     
  8. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Your old save games will not be compatible with the RP, so that is not an option. You might want to wait for a fix, assuming killap simply forgot to add it. You could just start a new game with the RP in the meantime, and continue with your old save later.
     
  9. MaxV

    MaxV First time out of the vault

    3
    Jul 22, 2013
    Ok, Darek, thanks for your help.
     
  10. zenla

    zenla First time out of the vault

    1
    Jul 27, 2013
    Two bugs so far.
    I can t bury the locket ghost from Den because there is rope not shovel
    in bookcase.
    When I am in Modoc I ask my men to wait for me while I bomb the toilet but then only either sulik or vic wants to join me saying I am too crowded
    Also Dynamite will not blow up If I set timer to high and just magically disappear. Why I could even get hurt before I am leaving the well after implenting dynamite.
     
  11. Matthews

    Matthews It Wandered In From the Wastes

    193
    Aug 29, 2012
    Not really bugs, as there are shovels to be found in Arroyo, local traders in Den to my knowledge (found 1 at Tubby on my last run, could be randomized though). I recall 3 places where you need a shovel for questing, thus I make sure to pick one up ASAP and carry it along. (Also, why would anyone put a SHOVEL in a bookcase?)

    As long as the timer isn't under 1 minute, your group should make it out in time before it explodes. I never had to leave members behind, because the damage incoming is basically neglectable, unless you set off the bomb while still standing in the methane-cave in which case you all die.

    So not bugs per se.
     
  12. Felipefpl

    Felipefpl Look, Ma! Two Heads!

    374
    Jun 17, 2010
    THIS is the place for bug reports http://falloutmods.wikia.com/wiki/Restoration_Project_bug_reports and please, if you and everybody wanna really help killap read everything that is written there and post a savegame...
     
  13. SorgFall

    SorgFall Still Mildly Glowing

    220
    Jul 2, 2007
    Known bugs

    Are there any known bugs in Fallout 2 (I read they were called hard-coded often over the years), and any guidelines to somehow evade them?

    I'm not referring to the standard problem of saving mid-combat, which should be avoided at all costs because it could mess the game up.
     
  14. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    AFAIR there's a shovel on the ground near the bookcase, try pressing the shift key to highlight it for easy picking.
     
  15. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Re: Known bugs

    I've been making a list of these "unfixable'" issues on the wiki. See the top of the "Misc" section. They are marked as "Engine issue"

    http://falloutmods.wikia.com/wiki/Restoration_Project_bug_reports#Misc._bugs
     
  16. .Pixote.

    .Pixote. Carbon Dated and Proud
    Modder

    Sep 14, 2009
    Isn't that shovel a bit too obvious...remember Smitty (The Den) has a shovel, and there is a shovel on the ground near the Chosen Ones aunties tent (flint quest) in Arroyo. Maybe that shovel near the bookcase should be removed and allow the players to seek out the other 2 at their own expense. We wouldn't want to make it too easy... :P
     
  17. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    I swear in one iteration I removed the shovel (cause it's cheap) and then placed the diary there on the ground, which made it harder to find than just being on the shelf. Not sure why this ended up going back to the state it is in right now...
     
  18. Darek

    Darek is currently unavailable

    Jan 7, 2008
    In vanilla there were two shovels, one in the shelf and the other on the ground just in front of it. You changed the one in the shelf to the diary so I don't think you should go and remove the last one. The devs clearly felt you should find a shovel there, though two of them were probably a mistake.
     
  19. Felipefpl

    Felipefpl Look, Ma! Two Heads!

    374
    Jun 17, 2010
    talking about items and stuff, it comes to my mind if you told Pixote about this "(Yeah, this is an old vanilla issue. I thought Pixote came up with some graphic hack though. Either way, the Salvatore one can be addressed, but the Navarro one is too difficult without a different scenery piece there. -killap)" and if you fixed those tons of bugs a guy posted in the RP thread, i hope u didnt forget him. ;)
     
  20. .Pixote.

    .Pixote. Carbon Dated and Proud
    Modder

    Sep 14, 2009
    I'm sorry, what art hack are you referring to?