Fallout 2 Restoration Project 2.2 - OPEN BETA (ie NOT FINAL)

Discussion in 'Fallout General Modding' started by killap, Jan 6, 2013.

Thread Status:
Not open for further replies.
  1. Blacksun

    Blacksun First time out of the vault

    29
    Apr 20, 2013
    Bugs

    Arroyo:

    - the tails of the small scorpions in the temple (and maybe everywhere else) are showing the following description:

    (None)
    You see nothing out of the ordinary.
    It weights 5 pounds.

    - In Hakunins dialog the "i need healing" option don't appear


    Misc:

    - normal knives and spears use multiple slots in your inventory, so it looks like:

    ...
    knive
    knive (3)
    knive (2)
    ...
    spear (2)
    spear


    i will post all bugs i'll find through gameplay.
     
  2. Blacksun

    Blacksun First time out of the vault

    29
    Apr 20, 2013
    Klamath:

    - if you steal the spiked knuckles from the duntons before you kill them, the knuckles are still on their bodies.



    and a personal problem:

    i have edited the protos of the companions. in RP 2.1.2b you just need to copy the base-protos of the companions without write protection in your savegame\Proto\Critters folder before you entered a map with them and the stage-protos with write protection into Fallout2\Data\Proto\Critters and it worked.
    but now, if sulik levels up, his HP shows 95/85 and no other stats are changed.
    normally this problem is a result of write protected base-protos, so they can`t update themselves to the next stage, but my base-protos are without write-protection.

    can someone please help me? i am desperate. :(
     
  3. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Re: Bugs

    Do you know roughly where you picked up these weapons that don't stack properly?
     
  4. Darek

    Darek is currently unavailable

    Jan 7, 2008
    @ Blacksun

    I think you have fucked up your protos.
    The small scorpion tails does have both a name and a description.
    It's in the proto file for the small tail. If you don't have it you must have somehow removed it.
    That makes me a bit suspicious of your knife situation as well. That and I haven't seen that happening in this build myself. It used to be a problem but I thought all had been found and corrected.

    As for your level up problem, sounds to me like Suliks proto file in your save slot is write protected. They should never be for NPCs as the game won't be able to make any changes to them.
    If the base proto file in the data folder is write protected, the proto in the save slot will be too, so your base proto must have been write protected at some point to cause that.
    Also iirc, if your NPCs save slot proto is write protected, it will leave a write protected proto file in your data/proto folder as well (the data/proto folder is used as a temp folder). That one should be removed or it will make the save prote write protected again (going around in a nice little circle).
     
  5. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    I just got around to the quotation changes that merenbach made and I'm a bit confused/concerned with it all. For example, one of the changes that occurred was that all instances of ' changed to ’

    First off, one of my text editors doesn't even recognize the change (it puts a black rectangle in place of it). But what concerns me the most is that I'm not sure how to actually make that symbol on my keyboard. When I type a single quote I get a ' which means that all future edits to those files by me will be using a different symbol than what these changes brought about.

    Now I know nothing of font glyphs, so perhaps I just need to be educated in that area. I want to know more about this before I go and replace 99% of the text files with these changes.


    Really? I see no indication of this being possible in the script. Do you have a save game?

    Really? Do you have a save game?
     
  6. merenbach

    merenbach First time out of the vault

    42
    Dec 21, 2012
    @Killap: I've wondered whether this will be a problem. This is the character for a curly quote. Text editors that open the file in Windows Latin or ASCII, rather than UTF-8, may have a bit of trouble, but I'm pretty sure I've seen the character represented in the game dialogue.

    If you're seeing black rectangles in your editor then odds are other current or aspiring modders will, too. Instead of replacing all of those, I'm now thinking it would make more sense to not use any curly quotes and instead just use straight quotes (which I believe is pretty much a one-liner find-and-replace, compared to all the regexes I sent you).

    Please let us know what you think.

    Edit: I should add that I totally understand if this subproject needs to be shelved. I don't know how much work remains in total on the RP but I don't want to hold up anyone's enjoyment for the sake of punctuation.
     
  7. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    I'd honestly prefer to go with just single quotes. I definitely agree with making it all consistent, but I want to make it consistent in a way that doesn't require anyone to care what mode they open the text files in.

    This task isn't holding up the mod in anyway, so if you want to send a new batch of modified files, that's be cool. I'm going to pm you a new set of dialogue files though, since I've modified some since this beta began.
     
  8. Blacksun

    Blacksun First time out of the vault

    29
    Apr 20, 2013
    Re: Bugs


    arroyo, klamath, den and modoc
     
  9. Blacksun

    Blacksun First time out of the vault

    29
    Apr 20, 2013
    i have just a clean install of f2 and the beta of rp 2.2 installed. i didn`t remove any files, just placed my edited protos in the proper folders. it worked all very well in rp 2.1.2b.
    i didn't touch any protos except weapons and companions, so the problem with the tail of the small scorpion is not my fault.

    i can't remember of the "stack-problem" in rp 2.1.2b, but i just changed the damage dealt by weapons. how can this fuck all up?

    suliks and the other companion files in the save slot are definitely NOT write protected! that's the point giving me a headache! :(
    in the data\proto folder are just the stage protos and these are write protected, because the game would overwrite them.
    as mentioned before, all worked in 2.1.2b!
    would it help to upload a savegame slot for analysis?
     
  10. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Cool, I've made this option default for the release.

    Also, I've gone through all the reports sent to me, on the wiki, or found in this thread. Hopefully now I can focus my limited free time on the last bit of new content and not on fixes.

    I am happy to say that the UP has undergone testing and even more vanilla bugs have been found and fixed. Also minor discrepancies between the UP and RP were uncovered and addressed. Good news all around.
     
  11. Matthews

    Matthews It Wandered In From the Wastes

    193
    Aug 29, 2012
    Sweet. :)
    I haven't played the beta, since I didn't want to spoil my fun when I "explore" the fixes later on. ;)
     
  12. Blacksun

    Blacksun First time out of the vault

    29
    Apr 20, 2013
  13. Darek

    Darek is currently unavailable

    Jan 7, 2008
    IIRC when you change a weapon proto it does not change the weapons that are already placed on a map (as the old proto data is stored in the map), therefore you get knives with different proto data, hence the different stacks.

    As for your NPC protos...
    I didn't test playing with it but by the looks of it they are messed up.
    The protos in the save slot should be compressed with Gzip while the protos in data/proto should be uncompressed. Your save slot proto folder contains some compressed files and some that are not, and if the critters folder you linked to is your data/proto folder, then you have the same problem there.
    Can't say for sure that is your problem as I've never seen anything like this before, but it wouldn't surprise me if it is. I would try to get that sorted out first...
     
  14. Blacksun

    Blacksun First time out of the vault

    29
    Apr 20, 2013
    ok, that explains the stack problem!

    thank you very much for the advice with the compression! i never heard of it, but i will try! :D


    Update:
    It worked! now i can continue in my neverending adventure of bug-search! :D
     
  15. smuggler

    smuggler First time out of the vault

    7
    Mar 21, 2013
    Late to the party - just installed 2.2 to see what's what.

    Few things:

    I don't like the "Race" screen - find it kinda useless to remind me what type of character I use.

    Temple of trials - in 2.1.2b the character would say

    "Wow that's a big fucking ant" - each time he saw an Ant - kinda annoying but funny if said from time to time.

    Now though he doesn't say that even once.

    Also does the guy blocking the path on starting screen have less dialog options?

    Another thing I noticed even on previous version is that if your chance of hit is lower than 95% - say 79% I very often miss the first hit/shot.

    Great job on the project :clap: Hope I'd have more time to play and provide feedback but ...I just don't.
     
  16. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Um what?
    Where you high playing it last time? :lol:
    Pretty sure that has never been in the vanilla game nor the RP for that matter. Could it have been from some other mod or something?

    Yup, it's a bug when using the hero appearance mod. killap's fixed it but as this is just a beta, he will not be giving out any fixes.
     
  17. Skynet

    Skynet Mildly Dipped

    501
    Jun 5, 2003
    I don't remember that happening in temple of trials, but character says that comment about ants (when you look them) in caves beneath Broken Hills.


    I have had many suspicious missed shots, zero damage hits and even instant death kills at least in this new RP beta. I have no damage mods installed.
     
  18. smuggler

    smuggler First time out of the vault

    7
    Mar 21, 2013
    Right false alarm for "Whoa.. ...Ant" - had other patch there. Sorry for that. :oops:

    Gonna play for an hour now and see what I cant find. :D

    edit:

    Helping Torr, killed the first scorpion and went to Dunton brothers. They asked me if I'm interested in some job - I replied that I am but after that they tell me to

    "leave them alone cos they have work to do". - that's a rather awkward way of ending the previous subject ("are you interested in some job")

    Kinda like my ex on period :D
     
  19. The Dude Next to Cabbot

    The Dude Next to Cabbot First time out of the vault

    23
    Mar 28, 2012
    Not sure if someone already mentioned this (or if this issue is solely mine), but the new Lenny won't equip or use any weapon I give him, making him effectively combat-useless. :(


    BTW, love the RP. Don't play F2 anymore without it. Well done. :clap:
     
  20. .Pixote.

    .Pixote. Carbon Dated and Proud
    Modder

    Sep 14, 2009
    He is a rifle critter now, he won't touch pistols or sub machine guns...but hey, at least he should be able to use the gauss rifle later in the game.
     
Thread Status:
Not open for further replies.