Fallout 2 mod Megamod version 2.47 Bug Reports and Suggestions

Discussion in 'Fallout General Modding' started by MIB88, Mar 20, 2017.

  1. FalloutBruhMoments

    FalloutBruhMoments First time out of the vault

    Nov 8, 2019
    Probably leaves it there as a backup in case you want/need to revert to base game/pre-MM
  2. _Pyran_

    _Pyran_ Mildly Dipped

    Jan 31, 2017
    1. Not english lang - i will fixed this (Can't reproduce this problem)
    2. default - install mod in subfolder, no other action is required. (Savegame - work is fine).
    3. in the coming days, will check this.
    Last edited: Nov 18, 2019
  3. FalloutBruhMoments

    FalloutBruhMoments First time out of the vault

    Nov 8, 2019
    Also your ddraw doesnt allow for highlighting items or containers, shift key doesnt nothing and the word highlight isnt even found anywhere within the ini.
  4. _Pyran_

    _Pyran_ Mildly Dipped

    Jan 31, 2017
    In new versions of sfall-you can change the modes. Default: Objects are highlighted in the line of sight (sfall-mods.ini). Highlight items on the entire map, is equivalent to a cheat.

    !!! the installer is temporarily unavailable, please wait
    Last edited: Nov 21, 2019
    • [Rad] [Rad] x 1
  5. Nirran

    Nirran Vault Senior Citizen

    Apr 15, 2007
    it has been moved to this script - GL_Highlighting.int - included in the sfall package
  6. FalloutBruhMoments

    FalloutBruhMoments First time out of the vault

    Nov 8, 2019
    Thank you.
    Last edited: Nov 19, 2019
  7. _Pyran_

    _Pyran_ Mildly Dipped

    Jan 31, 2017
    Last edited: Nov 26, 2019
  8. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    Thanks, @_Pyran_ .

    And, just to comment on things from an earlier page:

    Fixed this game-crashing bug. (Strange that I also found it in another script and no one found it or else it just didn't have the same effect.)

    I am still looking into this issue regarding the comments even when Skynet is not in your party. However, I have to point out that infinite companion compatibility (i.e., the Cult of Personality perk) does NOT affect Skynet. It didn't make sense to me that a robot would be affected by a PC's personality. If I remember correctly, it also does not affect Robodog or K-9.

    Tested this and it works fine on my end. All three safe houses appear on the worldmap and I can enter those locations.
    Last edited: Nov 24, 2019
  9. _Pyran_

    _Pyran_ Mildly Dipped

    Jan 31, 2017
    One remark. I think that is going to affect if the brain is alive (the dog's brain, the monkey brain, the human brain). But this point is not critical.
  10. Muttie

    Muttie Still Mildly Glowing

    Oct 9, 2017
    Sorry, I was “a bit” afk. Sometimes internet/posting is too much for me.
    My mistake (facepalm while holding a sandwich). I eventually did find “alternative_sfall/SFALL-E_4.1.7/data/scripts” and figured out the G key is enabled by gl_sfall-mods.int.
    Perhaps that could be mentioned in the installation readme/instructions: (“To enable features copy int files from “alternative_sfall/SFALL-E_4.1.7/data/scripts” to “data/scripts”. Configurations can be made in ddraw.ini and sfall-mods.ini”).
    The scripts are:
    gl_ammomod.int (?)
    gl_highlighting.int (highlight items (default is within LoS), settings in sfall-mods.ini)
    gl_partycontrol.int (control party members (default is off), settings in sfall-mods.ini)
    gl_sfall-mods.int (to pick up items (default key is G), settings in sfall-mods.ini)

    - While using the g hotkey, I had error messages (probably missing text?). Not sure what is missing, but whenever I pick up an item I get an “error” message in the text window.
    It's probably one the following in gl_sfall-mods.int
    display_msg(message_str_game(3, 8000));
    display_msg(sprintf(message_str_game(3, 8002), obj_name(pickupItem)));
    Whatever that refers too seems to be missing (btw, I'm still using MM_2.47.4.1_full, so I may be outdated).

    - And the highlight LoS function has a peculiar issue. It can't detect the “Lavender Dream” when it's in the north corner of the “hole”: http://www.filedropper.com/losfail (one is showing the book, the other that the corner is blocked). In this position the LoS function can't highlight the book (i.e. LoS blocked). This is probably a map error, though @MIB88 (i.e. the book is lying in a corner the player can't enter, i.e. prevented by “blockers”. Can be picked up, though.).
    If you want to reproduce (the book spawns when entering the map the first time, and then its a random spawn place. Not sure if manipulation is possible (I tried it about 10 times during the day, then I switched to midnight and had it on the first try (probably luck, though).)
    P.S. These are the locations in Jorner's guide:
    • In the graveyard, just east of the church.
    • In the outhouse north of the Hole.
    • Behind a wall just southwest of the car behind Metzger's.
    • Beside a barrel south of the graveyard.
    And it does not list the position: “In the north corner of the Hole building”. Has this location been added by MM? Also I did not trigger “Behind a wall just southwest of the car behind Metzger's.” (chance?) but I did get “Underneath Vic's window” repeatedly.
    Perhaps this is a MM adjustment of the spawn?

    - I meant this Hr_mainmenu (http://www.filedropper.com/hrmainmenu: I took this from a previous MM version, it's Necropolis from Fo1). Not a big deal, but I liked that MM had its own unique mainmenu. Made it a bit more distinct.

    Disclaimer: I'm still using the old installer: MM_2.47.4.1_full. (I don't want to go through a new install/set up atm. Anyway, some of the things I mentioned may already be fixed/not an issue anymore.)
    This is probably an issue caused by installing Fallout too often. I had the same issue when I tried to install the new MM over my old version. All my “old savegames” worked, but "new games" didn't (same error message). I messed around a little (fresh install etc.). And it wouldn't change. What solved it eventually was “rebooting after deinstalling”, “registry cleaner” and “installing in a different install path” (as suggested in the readme of MM). Not sure what the issue exactly is, but one or all three of the above should fix it. I'm currently using “MM_2.47.4.1_full” under a new install path and it works fine. I have not tested if save-games carry over.
  11. _Pyran_

    _Pyran_ Mildly Dipped

    Jan 31, 2017
    • Original MM by MIB, modifies master.dat (packing files).
    • Version 2.47.4.x - does not spoil the master.dat, not packs anything, all changes are presented in patch000.dat (No need to remove).
    • 2.47.4.x - Only a clean installation, is permitted transfer\backup saves.

    • >>> gl_ammomod.int - the ability to switch circuit damage (glovz, yamm, crafty), without using modified proto files (But this is not necessary).
    • >>> G key text error - fixed, line translated .
    • >>> HR_Mainmenu - Image "Necropolis" returned :)
    MM link updated.
    Last edited: Jan 9, 2020
    • [Rad] [Rad] x 1
  12. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    And the fixes continue. For anyone keeping track...

    I cannot replicate this.

    Yes, I have also found this bug. Still trying to figure out what is happening here.

    You are rewarded by getting to keep what you looted and by continuing to be able to become one of the Cold Hearts. :P


    Are these elements from the RP?

    I will take a look at this.
  13. Muttie

    Muttie Still Mildly Glowing

    Oct 9, 2017
    She loots her own corpse (as all NPCs do in MM), removing the knife from the corpse may do it (EDIT: not as immersive, though, i.e. she did stab herself). Btw, her (the ghost's) "barter" isn't disabled.
    Last edited: Nov 28, 2019
  14. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    Thanks, @Muttie .

    I could either disable the loot bodies script on that map, or I could just remove the knife from the corpse and set it to the side. I mean, it would make sense either way as to the location of the knife. She could have stabbed herself and left it in until she died (and therefore it is in her inventory). Or, she could have stabbed herself and pulled it out (leaving it to the side).

    I'll disable barter, though.

    Edit: The body has a rock and healing powder in the inventory. No knife. The knife is already off to the side. My guess is that maybe she is picking up the knife when the player goes to kill the rats.

    Edit 2: The story so far... for anyone who is interested...

    Changes/Fixes made since version 2.47.4:
    -Numerous dialog and grammar fixes
    -Minor corrections to various maps (especially with regards to walking through objects)
    -Added SCAR (Skilldex Color Asthetic Redux) mod from @Kamos5
    -Removed some more instances where killed enemies had two sets of armor (including the Bridgekeeper, who will not produce a regular robe when killed)
    -Added a number of fixes/cleaned up code from the RP
    -Corrected a number of scripts which had incorrect/missing variables regarding Sexpert, Gigolo and Virgin (Thanks to @Muttie )
    -Fixed Modoc farm trapdoor in event explosives are used
    -Unwashed villagers no longer generate armor when killed
    -added more character enhancements from @Endocore
    -added moving turrets to Vault City
    -Myron has the proper talking head when wearing advanced power armors
    -Human Lenny should no longer be referred to as a ghoul when entering Vault City
    -Made a number of corrections to dialog for Private Dobbs
    -Fixed bug causing crash when asking Private Dobbs to rejoin your party
    -Removed potential bug regarding waiting for Cassidy, Sulik, and Klint
    -Removed potential bug regarding an unimplemented perk and related items
    -Unused items should no longer be spawned by geckos killed in random encounters
    -Marcus no longer becomes unresponsive after speaking with him about mutant sterility
    -Meris can once again be gained for your party
    -Corrected party member backgrounds for some locations
    -No longer possible to barter with the ghost at the Umbra Tribe
    -Toned down (just a little) the enemies of Vault 14's leaders
    -Skynet's floats will no longer appear when it is not with your party
    Last edited: Nov 30, 2019
    • [Rad] [Rad] x 1
  15. FalloutBruhMoments

    FalloutBruhMoments First time out of the vault

    Nov 8, 2019
    The link to the latest version (2.47.4) gives "permission denied" when you click it.
    therefore unable to download it.
  16. _Pyran_

    _Pyran_ Mildly Dipped

    Jan 31, 2017
    2.47.4 by MIB - fine, but sometimes issues a message "Permission Denied." Just, try again. manual & installer - fine
  17. neptunehs

    neptunehs First time out of the vault

    Nov 1, 2019
    From The Nearly Ultimate Fallout 2 Guide:
    These doors not locked.
    But "disabled" bots will not attack is RP's elements,sorry.

    I don't know if I misremember,but no drops when super mutants was killed by eletrical weapons with crit attack(In highest violence,by the way,in my config,weapon drops mod not open).
    Last edited: Dec 3, 2019
  18. Muttie

    Muttie Still Mildly Glowing

    Oct 9, 2017
    I did a quick-test: I see her ghost picking up stuff when I spawn it (i.e. waiting until midnight next to the body). I can't loot the body myself, no hand-icon (although the ghost seems to be able to). Anyway, she ends up with a Knife (unless I pick it up first), 2 Healing Powder (can be seen via barter and one may be from the body unless she starts with two) and a Rock (can only be seen when stealing from her). So it seems her ghost loots the body possibly, but definitely picks up the knife when spawned in. Perhaps it's best if the ghost has no items (to cancel stealing), disable loot bodies script, and allow the player-dude to loot the body (or remove the items from the body otherwise, i.e. if I can't loot the body it doesn't need to have any items on it).
  19. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    The ghost has no inventory on her. The rock and the two healing powders were from the dead body.
    So, I changed a few things:
    I modified the script for NPCs looting bodies to not occur on that map.
    I modified the dead critter on the ground, so she could be looted by the player character.
    I modified the ghost critter so it could not be bartered with.

    Something is weird, though. The script of the ghost already has a section that is supposed to prevent stealing (i.e., pickup_p_proc). What is there should prevent the stealing window from opening up. I wonder why it isn't working? Or, have I misunderstood what this code is for or doing?
  20. NovaRain

    NovaRain Casual Modder Modder Moderator

    Mar 10, 2007
    pickup_p_proc runs when the player is caught stealing from the critter (steal check failed). It does not prevent the player from using the skill.
    If you want to prevent the player from using Steal on the ghost, you can set the "no steal" critter flag for it (if the ghost uses its own unique proto) or call "script_overrides" in use_skill_on_p_proc of its script (prevent using any skill, since it's a ghost) or via USESKILL hook from sfall.