Fallout 2 Restoration Project 1.2 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Jun 9, 2008.

Thread Status:
Not open for further replies.
  1. McRae

    McRae For sale: clown shoes, never worn Orderite

    Dec 9, 2007
    I swear I saw this guy... but I admit it's been a little while without playing the RP... I might have seen a bug.
  2. Behemot

    Behemot First time out of the vault

    Jul 30, 2008
    I've encountered one problem...if I stay nearby hubologist in NCR (for example on street) when bomb I've put in his pocket explode, game crashes. Just like without Restoration mod. When I go to another part of NCR, wait 10 minutes and return back, hubologist is dead, but status in PipBoy doesn't change !

    I find it out now, after some game progress and I don't have old save...so I cannot do another job for Merk, but what's worse, I cannot buy holodisk with fake Vault 13 location and cannot try supermutant serum on Lenny in ring :lol: :cry:

    I am running full install on Win 98, Restoration 1.2 with all addons.
  3. vibalist

    vibalist First time out of the vault

    Apr 27, 2008
    I tried to do a search on this and nothing came up, so hopefully this hasn't been asked a million times before.

    When I go to Vic's shop in Klamath, the door to the back room where you find the radio is locked. Is this something your mod does? and if so, how the hell do I open it without having a high lockpick skill? :crazy: (bashing and shooting it doesn't help, and Vic doesn't say anything about this when I talk to him in the Den)
  4. Behemot

    Behemot First time out of the vault

    Jul 30, 2008
    Killap already helped me by e-mail...thank a lot Killap !
    You did a big piece of work on F2, but still...there are some bugs, that drives me crazy personally...

    Like this bug with bomb - if you plant bomb in somebody's pocket and leave the area, it detonates right when you are leaving; but after you came back or when you are leaving again and the person is dead, game crashes. Or when you want to save game after you go back after detonation, it crashes too. Looks like it don't save HP changes for that persons or what and than there is conflict when they are dead but shouldn't...
    Another bug is with Cassidy - another NPC's are fine - if the game crashes, his combat disposition (custom) change back to default...he is still coming somewhere out in combat than and it is really annoying to still change it... :|
    One bug is in Mordino's cassino, 2nd floor - it often crashes in combat, looks like error with atack (bad HP checksum ? no idea)...I don't have any other info about that however...

    vibalist: I was pretty surprised with that door, too, but I've invested to lockpick a bit and I've opened it for first approach...if I remember, I had lockpick arround 30...? Just invest to it, you need it for Toxic caves elevator anyway... :mrgreen: Or save and try it...if you are not able to open it with about 50 attempts, invest 5 to 10 % to lockpick :twisted:
  5. vibalist

    vibalist First time out of the vault

    Apr 27, 2008
    Alright, thank you. I guess that will have to do. It would have been nice to have an alternative option, though, like asking Vic for a key.

    And by the way, I thought you needed a high repair skill to make the elevator in the caves work...? As opposed to lockpick, I mean.
  6. Behemot

    Behemot First time out of the vault

    Jul 30, 2008
    You can gain some repair skill reading books during game (up to 91/93, not sure), but lockpick no...well, I haven't been there yet this time, but what I remember, I needed high lockpick skill (50+ and Electronic Lockpick MKII) rather than repair. Think Vic is able to repair it...

    And...yes, I was expecting Vic has a key for his house and has nothing :lol: And he has your first rifle there :D
  7. Morticia

    Morticia Look, Ma! Two Heads!

    Mar 9, 2008

    You need repair skill to get the generator running, then electronic lockpicks to open the elevator. Those are gameplay questions, and there is another thread for them. Vic having a key to that door might be a good suggestion, though Metzger probably would have it. As Behemot says, you don't need really high lockpicking, just keep trying over and over, and reload a saved game if you jam the lock with lack of skill.

    @Behemot (and others),

    I don't know if this is helpful or not, but the crashes from planting a bomb on someone can be avoided by saving before you do it, (not in combat, of course,) then exiting the game and restarting. Load that fresh save and it never crashes. So much for smooth and continuous gameplay though. :(

    Leads me to believe the game keeps some kind of running data cache that gets filled up the longer you play, and When it tries to calculate the explosion it overloads.

    "Baldur's Gate" (not the same game engine, I know) had an actual cache file that would fill up the same way. The longer you played, the slower the game ran, until it got so choppy and jumpy it was unplayable. Manually deleting that file would fix it.

    Someone like Timeslip, who knew more about how the game engine works might figure out how this cache works (if it even exists) and a way to manage it that fixes another long known Fallout bug.
  8. wrzask

    wrzask First time out of the vault

    Jul 25, 2008
    Hi there,

    Now I have two bugs to report.

    1. The game crashes (technically - hangs and starts eating all the memory, until it dies) in the Vault City courtyard, after I leave Marcus there, if Marcus is wearing armor (from the Abbey). When I leave Marcus just before the Vault City inner gate, all is fine, but when he's left anywhere in the outer area, the game crashes.

    This didn't happen when Marcus wasn't wearing his armor. And appears to happen only there (I didn't check everything, but still it's the only place I've hitten this bug).

    2. In the Enclave, the entry hall (foyer) elevator allows only to go to the "Entry hall" or "Vertibird unloading pod". It doesn't matter whether I have used the tanker or a vertibird to travel to the Enclave - I'm unable to get to any other level than these two forementioned.

    Or maybe I'm just clueless on this one as well? There's another elevator in the Guard Barracks, but I can't get to it. Any hints? :)

    If it is a bug, it could have been triggered by my completion (or a near-completion) of the vertibird flight option. I've got the yellow reactor card, figured that I need to redirect the radar.. Anyway, this stops me from ending the game.
  9. Behemot

    Behemot First time out of the vault

    Jul 30, 2008
    Wow man thanks...gonna try this now :lol:

    Can be that problem with Cassidy related to this ? I'll try it and report than...

    ADD// planting Cordex to Jules'es pocket looks functionable with exiting game, gonna try AHS-9, there I've encountered the problem...
  10. Morticia

    Morticia Look, Ma! Two Heads!

    Mar 9, 2008

    The lift only goes between the unloading pad and entry, but there is a stairway behind it that will take you lower.
  11. clones

    clones First time out of the vault

    Jul 7, 2008
    No one knowe??
    My char takes marichuana and get (petc and dur = 10) on fiew days (about 8)
    Next stats go down perc, agl and dur on about 3days...
    but next stats go up to max (i check one month later) and dontgo down??
    it is a bug or not?
  12. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    You can also blow the door off the hinges with explosives (bomb, molotov cocktail, etc) So you do have options here.

    I'm pretty certain that the marijuana is bugged since I have gotten reports about this before. I will look into it.
  13. vibalist

    vibalist First time out of the vault

    Apr 27, 2008
    I took this quote from one of the older threads relating to unofficial Fallout mods. The reason is because I'm having some issues that was brought up a while ago in one of those threads. When I enter the Ghost Farm *after* doing the slag quest of delivering the message to Modoc, my game freezes. I'm wondering if you know what's causing this, Killap?

    Thanks in advance.
  14. Morticia

    Morticia Look, Ma! Two Heads!

    Mar 9, 2008
    According to the wiki bug list, no one has reported any problems with the Ghost Farm in RP. The thread that you took the quote from would probably be a better place to look for the solution. What was the answer there?
  15. vibalist

    vibalist First time out of the vault

    Apr 27, 2008
    Pretty much the same as you gave me. That it hasn't really been experienced before. But then again, if someone else had the same problem a while ago it might be relevant.

    As for the thread, it's been locked now, so I thought I might as well bring it here.

    Anyway, it's not that much of an issue, since the ghost farm, as far as I know, is not a place you need to visit after solving the slag quest and the one with Jonny, so I'm going to be fine here. Just thought I'd bring it up.
  16. zenitfan4life

    zenitfan4life First time out of the vault

    May 27, 2008
    Hello guys, I have some issues to report. They are not really big problems, but it's wouldn't hurt to fix them for RP 1.3

    My character loses the bonus move (the yellow ones) if I re-load before I used them. Also, even if I use them, save the game, and then load it, the yellow bonus move dots still appears on the screen, although I've already used them. This is really annoying especially if you're playing HtH or melee character.

    In Modoc, I had 3 ropes in my inventory, and I used it on the well by using the right-click backpack all ropes disappear! I think the engine doesn't check the amount of ropes in your inventory and uses them all. Not sure if this happens in other places where you need to use the rope (i.e. Sulik's village). This can be avoided by putting one of the ropes in the action window, and manually clicking on the well though.

    I accepted Farrell's quest to help him find the golden watch. When I killed the mole rat, found it, and approached him, he thanked me, told me that he and Cornelius can be friends again, I got my 1,500xp, but the watch remained in my inventory. In addition, the dialog option about his safe remained, and he kept getting pissed about it. And he stays pissed at you even after you help him find the golden watch.

    When I came to Modoc, Lumpy was standing inside Skeeter's house instead of his own, the one above Skeeter's . Sometimes when I re-load, he disappears from the map completely, which sucks.

    When I ask Skeeter to put a scope on my hunting riffle, I end up with a scoped hunting riffle in my inventory in addition to my original hunting riffle! I also checked my weight and it increased by 12 pounds. Basically, this is just like the trick when you can drop the spear in Arroyo and the bridge guy still makes you a sharpened one, except it happens automatically here.

    Council McClure is bugged. Every time you tell him that you have a plan to optimize the Gecko plant, he also offers to take a look at the economic data disc, and you keep getting 750XP every time you mention it to him. You can get as much as XP as you want this way. I think that the variable for completion of this quest is never canceled out and he is caught in a loop. Maybe removing the option to keep telling him about optimizing the plant after the first time you get his permission to access the Vault's files should solve this bug.

    If you act mean towards Fred when he wants to reward you (telling him he looks like crap, not listening to him and telling him to just give you your money) he gives you $500 instead of his normal reward, like he's suppose to. However, the dialog doesn't end, and in addition, he gives you the normal reward on top of the $500 (the $2000, bunch of batteries and a grenade). I think a loop is messed up here. So much for being mean!

    Some slavers and the dog in Metzerger's slaver camp are not spelled with capital letter first. (ie: You see:dog. You see:slaver)

    Hope this helps!
  17. Behemot

    Behemot First time out of the vault

    Jul 30, 2008
    I was in this part two days ago and he normaly took it...

    But I have one funny thing right now...I just wanted to try my new Bozar (stolen from that guy in NCR Bazar) and it looks like something is really fucked up. It does sound like shotgun ! And atack is very fast. It kills just like normal Bozar, but that sound...
    Plus I tried that with saving before dynamite killing and nothing...so I had to give 15 super stimps to AHS-9 and than give him Cordex to his desk...he died normally, uff. But Cassidy is fucking his combat control like normaly, after every game crash.

    Than it looks like some bugy things can be added to list on page 38 (don't know if there are there on next pages or no); it was still freezing to me in San Francisco if I just take off things that are on list and placed them to Brotherhood facility there; if I let them in New Reno with all my 9 Cat Paw's, Easter Egg, all my holodisks, that amulet from Gecko and Anna's diary (and Abbey computer card with me in inventory), it is OK...no more info, sorry...

    ADD// I didn't read full list of changes, but was stores in game changed, too ? Because I am afraid, that weapon stores didn't get many new weapons...for exmaple Red 888 guns still have no Gatling Vindicator, Gauss rifle (no ammo)...NCR bazar do not have Gatling Avenger and ammo I need, too (gauss and other). Without Restoration 1.2 they ussualy had new things every my visit :?
  18. Kanhef

    Kanhef Vault Dweller

    Sep 2, 2007
    You picked up the bag in Modoc, right? It's a known bug that the game has trouble removing anything below it in your inventory. That's why you still have the watch, rifle, disc, etc. The best solution would be to remove the bag from the game entirely.
  19. Josan12

    Josan12 Vault Senior Citizen

    Oct 15, 2007
    Agreed. Does anyone ever use that thing anyway?
  20. Glovz

    Glovz Vault Dweller

    Sep 16, 2005
    If the bag does not give the player any sort of carrying bonus (ex. can carry x items more or handle x more weight) then I agree, get rid of it.

    Plus we have already established two of the most impotant things:
    1- it's bugged!!!
    2- it's not going to be fixed
Thread Status:
Not open for further replies.